diff --git a/main/postmarketos-base/APKBUILD b/main/postmarketos-base/APKBUILD
index c96b2148b21fc13457fa861f35022d668d50afc6..a47724f33801c11b8976af8553737e0f68a14390 100644
--- a/main/postmarketos-base/APKBUILD
+++ b/main/postmarketos-base/APKBUILD
@@ -1,6 +1,6 @@
 pkgname=postmarketos-base
 pkgver=36
-pkgrel=2
+pkgrel=3
 pkgdesc="Meta package for minimal postmarketOS base"
 url="https://postmarketos.org"
 arch="noarch"
@@ -70,7 +70,7 @@ _source755="
 	etc/init.d/deferred-initcalls
 	etc/init.d/swapfile
 	etc/init.d/tmpfs
-	sbin/swapfile
+	usr/bin/swapfile
 	usr/lib/firmwareload.sh
 	"
 
@@ -188,8 +188,8 @@ de4d8f258cb2ce654be15abe0188caa6ca9cc163fd45350f2025e7e9d043878e3f1202ef9033b1b1
 f5c6913040a0448c346fdd0b5dbea865a3ac92ac1a21646d32753e6521642a27b061c314f10a14b612b78aa6bc8d3209e51f7ced95c478f1be55e478ff04067b  rootfs-usr-lib-udev-rules.d-90-feedbackd-regulator-haptic.rules
 d89a7e4b9d601431c62c11f83c9c72fdb90384d9100ee5fc4aff25dda0836fd3bf9e48c0536615be791374459eb8fbaf36d27358d4402ce768a9b9a32bed4f93  rootfs-usr-share-mkinitfs-files-postmarketos-base.files
 3c049c5e6fbe3079ac333f416cbaf5d3890a7941b79d68741bfc861ee94358fba6d8b72614fe99ab84563f9208613037c6702a7d0fc5a6dfa9d0518b5a13b0cb  rootfs-etc-init.d-deferred-initcalls
-f5cc0f1265955d2646e5f099dd4b5d4c287945bfc18c16044db57670d456f55c678fc11cc59e6dab3fa340832ce869d516302a3a35c13518539ed0cedca51819  rootfs-etc-init.d-swapfile
+42d6bce78b6e3c118dcbd9228b138661a05f8f321f17457e8df8f2398c0b780399d8d056f0a7c50d91557ac8698ab37dde61ec1a13fd69a7b3faad092f126580  rootfs-etc-init.d-swapfile
 0cd9a0b8490028d854b65d0648aaf84e4703921b8b7797517dd65ffaa1ec9e225487007dcccd42c249a9f2470e5adacf95760536c9508138b14de7252de38473  rootfs-etc-init.d-tmpfs
-23df2632e8ef372dccd6b9abac61441dd0ee447ccc7428fba495e28f1b697ebc415f7580dbb9a39d22d162a175d7264b47bdf9f66552347e35d9d0bb7828647d  rootfs-sbin-swapfile
+23df2632e8ef372dccd6b9abac61441dd0ee447ccc7428fba495e28f1b697ebc415f7580dbb9a39d22d162a175d7264b47bdf9f66552347e35d9d0bb7828647d  rootfs-usr-bin-swapfile
 72c73bd67bfe2a659c469781e4def038a9b2482e014c0304150fbc25c5325fc7a36b288de76447837741bb9a828eb1db6df0d33b41cf67c7a25bb27b03777b1f  rootfs-usr-lib-firmwareload.sh
 "
diff --git a/main/postmarketos-base/rootfs-etc-init.d-swapfile b/main/postmarketos-base/rootfs-etc-init.d-swapfile
index 458ebfe67bf39b5f9af348a4eec8523ca5b0d9ab..64a0db054f1cf9933a2cc857b9d3a02f93ce9455 100644
--- a/main/postmarketos-base/rootfs-etc-init.d-swapfile
+++ b/main/postmarketos-base/rootfs-etc-init.d-swapfile
@@ -8,14 +8,14 @@ depend()
 start()
 {
 	ebegin "Activating swap file"
-	/sbin/swapfile
+	swapfile
 	eend $?
 }
 
 stop()
 {
 	ebegin "Deactivating swap file"
-	/sbin/swapoff -a >/dev/null
+	swapoff -a >/dev/null
 	eend $?
 }
 
diff --git a/main/postmarketos-base/rootfs-sbin-swapfile b/main/postmarketos-base/rootfs-usr-bin-swapfile
similarity index 100%
rename from main/postmarketos-base/rootfs-sbin-swapfile
rename to main/postmarketos-base/rootfs-usr-bin-swapfile