diff --git a/main/postmarketos-splash/APKBUILD b/main/postmarketos-splash/APKBUILD
index bf39c6c914923ffc83692fa243a39869818dae6f..c9faf7c0a75881776fd506d5742793300aaa528d 100644
--- a/main/postmarketos-splash/APKBUILD
+++ b/main/postmarketos-splash/APKBUILD
@@ -1,5 +1,5 @@
 pkgname=postmarketos-splash
-pkgver=2
+pkgver=3
 pkgrel=0
 pkgdesc="Splash screen for postmarketOS"
 url="https://gitlab.com/postmarketos"
@@ -20,6 +20,6 @@ package() {
 		"$pkgdir"/usr/share/fonts/ttf-pmos/pmos.ttf
 }
 
-sha512sums="580c96501137bbd606ee0a946ac057777a1f07e780d84e40bfb7909db09d2704d308373baea6e25fde50866918e169070c0842893732c5fd339cc1f0c329f85a  make-splash.py
+sha512sums="e731405d1c3eae265058d2a9f32286b36aa614d26fa86b915bef006b157008fb83c22031d1cffac5034d50d92cdf1d39f4148b46d249fc5db0db67a3a1bdfb7d  make-splash.py
 cdde481bf7c68840515b839d974dd1dddfb37551a2939780e13dce11331f7d1964043de48f8902a30372e9fc9f042bd4ee133e2098694739c452a76b70e97111  config.ini
 81e5df350bf7f435ab5480f7028fc3cabf5a947fa0dff1ed219f6d9ac18a1250f5114887a9f5f270cc699af48cd77f23d14a84578ac8d2d0f3a3e90ec3211c45  pmos.ttf"
diff --git a/main/postmarketos-splash/make-splash.py b/main/postmarketos-splash/make-splash.py
index 5695203af0ba5fddccb9d165b40c02d5ea185cba..1bc76155698b1ce927da88d72ed1e0dc5ab1bbef 100644
--- a/main/postmarketos-splash/make-splash.py
+++ b/main/postmarketos-splash/make-splash.py
@@ -62,6 +62,9 @@ def make_splash(width, height, filename, landscape=False, text="", config_file=N
 
     del draw
 
+    if landscape:
+        im = im.transpose(Image.ROTATE_270)
+
     if raw:
         data = list(im.getdata())  # [(R,G,B), (R,G,B)]
         flat = list(itertools.chain.from_iterable(data))  # [R, G, B, R, G, B]