From 0818a37457026f0124e413f70aaf88c1dfee7a29 Mon Sep 17 00:00:00 2001
From: Oliver Smith <ollieparanoid@postmarketos.org>
Date: Sun, 18 Apr 2021 20:04:30 +0200
Subject: [PATCH] main/gcc6: fix missing includes with newer isl

Fix the following error:
gcc/graphite-isl-ast-to-gimple.c:114:7: error: 'isl_id_free' was not declared in this scope; did you mean 'isl_aff_free'?

Found the patch here:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86724

Note that Alpine edge has isl 0.18 and not 0.20, but the error message
is the same and the patch works.
[ci:skip-vercheck]: no need to rebuild existing packages for this

Related: https://builds.sr.ht/~postmarketos/job/489478
---
 .../0014-fix-missing-includes-isl-0.20.patch  | 54 +++++++++++++++++++
 main/gcc6/APKBUILD                            |  5 +-
 2 files changed, 58 insertions(+), 1 deletion(-)
 create mode 100644 main/gcc6/0014-fix-missing-includes-isl-0.20.patch

diff --git a/main/gcc6/0014-fix-missing-includes-isl-0.20.patch b/main/gcc6/0014-fix-missing-includes-isl-0.20.patch
new file mode 100644
index 00000000000..36d7893faee
--- /dev/null
+++ b/main/gcc6/0014-fix-missing-includes-isl-0.20.patch
@@ -0,0 +1,54 @@
+From e31e485e7b453cd6cddf5a0a137b9c98bc797ea5 Mon Sep 17 00:00:00 2001
+From: Matthias Klose <doko@ubuntu.com>
+Date: Tue, 14 Aug 2018 15:15:39 +0000
+Subject: [PATCH] backport: re PR tree-optimization/86724 (Compilation error
+ with new isl 0.20 (missing includes))
+
+2018-08-14  Matthias Klose  <doko@ubuntu.com>
+
+        Backport from mainline
+        2018-08-01  Richard Biener  <rguenther@suse.de>
+
+        PR bootstrap/86724
+        * graphite.h: Include isl/id.h and isl/space.h to allow build
+        with ISL 0.20.
+
+From-SVN: r263539
+---
+ gcc/ChangeLog  | 9 +++++++++
+ gcc/graphite.h | 2 ++
+ 2 files changed, 11 insertions(+)
+
+diff --git a/gcc/ChangeLog b/gcc/ChangeLog
+index c7f61504757..4aaaeac328a 100644
+--- a/gcc/ChangeLog
++++ b/gcc/ChangeLog
+@@ -1,3 +1,12 @@
++2018-08-14  Matthias Klose  <doko@ubuntu.com>
++
++	Backport from mainline
++	2018-08-01  Richard Biener  <rguenther@suse.de>
++
++	PR bootstrap/86724
++	* graphite.h: Include isl/id.h and isl/space.h to allow build
++	with ISL 0.20.
++
+ 2018-08-10  Segher Boessenkool  <segher@kernel.crashing.org>
+ 
+ 	Backport from mainline
+diff --git a/gcc/graphite.h b/gcc/graphite.h
+index 578fa1a6d98..431d0ed0a5e 100644
+--- a/gcc/graphite.h
++++ b/gcc/graphite.h
+@@ -40,6 +40,8 @@ along with GCC; see the file COPYING3.  If not see
+ #ifdef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
+ /* isl 0.15 or later.  */
+ #include <isl/schedule_node.h>
++#include <isl/id.h>
++#include <isl/space.h>
+ 
+ #else
+ /* isl 0.14 or 0.13.  */
+-- 
+2.27.0
+
diff --git a/main/gcc6/APKBUILD b/main/gcc6/APKBUILD
index 5a89ed8b0d1..29affbea7c4 100644
--- a/main/gcc6/APKBUILD
+++ b/main/gcc6/APKBUILD
@@ -198,6 +198,8 @@ source="http://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$_pkgver}/gcc-${_pkg
 	0011-i386-Update-mfunction-return-for-return-with-pop.patch
 	0012-i386-Add-TARGET_INDIRECT_BRANCH_REGISTER.patch
 	0013-i386-Don-t-generate-alias-for-function-return-thunk.patch
+
+	0014-fix-missing-includes-isl-0.20.patch
 	"
 
 # we build out-of-tree
@@ -470,4 +472,5 @@ baa27a4b912d8e27cd65a556b09cf45289a0e00e86dae3925f2923d1f3752080e80d80e159c996ef
 b7b59f3203bf53168de2170b91738cd456f6ae205b3fe5bf8aacbaa8cc5624dd09c941ad8f1071d1ab8ab4fb5f69068a4bc792c0486fdec1ee2eb9c83688bb78  0010-i386-Pass-INVALID_REGNUM-as-invalid-register-number.patch
 c53d4c5968865abb709ee8a9af9d57917d43ea3ba31ee8312f9e8f338e9b1b44babf5aa3414848da7267e5cf13a9261815eb9185dc153cbd41ee7ce5ea23d2d0  0011-i386-Update-mfunction-return-for-return-with-pop.patch
 955080ba3e42cfe2f604e5dcef46aa6fca7c899c7808398947af655ff3b7954e30807ef85246986a5cc7db36dbc870db151e9fa8d8bc967b89ea56efdf64614c  0012-i386-Add-TARGET_INDIRECT_BRANCH_REGISTER.patch
-3aae3a9cef8e8afe5a5433db8d9f410e1a2882481af01bb1d33232f987dbb74d7780c32be70b868bb391b3601b65ed3a16d777afea946f5eeaff72aa1e7fa3a9  0013-i386-Don-t-generate-alias-for-function-return-thunk.patch"
+3aae3a9cef8e8afe5a5433db8d9f410e1a2882481af01bb1d33232f987dbb74d7780c32be70b868bb391b3601b65ed3a16d777afea946f5eeaff72aa1e7fa3a9  0013-i386-Don-t-generate-alias-for-function-return-thunk.patch
+e926a9c43eb774f788bbba168f4363fe37ccf2d57531540a6bccb3e16a487aa42e85dfdfc4fb0a3370eb890d100cd1e93279efb2fc9af73b09e3225511afa132  0014-fix-missing-includes-isl-0.20.patch"
-- 
GitLab