diff --git a/device/linux-samsung-jflte/00_fix_return_address.patch b/device/linux-samsung-jflte/00_fix_return_address.patch
deleted file mode 100644
index 287d1f707fa8d7daad8caadbb720d5c1091af0cf..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/00_fix_return_address.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
-From: Behan Webster <behanw@converseincode.com>
-Date: Wed, 24 Sep 2014 01:06:46 +0100
-Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
-
-With compilers which follow the C99 standard (like modern versions of gcc and
-clang), "extern inline" does the wrong thing (emits code for an externally
-linkable version of the inline function). In this case using static inline
-and removing the NULL version of return_address in return_address.c does
-the right thing.
-
-Signed-off-by: Behan Webster <behanw@converseincode.com>
-Reviewed-by: Mark Charlebois <charlebm@gmail.com>
-Acked-by: Steven Rostedt <rostedt@goodmis.org>
-Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
----
- arch/arm/include/asm/ftrace.h    | 2 +-
- arch/arm/kernel/return_address.c | 5 -----
- 2 files changed, 1 insertion(+), 6 deletions(-)
-
-diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
-index 39eb16b0066f2..bfe2a2f5a644e 100644
---- a/arch/arm/include/asm/ftrace.h
-+++ b/arch/arm/include/asm/ftrace.h
-@@ -45,7 +45,7 @@ void *return_address(unsigned int);
- 
- #else
- 
--extern inline void *return_address(unsigned int level)
-+static inline void *return_address(unsigned int level)
- {
- 	return NULL;
- }
-diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
-index fafedd86885dd..f6aa84d5b93c9 100644
---- a/arch/arm/kernel/return_address.c
-+++ b/arch/arm/kernel/return_address.c
-@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
- #warning "TODO: return_address should use unwind tables"
- #endif
- 
--void *return_address(unsigned int level)
--{
--	return NULL;
--}
--
- #endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
- 
- EXPORT_SYMBOL_GPL(return_address);
diff --git a/device/linux-samsung-jflte/01_msm-fix-perf_trace_counters.patch b/device/linux-samsung-jflte/01_msm-fix-perf_trace_counters.patch
deleted file mode 100644
index 97812bf4ecf6367025d77ffabbd581d46c8a15eb..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/01_msm-fix-perf_trace_counters.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From e41494c15d4df342854ac3d2940f5d6ac3158212 Mon Sep 17 00:00:00 2001
-From: Bryan Huntsman <bryanh@codeaurora.org>
-Date: Mon, 3 Jun 2013 18:48:08 -0700
-Subject: [PATCH] msm: fix in-tree compilation for perf_trace_counters
-
-In-tree compilation for arch/arm/mach-msm/perf_trace_counters.c was
-hitting this error:
-
-    In file included from arch/arm/mach-msm/perf_trace_counters.h:127:0,
-                     from arch/arm/mach-msm/perf_trace_counters.c:14:
-    include/trace/define_trace.h:79:43: fatal error: ./perf_trace_counters.h: No such file or directory
-
-Instructions for TRACE_INCLUDE_FILE in include/trace/define_trace.h say
-"the path is relative to define_trace.h, not the file including it".
-Fix in-tree compilation by making the path relative to define_trace.h.
-
-Signed-off-by: Bryan Huntsman <bryanh@codeaurora.org>
----
- arch/arm/mach-msm/perf_trace_counters.h | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/arch/arm/mach-msm/perf_trace_counters.h b/arch/arm/mach-msm/perf_trace_counters.h
-index ce7e336aa40d..8f77badf42ac 100644
---- a/arch/arm/mach-msm/perf_trace_counters.h
-+++ b/arch/arm/mach-msm/perf_trace_counters.h
-@@ -121,7 +121,6 @@ TRACE_EVENT(sched_switch_with_ctrs,
- 
- #endif
- #undef TRACE_INCLUDE_PATH
--#define TRACE_INCLUDE_PATH .
-+#define TRACE_INCLUDE_PATH ../../arch/arm/mach-msm
- #define TRACE_INCLUDE_FILE perf_trace_counters
- #include <trace/define_trace.h>
--
diff --git a/device/linux-samsung-jflte/02_gpu-msm-fix-gcc5-compile.patch b/device/linux-samsung-jflte/02_gpu-msm-fix-gcc5-compile.patch
deleted file mode 100644
index 91b17cd76b7a5fa7dc1dedcf4362edf71082101b..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/02_gpu-msm-fix-gcc5-compile.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-source:
-https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
-
-* These need to be static to avoid these errors:
-
-drivers/built-in.o: In function `.LANCHOR1':
-msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
-msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
-Makefile:877: recipe for target '.tmp_vmlinux1' failed
-make: *** [.tmp_vmlinux1] Error 1
-
-Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
-
---- a/drivers/gpu/msm/kgsl_iommu.c
-+++ b/drivers/gpu/msm/kgsl_iommu.c
-@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
-  *
-  * Return - int - number of commands.
-  */
--inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
-+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
- 						unsigned int *cmds)
- {
- 	struct kgsl_device *device = mmu->device;
-@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
-  *
-  * Return - int - number of commands.
-  */
--inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
-+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
- 					unsigned int *cmds)
- {
- 	struct kgsl_device *device = mmu->device;
diff --git a/device/linux-samsung-jflte/APKBUILD b/device/linux-samsung-jflte/APKBUILD
index 318741a6c306153478e1996a31a1f7765559a2f5..7191ff7c7a845236dd5bb7bf8aafe12940e4b558 100644
--- a/device/linux-samsung-jflte/APKBUILD
+++ b/device/linux-samsung-jflte/APKBUILD
@@ -3,7 +3,7 @@
 
 pkgname="linux-samsung-jflte"
 pkgver=3.4.112
-pkgrel=9
+pkgrel=10
 pkgdesc="Samsung Galaxy S4 kernel fork"
 arch="armv7"
 _carch="arm"
@@ -24,14 +24,10 @@ _config="config-${_flavor}.${arch}"
 source="
 	$pkgname-$_commit.tar.gz::https://github.com/LineageOS/${_repository}/archive/${_commit}.tar.gz
 	$_config
-	00_fix_return_address.patch
-	patch_lifebook_detect.patch
-	patch_fsp_detect.patch
-	02_gpu-msm-fix-gcc5-compile.patch
 	03-fix-video-argb-setting.patch
-	gpu_msm2_fix_compile.patch
 	gcc7-give-up-on-ilog2-const-optimizations.patch
 	gcc8-fix-put-user.patch
+	kernel-use-the-gnu89-standard-explicitly.patch
 "
 builddir="$srcdir/${_repository}-${_commit}"
 
@@ -68,11 +64,7 @@ package() {
 
 sha512sums="7b73724636d9fb2a19e6405b1c6acd9f08020cb2d8c51f209eab2dea90616f15e88e96cdea62931864a6a3f6d4ad1c0b0b9b5cae3e3a690c20f5a9dcb4b33d82  linux-samsung-jflte-e8d93e03563e42d7c762d4e9a87d77115102b301.tar.gz
 1984ab34f5ed15ef7d7c2fd18a8aba66d2d0a736938d2bcfaa618e8f85a5b25d0bf9d7240aedffae741c5f0495288c299e9bdbe050135e4c608113e23b9c5f92  config-samsung-jflte.armv7
-ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864  00_fix_return_address.patch
-36418ec3d31d1d6d9915afcf3d38d4549aeeb49c3825414b51b67db7a1ab6482f22d2723da3b258b671956809949278a51f6507df9b0052aec0bd0c59f56919a  patch_lifebook_detect.patch
-9da951bb0391564f33bdb0a97c339997eda7b15ec2f160da8af237cc87c233b8c3dcdc1a12759e04d69d075ae9b0afaf726101ef356e788d7f4606a03db2e248  patch_fsp_detect.patch
-7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881  02_gpu-msm-fix-gcc5-compile.patch
 e3083c260ed9c4fc0d83f43106700b6173876dbfae072f6e6696ac6785a4dc17771fbcb3e21601e04ed29a11bf0f7a2a09ad549375e0c34cea245c7f2e2bcbbd  03-fix-video-argb-setting.patch
-8ab0ed40315a22b046e6250df7ad0f7834ed011598c85d34500b6fc047f1c830b998f9fa3b1d5150d98ba34f3924cd62576e0e7d3d62fcc9832319eafc533c96  gpu_msm2_fix_compile.patch
 77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7  gcc7-give-up-on-ilog2-const-optimizations.patch
-197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967  gcc8-fix-put-user.patch"
+197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967  gcc8-fix-put-user.patch
+ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c  kernel-use-the-gnu89-standard-explicitly.patch"
diff --git a/device/linux-samsung-jflte/gpu_msm2_fix_compile.patch b/device/linux-samsung-jflte/gpu_msm2_fix_compile.patch
deleted file mode 100644
index bfdbf0837a3a881c02b06caa6fe2b1992cbb87bc..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/gpu_msm2_fix_compile.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-fix undefined reference to `kgsl_iommu_sync_lock'
-diff --git a/drivers/gpu/msm2/kgsl_iommu.c b/drivers/gpu/msm2/kgsl_iommu.c
-index 5ad557f..9450041 100644
---- a/drivers/gpu/msm2/kgsl_iommu.c
-+++ b/drivers/gpu/msm2/kgsl_iommu.c
-@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
-  *
-  * Return - int - number of commands.
-  */
--inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
-+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
- 						unsigned int *cmds)
- {
- 	struct kgsl_device *device = mmu->device;
-@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
-  *
-  * Return - int - number of commands.
-  */
--inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
-+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
- 					unsigned int *cmds)
- {
- 	struct kgsl_device *device = mmu->device;
diff --git a/device/linux-samsung-jflte/kernel-use-the-gnu89-standard-explicitly.patch b/device/linux-samsung-jflte/kernel-use-the-gnu89-standard-explicitly.patch
new file mode 120000
index 0000000000000000000000000000000000000000..a5f4de276037a4f48770b790adbd92649e666cf9
--- /dev/null
+++ b/device/linux-samsung-jflte/kernel-use-the-gnu89-standard-explicitly.patch
@@ -0,0 +1 @@
+../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
\ No newline at end of file
diff --git a/device/linux-samsung-jflte/patch_fsp_detect.patch b/device/linux-samsung-jflte/patch_fsp_detect.patch
deleted file mode 100644
index 86f3603895e370b0c806e872195d8adcb9e74f47..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/patch_fsp_detect.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix undefined reference to `fsp_detect'
-diff --git a/drivers/input/mouse/sentelic.h b/drivers/input/mouse/sentelic.h
-index 334de19..06fc881 100644
---- a/drivers/input/mouse/sentelic.h
-+++ b/drivers/input/mouse/sentelic.h
-@@ -115,7 +115,7 @@ struct fsp_data {
- extern int fsp_detect(struct psmouse *psmouse, bool set_properties);
- extern int fsp_init(struct psmouse *psmouse);
- #else
--inline int fsp_detect(struct psmouse *psmouse, bool set_properties)
-+static inline int fsp_detect(struct psmouse *psmouse, bool set_properties)
- {
- 	return -ENOSYS;
- }
diff --git a/device/linux-samsung-jflte/patch_lifebook_detect.patch b/device/linux-samsung-jflte/patch_lifebook_detect.patch
deleted file mode 100644
index 21036def79c7782a353e87df796ab4ecc9b0fe0e..0000000000000000000000000000000000000000
--- a/device/linux-samsung-jflte/patch_lifebook_detect.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-fix undefined reference to `lifebook_detect'
-diff --git a/drivers/input/mouse/lifebook.h b/drivers/input/mouse/lifebook.h
-index 4c4326c..e4c2453 100644
---- a/drivers/input/mouse/lifebook.h
-+++ b/drivers/input/mouse/lifebook.h
-@@ -19,7 +19,7 @@ int lifebook_init(struct psmouse *psmouse);
- inline void lifebook_module_init(void)
- {
- }
--inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
-+static inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
- {
- 	return -ENOSYS;
- }