From 0bf40d20e05548458e9c2752206b8337b3ca2f05 Mon Sep 17 00:00:00 2001
From: Robert Mader <robert.mader@collabora.com>
Date: Tue, 24 Sep 2024 20:15:00 +0200
Subject: [PATCH] linux-postmarketos-allwinner: restore CMA size (MR 5626)

This partly reverts the commit mentioned below. When disabling CMA
I thought that libcamera was the only user of it, which is only true
for userspace, though.
In fact CMA is used and often even required by the kernel for HW video
decoders, display engines and other hardware that might not have a
MMU.

Thus restore the previously established value.

Fixes: 196ece029 (linux-postmarketos-allwinner: enable CONFIG_UDMABUF (MR 5585))
[ci:skip-build]
---
 device/main/linux-postmarketos-allwinner/APKBUILD             | 2 +-
 device/main/linux-purism-librem5/APKBUILD                     | 4 ++--
 .../main/linux-purism-librem5/config-purism-librem5.aarch64   | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/device/main/linux-postmarketos-allwinner/APKBUILD b/device/main/linux-postmarketos-allwinner/APKBUILD
index 9bd918c0e7c..c6e2e4addb3 100644
--- a/device/main/linux-postmarketos-allwinner/APKBUILD
+++ b/device/main/linux-postmarketos-allwinner/APKBUILD
@@ -4,7 +4,7 @@ _flavor=postmarketos-allwinner
 _config="config-$_flavor.$CARCH"
 pkgname=linux-$_flavor
 pkgver=6.9.10_git20240721
-pkgrel=4
+pkgrel=5
 _tag="orange-pi-6.9-20240721-2345"
 pkgdesc="Kernel fork with Pine64 patches (megi's tree, slightly patched)"
 arch="aarch64 armv7"
diff --git a/device/main/linux-purism-librem5/APKBUILD b/device/main/linux-purism-librem5/APKBUILD
index cf9cc8d2583..61565fa29f7 100644
--- a/device/main/linux-purism-librem5/APKBUILD
+++ b/device/main/linux-purism-librem5/APKBUILD
@@ -4,7 +4,7 @@
 # Contributor: Clayton Craft <clayton@craftyguy.net>
 pkgname=linux-purism-librem5
 pkgver=6.6.40
-pkgrel=4
+pkgrel=5
 # NOTE: Don't forget to rebase the config! See prepare() for instructions.
 _purismrel=2
 # <kernel ver>.<purism kernel release>
@@ -90,5 +90,5 @@ package() {
 
 sha512sums="
 b16f6d040024d826d4ac7a33ad23137fafbf1ac7ac8adeef3fd80a80dc308b70cf572de6e4a451eb607b1d18ad58c03493108c7a1ff9b26fa2bd03a475002903  linux-purism-librem5-6.6.40pureos2.tar.gz
-e938306d7f2d91e7e0a279e25eb163fb8922b32b0eca7f96f96de2a06e3f51a7aa3e7cb9bc640a793e731a2e4580d86d84d9e4240c1fe76a505345940bf3133e  config-purism-librem5.aarch64
+8b1d9d3562f77e5492a27d850461f0fe2674b0522def624033e63b82d2c4c04c7d23b95a3447ac97dc1689494449683d8a545a2b4a9c7046017f89e2a62575fe  config-purism-librem5.aarch64
 "
diff --git a/device/main/linux-purism-librem5/config-purism-librem5.aarch64 b/device/main/linux-purism-librem5/config-purism-librem5.aarch64
index 85f8a71d37b..9ba76bc1698 100644
--- a/device/main/linux-purism-librem5/config-purism-librem5.aarch64
+++ b/device/main/linux-purism-librem5/config-purism-librem5.aarch64
@@ -7756,7 +7756,7 @@ CONFIG_DMA_CMA=y
 #
 # Default contiguous memory area size:
 #
-CONFIG_CMA_SIZE_MBYTES=0
+CONFIG_CMA_SIZE_MBYTES=320
 CONFIG_CMA_SIZE_SEL_MBYTES=y
 # CONFIG_CMA_SIZE_SEL_PERCENTAGE is not set
 # CONFIG_CMA_SIZE_SEL_MIN is not set
-- 
GitLab