diff --git a/main/swclock-offset/APKBUILD b/main/swclock-offset/APKBUILD
index 3073659dd586870f1e53c307ac381661765ebca9..f35fee1fd70da147adcf3f037011a9e4ddb45b09 100644
--- a/main/swclock-offset/APKBUILD
+++ b/main/swclock-offset/APKBUILD
@@ -1,19 +1,25 @@
 # Maintainer: Jakko <jahau@rocketmail.com>
 pkgname=swclock-offset
-pkgver=0.2.2
+pkgver=0.2.3
 pkgrel=0
 pkgdesc="Keep system time at an offset to a non-writable RTC"
 url="https://gitlab.com/postmarketOS/swclock-offset"
 arch="noarch"
 license="GPL-3.0-or-later"
 install="$pkgname.post-deinstall"
-subpackages="$pkgname-openrc"
+subpackages="$pkgname-openrc $pkgname-systemd"
 source="https://gitlab.com/postmarketOS/swclock-offset/-/archive/$pkgver/swclock-offset-$pkgver.tar.gz"
 options="!check" # No tests
 
 package() {
 	make DESTDIR="$pkgdir" install
-	make DESTDIR="$pkgdir" install_openrc
+}
+
+systemd() {
+	install="$subpkgname.post-install $subpkgname.pre-deinstall"
+	install_if="$pkgname=$pkgver-r$pkgrel systemd"
+
+	amove usr/lib/systemd
 }
 
 openrc() {
@@ -22,5 +28,5 @@ openrc() {
 }
 
 sha512sums="
-44f759dd2249ecce35f5baf9f432fd933e3a07b7ea425ea0f07314c7c3c94ce2d1ab7442d9bce8f03f5d436d15865ae3f4f63d3dc83cc6063af09986b7767e10  swclock-offset-0.2.2.tar.gz
+51c01dc1ffc4b1bd60b1c195fdf80e603580a943535901f2780e67dd7bdba709731cf854b7ec2af3cf68e31ca002db54814ada352eb9b93fb5c62a82a48961dd  swclock-offset-0.2.3.tar.gz
 "
diff --git a/main/swclock-offset/swclock-offset-systemd.post-install b/main/swclock-offset/swclock-offset-systemd.post-install
new file mode 100644
index 0000000000000000000000000000000000000000..9309c2c0019f948815579be22831f344fc031ece
--- /dev/null
+++ b/main/swclock-offset/swclock-offset-systemd.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+. /usr/lib/systemd/systemd-apk-macros.sh
+systemd_service_post_install system swclock-offset-boot.service
+systemd_service_post_install system swclock-offset-shutdown.service
diff --git a/main/swclock-offset/swclock-offset-systemd.pre-deinstall b/main/swclock-offset/swclock-offset-systemd.pre-deinstall
new file mode 100644
index 0000000000000000000000000000000000000000..d620575dd5cef7900baeb141222f45f49b24948f
--- /dev/null
+++ b/main/swclock-offset/swclock-offset-systemd.pre-deinstall
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+. /usr/lib/systemd/systemd-apk-macros.sh
+systemd_service_pre_deinstall system swclock-offset-boot.service
+systemd_service_pre_deinstall system swclock-offset-shutdown.service