From 1cf42e6db882b44ce248853a9adf6d7aec3b4aa6 Mon Sep 17 00:00:00 2001
From: Bradley <bard@disroot.org>
Date: Sat, 20 Jun 2020 04:27:27 -0500
Subject: [PATCH] linux-postmarketos-allwinner: enable f2fs module and fs
 compression (MR 1353)

[ci:skip-build] builds locally
---
 main/linux-postmarketos-allwinner/APKBUILD         |  4 ++--
 .../config-postmarketos-allwinner.aarch64          | 14 ++++++++++++--
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/main/linux-postmarketos-allwinner/APKBUILD b/main/linux-postmarketos-allwinner/APKBUILD
index fa02647edd0..010d6722dd3 100644
--- a/main/linux-postmarketos-allwinner/APKBUILD
+++ b/main/linux-postmarketos-allwinner/APKBUILD
@@ -2,7 +2,7 @@ _flavor=postmarketos-allwinner
 _config="config-$_flavor.$CARCH"
 pkgname=linux-$_flavor
 pkgver=5.6.0_git20200429
-pkgrel=4
+pkgrel=5
 arch="aarch64"
 pkgdesc="Kernel fork with Pine64 patches"
 url="https://gitlab.com/pine64-org/linux/"
@@ -65,6 +65,6 @@ dev() {
 		INSTALL_HDR_PATH="$subpkgdir"/usr
 }
 sha512sums="5c416e18ab0f798a18549cc63591d3eb29ea9e82ee9e48a34f2debfac590c516cecaa09fc1b51d0baedb330bd0f11c1e1f5868a3010591e73413b6d5397acfde  linux-postmarketos-allwinner-2a6074e53b019db8a4a63cb255bc29422db3fe19.tar.gz
-6a0ea9a21c36fb46573de09f85513ee875e7673db81759246aed030fae3a68415d7b561af3ce52ccfd66ff9097cf9652249a67021b6f1de95e9e89769599f9cf  config-postmarketos-allwinner.aarch64
+4110573d164bf89487d70dba4e31961ea310010d2912c0285c5dc4b660f066d3cec5115b8eb5d5969a4fae7be2c5937d8045cdc33f8bbc67002afb26c943942a  config-postmarketos-allwinner.aarch64
 8cdfb6d8a894e610c261446663dfbe34c01612a091fa029645e86913634de4394db0d1ab7dedb190052dff82330f0ddabe31860bbf7cd6fe0cdf23e37d0a6ca6  disable-power-save.patch
 5f403bb1e3e7528954adcba4429768ce26bf13382dc6325ced245babcfb5252d515bea812b9df16d0e5370c9d4e07b4e0267f4c750281faf3cb6ffb29906700c  touch-dts.patch"
diff --git a/main/linux-postmarketos-allwinner/config-postmarketos-allwinner.aarch64 b/main/linux-postmarketos-allwinner/config-postmarketos-allwinner.aarch64
index 36e893a9dd6..21952385020 100644
--- a/main/linux-postmarketos-allwinner/config-postmarketos-allwinner.aarch64
+++ b/main/linux-postmarketos-allwinner/config-postmarketos-allwinner.aarch64
@@ -4788,7 +4788,16 @@ CONFIG_BTRFS_FS_POSIX_ACL=y
 # CONFIG_BTRFS_ASSERT is not set
 # CONFIG_BTRFS_FS_REF_VERIFY is not set
 # CONFIG_NILFS2_FS is not set
-# CONFIG_F2FS_FS is not set
+CONFIG_F2FS_FS=m
+CONFIG_F2FS_STAT_FS=y
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_FS_POSIX_ACL=y
+# CONFIG_F2FS_FS_SECURITY is not set
+# CONFIG_F2FS_CHECK_FS is not set
+# CONFIG_F2FS_FAULT_INJECTION is not set
+CONFIG_F2FS_FS_COMPRESSION=y
+CONFIG_F2FS_FS_LZO=y
+CONFIG_F2FS_FS_LZ4=y
 # CONFIG_FS_DAX is not set
 CONFIG_FS_POSIX_ACL=y
 CONFIG_EXPORTFS=y
@@ -5118,7 +5127,7 @@ CONFIG_CRYPTO_HMAC=y
 # Digest
 #
 CONFIG_CRYPTO_CRC32C=y
-# CONFIG_CRYPTO_CRC32 is not set
+CONFIG_CRYPTO_CRC32=m
 CONFIG_CRYPTO_XXHASH=m
 CONFIG_CRYPTO_BLAKE2B=m
 # CONFIG_CRYPTO_BLAKE2S is not set
@@ -5276,6 +5285,7 @@ CONFIG_ZLIB_INFLATE=y
 CONFIG_ZLIB_DEFLATE=y
 CONFIG_LZO_COMPRESS=y
 CONFIG_LZO_DECOMPRESS=y
+CONFIG_LZ4_COMPRESS=y
 CONFIG_LZ4_DECOMPRESS=y
 CONFIG_ZSTD_COMPRESS=m
 CONFIG_ZSTD_DECOMPRESS=m
-- 
GitLab