diff --git a/packages/plasma-keyboard/APKBUILD b/packages/plasma-keyboard/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..af5cfa773c9907b0e8690fa2ce2cab35100316c0
--- /dev/null
+++ b/packages/plasma-keyboard/APKBUILD
@@ -0,0 +1,45 @@
+maintainer="team/kde <bribbers@disroot.org>"
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
+pkgname=plasma-keyboard
+pkgver=99999_git20250305
+pkgrel=0
+_commit="5412caeaba1b7d42b41f122432e74d684175a687"
+# armhf blocked by qt6-qtdeclarative -> ki18n
+arch="all !armhf"
+url="https://invent.kde.org/plasma/plasma-keyboard"
+pkgdesc="Virtual keyboard for Qt-based desktops"
+license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
+makedepends="
+	extra-cmake-modules
+	kcoreaddons-dev
+	ki18n-dev
+	qt6-qtbase-dev
+	qt6-qtvirtualkeyboard-dev
+	qt6-qtwayland-dev
+	samurai
+	wayland-dev
+	wayland-protocols
+	"
+_repo_url="https://invent.kde.org/plasma/plasma-keyboard.git"
+source="https://nightly.postmarketos.org/plasma-mobile/sources/2025-03-25/plasma-keyboard-$_commit.tar.xz"
+options="!check" # No tests
+
+builddir="$srcdir/plasma-keyboard-$_commit"
+
+build() {
+	cmake -B build -G Ninja \
+		-DCMAKE_BUILD_TYPE=MinSizeRel \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_INSTALL_LIBDIR=lib
+	cmake --build build
+}
+
+package() {
+	DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+63f39918cbb828d9b80e4511fc812761b3611b508e7376e05563e3251ca30d9598b9a8c77595ca9d18a3976bd4e655d425dc0992da7f4b1e884e6a8d4ff6322d  plasma-keyboard-5412caeaba1b7d42b41f122432e74d684175a687.tar.xz
+"