diff --git a/device/testing/device-lenovo-kuntao/APKBUILD b/device/testing/device-lenovo-kuntao/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..7fff3ad487244c918e231a982826eb3658d50ce7
--- /dev/null
+++ b/device/testing/device-lenovo-kuntao/APKBUILD
@@ -0,0 +1,38 @@
+# Reference: <https://postmarketos.org/devicepkg>
+pkgname=device-lenovo-kuntao
+pkgdesc="Lenovo P2"
+pkgver=1
+pkgrel=0
+url="https://postmarketos.org"
+license="MIT"
+arch="aarch64"
+options="!check !archcheck"
+depends="
+	linux-postmarketos-qcom-msm8953
+	mkbootimg
+	postmarketos-base
+"
+makedepends="devicepkg-dev"
+source="deviceinfo modules-initfs"
+subpackages="
+	$pkgname-nonfree-firmware:nonfree_firmware
+"
+
+build() {
+	devicepkg_build $startdir $pkgname
+}
+
+package() {
+	devicepkg_package $startdir $pkgname
+}
+
+nonfree_firmware() {
+	pkgdesc="GPU/Wi-Fi/Bluetooth/Audio/Video/Modem firmware"
+	depends="msm-firmware-loader"
+	mkdir "$subpkgdir"
+}
+
+sha512sums="
+d2be963b0e4a53630c99a60c823914564bec6f5c126d86e5ba27f04721bb509705681a6de1822eb63f3f60bcf002f4b8a88ec9c0cbf1563dc4ae26eb8455c81b  deviceinfo
+e70bae17df23dcaaaea0e2d3616556f04baa23f8ee1357785c0f539bf97282d8ddff53953e155b72689bb73beb38c2da3d08de2a61e866684edfa10a6593885d  modules-initfs
+"
diff --git a/device/testing/device-lenovo-kuntao/deviceinfo b/device/testing/device-lenovo-kuntao/deviceinfo
new file mode 100644
index 0000000000000000000000000000000000000000..57c2685802afdd4487c14b6b01051cc9beda1882
--- /dev/null
+++ b/device/testing/device-lenovo-kuntao/deviceinfo
@@ -0,0 +1,35 @@
+# Reference: <https://postmarketos.org/deviceinfo>
+# Please use double quotes only. You can source this file in shell
+# scripts.
+
+deviceinfo_format_version="0"
+deviceinfo_name="Lenovo P2"
+deviceinfo_manufacturer="Lenovo"
+deviceinfo_codename="lenovo-kuntao"
+deviceinfo_year="2016"
+deviceinfo_dtb="qcom/msm8953-lenovo-kuntao"
+deviceinfo_append_dtb="true"
+deviceinfo_arch="aarch64"
+
+# Device related
+deviceinfo_gpu_accelerated="true"
+deviceinfo_chassis="handset"
+deviceinfo_keyboard="false"
+deviceinfo_external_storage="true"
+deviceinfo_screen_width="1080"
+deviceinfo_screen_height="1920"
+deviceinfo_getty="ttyMSM0;115200"
+
+# Bootloader related
+deviceinfo_flash_method="fastboot"
+deviceinfo_kernel_cmdline="console=earlycon console=ttyMSM0,115200 PMOS_NO_OUTPUT_REDIRECT"
+deviceinfo_generate_bootimg="true"
+deviceinfo_bootimg_qcdt="false"
+deviceinfo_bootimg_dtb_second="false"
+deviceinfo_flash_pagesize="2048"
+deviceinfo_flash_offset_base="0x80000000"
+deviceinfo_flash_offset_kernel="0x00008000"
+deviceinfo_flash_offset_ramdisk="0x01000000"
+deviceinfo_flash_offset_second="0x00f00000"
+deviceinfo_flash_offset_tags="0x00000100"
+deviceinfo_flash_sparse="true"
diff --git a/device/testing/device-lenovo-kuntao/modules-initfs b/device/testing/device-lenovo-kuntao/modules-initfs
new file mode 100644
index 0000000000000000000000000000000000000000..f8583838a3e19b3aabb809b88b2778af97061a3b
--- /dev/null
+++ b/device/testing/device-lenovo-kuntao/modules-initfs
@@ -0,0 +1,9 @@
+# Remove this file if unnecessary (CHANGEME!)
+# This file shall contain a list of modules to be included in the initramfs,
+# so that they are available in early boot stages. In general, it should
+# include modules to support unlocking FDE (touchscreen, panel, etc),
+# USB networking, and telnet in the debug-shell.
+# The format is one module name per line. Lines starting with the character
+# '#', and empty lines are ignored. If there are multiple kernel variants
+# with different initramfs module requirements, one modules-initfs.$variant
+# file should be created for each of them.