From 317149e7f86a3ac5199b529cfa7ef123fc7f84c3 Mon Sep 17 00:00:00 2001
From: Martijn Braam <martijn@brixit.nl>
Date: Fri, 14 Sep 2018 02:58:33 +0200
Subject: [PATCH] Fixed u-boot binary

---
 device/device-pine-a64lts/APKBUILD   |   2 +-
 device/device-pine-a64lts/deviceinfo |   2 +-
 temp/u-boot/APKBUILD                 |   6 +-
 temp/u-boot/sopine-baseboard.patch   | 207 +++++++++++++++++++++++++++
 4 files changed, 213 insertions(+), 4 deletions(-)
 create mode 100644 temp/u-boot/sopine-baseboard.patch

diff --git a/device/device-pine-a64lts/APKBUILD b/device/device-pine-a64lts/APKBUILD
index 3cb2712e532..f69f97cc064 100644
--- a/device/device-pine-a64lts/APKBUILD
+++ b/device/device-pine-a64lts/APKBUILD
@@ -26,5 +26,5 @@ package() {
 
 }
 
-sha512sums="c6f0ab5c8a5312614facbf6284c2a19b634636a1435e179e96be152004a9d7731ce2de898b898a1a84aeea5476e9b4f31bf717bf79e74f4be2030385d935f9b1  deviceinfo
+sha512sums="f462e07c7f3795f80b7f97ae0c6745d0807680dc021a866fd0450a0f17535efdaec2a19a5907a44d440b1bb870515db233824096a757c3b4a7b93ec354736a54  deviceinfo
 fc71acf937691b09f2ac9b8cd724af245555c90fdff6a1fd0e64c0cad04cfc0b46ff5dec61b3ff42e6b076b02e5cf2518089c54340c35a91c0b2b88731826492  uboot-script.cmd"
diff --git a/device/device-pine-a64lts/deviceinfo b/device/device-pine-a64lts/deviceinfo
index 12c50e21af1..43cc41793c3 100644
--- a/device/device-pine-a64lts/deviceinfo
+++ b/device/device-pine-a64lts/deviceinfo
@@ -21,4 +21,4 @@ deviceinfo_dev_keyboard=""
 # Bootloader related
 deviceinfo_flash_method="none"
 deviceinfo_generate_legacy_uboot_initfs="true"
-deviceinfo_write_uboot_spl="pine64_plus/u-boot-sunxi-with-spl.bin"
+deviceinfo_write_uboot_spl="sopine_baseboard/u-boot-sunxi-with-spl.bin"
diff --git a/temp/u-boot/APKBUILD b/temp/u-boot/APKBUILD
index 5b61e7cdc7d..0f41496fcdd 100644
--- a/temp/u-boot/APKBUILD
+++ b/temp/u-boot/APKBUILD
@@ -18,6 +18,7 @@ source="ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver//_/-}.tar.bz2
         arm-trusted-firmware-${_atfversion}.tar.gz::https://github.com/apritzel/arm-trusted-firmware/archive/${_atfversion}.tar.gz
 	README.txt
 	update-u-boot
+	sopine-baseboard.patch
 	"
 
 builddir="$srcdir"/u-boot-${pkgver//_/-}
@@ -34,7 +35,7 @@ armhf) board_configs="
 aarch64) board_configs="
 	thunderx:thunderx_88xx
 	raspberrypi:rpi_3
-	pine64:pine64_plus
+	pine64:sopine_baseboard
 	";;
 esac
 
@@ -120,4 +121,5 @@ done
 sha512sums="218f71282c9d027b0faf210ce2d4d713779e0c61ea4a23f03d5dec0ca8836a3c26b46c5e258d583834f5b5a2f4663f98729ca4b0101a60f85457eb892f8370d2  u-boot-2018.05.tar.bz2
 e964f0903f29a08d3a4a3177bcbfa9df68f47d30cac7f0d2597a7101c00632efdcd2c6ecba7f8be2e66a9689388bf2fa03087c0023ef99a5e1d080af5518d53c  arm-trusted-firmware-c9f55c023164a6c8c49f70f7ac6c68c626839d6f.tar.gz
 f8c9bb6e84d6f0620c976ac7ad5dd7ec7ff9dfdd4b1d03d2bf6653e7beccf80bdf2debfc92fb1f696dba92fb40287d3c45897e0078951451d0835cb61a5f16d1  README.txt
-b3b4fb70c4eea2034bae45c513bca7b738be7507b46d3f2d62b31c794cd238d492acf960c95078cb1c945520debd5d2762103df7cef0fc36acfe9ff9a94549fc  update-u-boot"
+b3b4fb70c4eea2034bae45c513bca7b738be7507b46d3f2d62b31c794cd238d492acf960c95078cb1c945520debd5d2762103df7cef0fc36acfe9ff9a94549fc  update-u-boot
+50b19c0452d58ff80dfd2643330bbfe2349db687af258e5cb61f3872e0cac800df160baee7d6b0133bcc8b60d743a03e513db62a1917388101cfdea634424ae4  sopine-baseboard.patch"
diff --git a/temp/u-boot/sopine-baseboard.patch b/temp/u-boot/sopine-baseboard.patch
new file mode 100644
index 00000000000..5a2eb1e821d
--- /dev/null
+++ b/temp/u-boot/sopine-baseboard.patch
@@ -0,0 +1,207 @@
+diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
+index 6fe93a8..d67914f 100644
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -379,7 +379,8 @@ dtb-$(CONFIG_MACH_SUN50I) += \
+ 	sun50i-a64-olinuxino.dtb \
+ 	sun50i-a64-orangepi-win.dtb \
+ 	sun50i-a64-pine64-plus.dtb \
+-	sun50i-a64-pine64.dtb
++	sun50i-a64-pine64.dtb \
++	sun50i-a64-sopine-baseboard.dtb
+ dtb-$(CONFIG_MACH_SUN9I) += \
+ 	sun9i-a80-optimus.dtb \
+ 	sun9i-a80-cubieboard4.dtb \
+diff --git a/configs/sopine_baseboard_defconfig b/configs/sopine_baseboard_defconfig
+index 05436a1..c79c111 100644
+--- a/configs/sopine_baseboard_defconfig
++++ b/configs/sopine_baseboard_defconfig
+@@ -10,7 +10,7 @@ CONFIG_DRAM_ODT_EN=y
+ CONFIG_MMC0_CD_PIN=""
+ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
+ CONFIG_SPL_SPI_SUNXI=y
+-CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-pine64-plus"
++CONFIG_DEFAULT_DEVICE_TREE="sun50i-a64-sopine-baseboard"
+ # CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
+ # CONFIG_CMD_FLASH is not set
+ # CONFIG_SPL_DOS_PARTITION is not set
+diff --git a/arch/arm/dts/sun50i-a64-sopine-baseboard.dts b/arch/arm/dts/sun50i-a64-sopine-baseboard.dts
+new file mode 100644
+index 0000000..42c0f10
+--- /dev/null
++++ b/arch/arm/dts/sun50i-a64-sopine-baseboard.dts
+@@ -0,0 +1,102 @@
++/*
++ * Copyright (c) 2017 Icenowy Zheng <icenowy@aosc.xyz>
++ *
++ * Based on sun50i-a64-pine64.dts, which is:
++ *   Copyright (c) 2016 ARM Ltd.
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This library is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This library is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++
++#include "sun50i-a64-sopine.dtsi"
++
++/ {
++	model = "SoPine with baseboard";
++	compatible = "pine64,sopine-baseboard", "pine64,sopine",
++		     "allwinner,sun50i-a64";
++
++	aliases {
++		serial0 = &uart0;
++	};
++
++	chosen {
++		stdout-path = "serial0:115200n8";
++	};
++
++	reg_vcc1v8: vcc1v8 {
++		compatible = "regulator-fixed";
++		regulator-name = "vcc1v8";
++		regulator-min-microvolt = <1800000>;
++		regulator-max-microvolt = <1800000>;
++	};
++};
++
++&ehci0 {
++	status = "okay";
++};
++
++&ehci1 {
++	status = "okay";
++};
++
++&mmc2 {
++	pinctrl-names = "default";
++	pinctrl-0 = <&mmc2_pins>;
++	vmmc-supply = <&reg_vcc3v3>;
++	vqmmc-supply = <&reg_vcc1v8>;
++	bus-width = <8>;
++	non-removable;
++	cap-mmc-hw-reset;
++	status = "okay";
++};
++
++&ohci0 {
++	status = "okay";
++};
++
++&ohci1 {
++	status = "okay";
++};
++
++&uart0 {
++	pinctrl-names = "default";
++	pinctrl-0 = <&uart0_pins_a>;
++	status = "okay";
++};
+diff --git a/arch/arm/dts/sun50i-a64-sopine.dtsi b/arch/arm/dts/sun50i-a64-sopine.dtsi
+new file mode 100644
+index 0000000..475518b
+--- /dev/null
++++ b/arch/arm/dts/sun50i-a64-sopine.dtsi
+@@ -0,0 +1,65 @@
++/*
++ * Copyright (c) 2017 Icenowy Zheng <icenowy@aosc.xyz>
++ *
++ * Based on sun50i-a64-pine64.dts, which is:
++ *   Copyright (c) 2016 ARM Ltd.
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This library is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This library is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++#include "sun50i-a64.dtsi"
++
++/ {
++	reg_vcc3v3: vcc3v3 {
++		compatible = "regulator-fixed";
++		regulator-name = "vcc3v3";
++		regulator-min-microvolt = <3300000>;
++		regulator-max-microvolt = <3300000>;
++	};
++};
++
++&mmc0 {
++	pinctrl-names = "default";
++	pinctrl-0 = <&mmc0_pins>;
++	vmmc-supply = <&reg_vcc3v3>;
++	non-removable;
++	disable-wp;
++	bus-width = <4>;
++	status = "okay";
++};
+
-- 
GitLab