diff --git a/kde/kdeconnect/APKBUILD b/kde/kdeconnect/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..26a5e8aacdfc71a4bb410270589e34c33861f17d
--- /dev/null
+++ b/kde/kdeconnect/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdeconnect
+pkgver=1.3.1_git20180822
+pkgrel=0
+_commit="14994132f83d33edd2ef2bad29c8873d17610d24"
+pkgdesc="Adds communication between KDE and your smartphone"
+url="https://community.kde.org/KDEConnect"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends="extra-cmake-modules kdoctools-dev kconfigwidgets-dev kdbusaddons-dev kiconthemes-dev
+		knotifications-dev kio-dev kcmutils-dev qca-qt5-dev plasma-framework-dev libexecinfo-dev
+		qt5-qtdeclarative-dev"
+subpackages="$pkgname-doc $pkgname-mobile" #$pkgname-lang is only available in the release package
+#source="https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-kde-$pkgver.tar.xz
+source="$pkgname-$_commit.tar.gz::https://github.com/KDE/$pkgname-kde/archive/$_commit.tar.gz"
+options="!check" # Requires running X11 server
+builddir="$srcdir/$pkgname-kde-$_commit"
+
+build() {
+	cd "$builddir"
+	cmake \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DBUILD_TESTING=ON \
+		-DCMAKE_INSTALL_LIBDIR=lib \
+		-DCMAKE_INSTALL_LIBEXECDIR=lib \
+		-DEXPERIMENTALAPP_ENABLED=true \
+		-DBUILD_TYPE=Release
+	make
+}
+
+check() {
+	cd "$builddir"
+	CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
+}
+
+mobile() {
+	depends="kirigami2"
+	install -d "$subpkgdir"/usr/share/applications
+	install -d "$subpkgdir"/usr/bin
+	install -d "$subpkgdir"/usr/lib/qt5/plugins/kdeconnect
+
+	mv "$pkgdir"/usr/bin/kcapp "$subpkgdir"/usr/bin/
+	mv "$pkgdir"/usr/share/applications/org.kde.kdeconnect.app.desktop "$subpkgdir"/usr/share/applications/	
+	mv "$pkgdir"/usr/lib/qt5/plugins/kdeconnect/kdeconnect_remotecommands.so "$subpkgdir"/usr/lib/qt5/plugins/kdeconnect/
+	mv "$pkgdir"/usr/lib/qt5/plugins/kdeconnect/kdeconnect_remotecontrol.so "$subpkgdir"/usr/lib/qt5/plugins/kdeconnect/
+	mv "$pkgdir"/usr/lib/qt5/plugins/kdeconnect/kdeconnect_lockdevice.so "$subpkgdir"/usr/lib/qt5/plugins/kdeconnect/
+	mv "$pkgdir"/usr/lib/qt5/plugins/kdeconnect/kdeconnect_mprisremote.so "$subpkgdir"/usr/lib/qt5/plugins/kdeconnect/
+}
+
+sha512sums="a7c2381e1bbcca1e2ca0d1f3a0ff6d9d5759ea21a11fb5dc0de0992dca3c2ddbe4afc3adfa5685bb1b624bb3bcec4f58d43f1ea61324c23aaabc9835b1494373  kdeconnect-14994132f83d33edd2ef2bad29c8873d17610d24.tar.gz"