From 44f043857436d513049d121aab0a8eec7964864b Mon Sep 17 00:00:00 2001
From: Martijn Braam <martijn@brixit.nl>
Date: Sun, 16 Sep 2018 02:01:20 +0200
Subject: [PATCH] Added pine64 support to the update-u-boot command

---
 temp/u-boot/APKBUILD      | 2 +-
 temp/u-boot/update-u-boot | 8 +++++++-
 2 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/temp/u-boot/APKBUILD b/temp/u-boot/APKBUILD
index 0f41496fcdd..917d5c5b2d3 100644
--- a/temp/u-boot/APKBUILD
+++ b/temp/u-boot/APKBUILD
@@ -121,5 +121,5 @@ done
 sha512sums="218f71282c9d027b0faf210ce2d4d713779e0c61ea4a23f03d5dec0ca8836a3c26b46c5e258d583834f5b5a2f4663f98729ca4b0101a60f85457eb892f8370d2  u-boot-2018.05.tar.bz2
 e964f0903f29a08d3a4a3177bcbfa9df68f47d30cac7f0d2597a7101c00632efdcd2c6ecba7f8be2e66a9689388bf2fa03087c0023ef99a5e1d080af5518d53c  arm-trusted-firmware-c9f55c023164a6c8c49f70f7ac6c68c626839d6f.tar.gz
 f8c9bb6e84d6f0620c976ac7ad5dd7ec7ff9dfdd4b1d03d2bf6653e7beccf80bdf2debfc92fb1f696dba92fb40287d3c45897e0078951451d0835cb61a5f16d1  README.txt
-b3b4fb70c4eea2034bae45c513bca7b738be7507b46d3f2d62b31c794cd238d492acf960c95078cb1c945520debd5d2762103df7cef0fc36acfe9ff9a94549fc  update-u-boot
+f3bb656bbd13caf10a8ea619bc08b439e7dc27526c9cbdfa0374f4f8e277632ff4df06b34d441d6723a93d4a54aa03465d4270c44219d6a150d416b9c56edbbe  update-u-boot
 50b19c0452d58ff80dfd2643330bbfe2349db687af258e5cb61f3872e0cac800df160baee7d6b0133bcc8b60d743a03e513db62a1917388101cfdea634424ae4  sopine-baseboard.patch"
diff --git a/temp/u-boot/update-u-boot b/temp/u-boot/update-u-boot
index b012b5fedfa..3496362590f 100644
--- a/temp/u-boot/update-u-boot
+++ b/temp/u-boot/update-u-boot
@@ -10,6 +10,7 @@ get_defaults() {
 	if [ -z "$board" -a -e /sys/firmware/devicetree/base/compatible ]; then
 		case "$(cat /sys/firmware/devicetree/base/compatible 2>/dev/null)" in
 		wand,*) board=wand ;;
+		pine64,*) board=pine64 ;;
 		esac
 	fi
 
@@ -39,7 +40,7 @@ usage: $0 [-b|--board <board-type>] [-d|--device <device>]
 
 options:
 
- -b,--board <board>       Specify the board type: wand, cubie, cubie2, cuboxi
+ -b,--board <board>       Specify the board type: wand, cubie, cubie2, cuboxi, pine64
                           (current default: ${board:-none})
 
  -d,--device <device>     Specify the device where to install u-boot
@@ -62,6 +63,7 @@ while [ $# -gt 0 ]; do
 		wand|wandboard) board="wand" ;;
 		cubie|cubieboard) board="cubie" ;;
 		cuboxi|mx6cuboxi) board="mx6cuboxi" ;;
+		pine64) board="pine64" ;;
 		*) usage; exit 1;;
 		esac
 		shift
@@ -115,6 +117,10 @@ mx6cuboxi)
 	$dryrun dd if=$imagedir/mx6cuboxi/SPL of=$device bs=1k seek=1 status=none
 	$dryrun dd if=$imagedir/mx6cuboxi/u-boot.img of=$device bs=1k seek=69 status=none
 	;;
+pine64)
+	[ -e "$imagedir/sopine_baseboard" ] || die "PINE A64 images not installed, apk add u-boot-pine64"
+	$dryrun dd if=$imagedir/sopine_baseboard/u-boot-sunxi-with-spl.bin of=$device bs=1024 seek=8 status=none
+	;;
 esac
 $dryrun sync
 ) || die "U-Boot installation in $device failed"
-- 
GitLab