From 4fe645dead68af78188b70c46636d9bfae6ec74a Mon Sep 17 00:00:00 2001
From: Alexey Min <alexey.min@gmail.com>
Date: Mon, 17 Oct 2022 12:53:56 +0300
Subject: [PATCH] main/lk2nd: upgrade to 0.13.0 (MR 3554)

- Support for the huawei-g7 display panel in lk1st
- FS based boot is skipped when going to the recovery
- Generate image without appended dtb for lk2nd-msm8226
- Some bug fixes and device improvements

New devices:
 - Samsung Galaxy Ace 4 (SM-G357FZ)
 - Samsung Galaxy Grand 2 (SM-G7102)
 - Samsung Galaxy Grand Max (SM-G720AX)
 - Samsung Galaxy Tab 4 10.1 (2014) (SM-T530)
 - Huawei Ascend G6 L11 LTE
 - Some new variants for the existing Samsung devices

Changelog: https://github.com/msm8916-mainline/lk2nd/releases/tag/0.13.0
---
 main/lk2nd/APKBUILD | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/main/lk2nd/APKBUILD b/main/lk2nd/APKBUILD
index 2108a2bc736..8cf3cb89aca 100644
--- a/main/lk2nd/APKBUILD
+++ b/main/lk2nd/APKBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Alexey Minnekhanov <alexeymin@postmarketos.org>
 pkgname=lk2nd
-pkgver=0.12.0
+pkgver=0.13.0
 pkgrel=0
 pkgdesc="Secondary little kernel (lk) bootloader for several Qualcomm devices"
 arch="armv7 aarch64"
@@ -17,10 +17,11 @@ options="!check !archcheck !tracedeps !strip pmb:cross-native"
 # * stripping of unused sections is done in lk2nd's own ld script.
 
 subpackages="
+	$pkgname-msm8226
+	$pkgname-msm8226-appended:msm8226_appended
 	$pkgname-msm8916
 	$pkgname-msm8916-appended:msm8916_appended
 	$pkgname-msm8974
-	$pkgname-msm8226-appended:msm8226_appended
 "
 
 build() {
@@ -64,11 +65,16 @@ msm8974() {
 		"$subpkgdir"/boot
 }
 
+msm8226() {
+	install -Dm644 "$builddir"/build-lk2nd-msm8226/lk2nd.img \
+		"$subpkgdir"/boot/lk2nd.img
+}
+
 msm8226_appended() {
 	install -Dm644 "$builddir"/build-lk2nd-msm8226/lk2nd-appended-dtb.img \
 		"$subpkgdir"/boot/lk2nd.img
 }
 
 sha512sums="
-f5903875f0c96d3346d6d7116465d7dff7645bf0df577448623a044d2d03f3d48b18253e92fd8b7dffdb309b44d0b13ed3d3dde17a34afb2c8357852c504d0ab  lk2nd-0.12.0.tar.gz
+20fc61cdad9e376e45a72eeb8e4fd5019548de1014e012abba9c278d62304fd50efc70fb34c19cc1540c4bd541d56472529a6324bb8189847a770d68efc268df  lk2nd-0.13.0.tar.gz
 "
-- 
GitLab