Skip to content
Snippets Groups Projects
Unverified Commit 59c6a25c authored by Dominduchami's avatar Dominduchami Committed by Martijn Braam
Browse files

htc-leo: new device (MR 1666)

parent 855564d4
No related branches found
No related tags found
No related merge requests found
Pipeline #200582 passed
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-htc-leo
pkgdesc="HTC HD2"
pkgver=0.1
pkgrel=0
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="postmarketos-base linux-htc-leo mkbootimg mesa-dri-swrast msm-fb-refresher"
makedepends="devicepkg-dev"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="be7a9638313f9376460bc3f5b6b35038ecdb16e37369cec32771e457c0a081a1b9dff699adcdff317d3f47ebfc04d4563800b390fae3e5807bd350efbba4acd9 deviceinfo"
# Reference: <https://postmarketos.org/deviceinfo>
# Please use double quotes only. You can source this file in shell scripts.
deviceinfo_format_version="0"
deviceinfo_name="HTC HD2"
deviceinfo_manufacturer="HTC"
deviceinfo_codename="htc-leo"
deviceinfo_year="2009"
deviceinfo_dtb=""
deviceinfo_modules_initfs=""
deviceinfo_arch="armv7"
deviceinfo_chassis="handset"
# Device related
deviceinfo_keyboard="false"
deviceinfo_external_storage="true"
deviceinfo_screen_width="480"
deviceinfo_screen_height="800"
# Bootloader related
deviceinfo_flash_method="fastboot"
deviceinfo_kernel_cmdline="no_console_suspend=1 wire.search_count=5"
deviceinfo_generate_bootimg="true"
deviceinfo_bootimg_qcdt="false"
deviceinfo_bootimg_dtb_second="false"
deviceinfo_flash_offset_base="0x11800000"
deviceinfo_flash_offset_kernel="0x00008000"
deviceinfo_flash_offset_ramdisk="0x01000000"
deviceinfo_flash_offset_second="0x00f00000"
deviceinfo_flash_offset_tags="0x00000100"
deviceinfo_flash_pagesize="2048"
This fixes errors like the following (because the cross-compiler is named differently):
/bin/sh: arm-eabi-ld: not found
/bin/sh: arm-eabi-gcc: not found
diff --git a/Makefile b/Makefile
index da2108a..52b5d12 100644
--- a/Makefile
+++ b/Makefile
@@ -195,7 +195,7 @@ SUBARCH := arm
SUBARCH := arm
export KBUILD_BUILDHOST := $(SUBARCH)
ARCH ?= $(SUBARCH)
-CROSS_COMPILE ?= /home/niko/arm-eabi-4.7/bin/arm-eabi-
+CROSS_COMPILE ?= $(CONFIG_CROSS_COMPILE:"%"=%)
CROSS_COMPILE ?= $(CONFIG_CROSS_COMPILE:"%"=%)
# Architecture as present in compile.h
# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm/configs/htcleo_defconfig
pkgname=linux-htc-leo
pkgver=3.0.4
pkgrel=0
pkgdesc="HTC HD2 kernel fork"
arch="armv7"
_carch="arm"
_flavor="htc-leo"
url="https://kernel.org"
license="GPL-2.0-only"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl gcc4 gcc-armv7"
# Compiler: GCC4. Doesn't boot with newer versions of GCC
if [ "${CC:0:5}" != "gcc4-" ]; then
CC="gcc4-$CC"
HOSTCC="gcc4-gcc"
CROSS_COMPILE="gcc4-$CROSS_COMPILE"
fi
# Source
#_repository="android_kernel_htc_qsd8k"
#_commit="917cc470bb9c5ef1655ecb49357db4917eaa8957"
_repository="android_kernel_htc_htcleo"
_commit="fb2ba086ea96647f38539664ebf0aa6eca61d7bb"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://github.com/qsd8k-legacy/$_repository/archive/$_commit.tar.gz
$_config
01-fix-compiler-path.patch
"
builddir="$srcdir/$_repository-$_commit"
_outdir="out"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
}
sha512sums="5f324b69ff30284c0aabf16f9580726470eb54ce7edf6066e22d41d92e8be05085f9fb38fddeceee9cec4fb30cd68dda51585ff73ffbd4d52b154956aa81603e linux-htc-leo-fb2ba086ea96647f38539664ebf0aa6eca61d7bb.tar.gz
b4e0b06f16c1a950e9b95296b647a234cba5edc55701cd74297dd92d12c309d7a8b681022edd8e8e2fed739412a2af1b81210ccfcaa90090c3a83f017e41f760 config-htc-leo.armv7
4166bdd725a00577c1319f1103ad802fc4699da3b5aae247c77b035880d21925d16c4faece72e93f59c933774dd912fc08082b07af03a90b664b7fa2865a61bc 01-fix-compiler-path.patch"
This diff is collapsed.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment