Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
656eeb3c
Unverified
Commit
656eeb3c
authored
3 years ago
by
Luca Weiss
Committed by
Bart Ribbers
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
temp/dino: fix compilation with new vala (MR 2122)
parent
0645c552
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Pipeline
#197743
passed
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
temp/dino/9acb54df9254609f2fe4de83c9047d408412de28.patch
+40
-0
40 additions, 0 deletions
temp/dino/9acb54df9254609f2fe4de83c9047d408412de28.patch
temp/dino/APKBUILD
+4
-2
4 additions, 2 deletions
temp/dino/APKBUILD
with
44 additions
and
2 deletions
temp/dino/9acb54df9254609f2fe4de83c9047d408412de28.patch
0 → 100644
+
40
−
0
View file @
656eeb3c
From 9acb54df9254609f2fe4de83c9047d408412de28 Mon Sep 17 00:00:00 2001
From: Marvin W <git@larma.de>
Date: Sat, 6 Mar 2021 08:31:53 -0600
Subject: [PATCH] QLite: Adjust Real for latest vala version
---
qlite/src/column.vala | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/qlite/src/column.vala b/qlite/src/column.vala
index 60125ddf..45385f38 100644
--- a/qlite/src/column.vala
+++ b/qlite/src/column.vala
@@ -96,12 +96,14 @@
public abstract class Column<T> {
}
}
- public class Real : Column<double> {
- public Real(string name) {
+ public class NullableReal : Column<double?> {
+ public NullableReal(string name) {
base(name, FLOAT);
}
- public override double get(Row row, string? table_name = DEFALT_TABLE_NAME) {
+ public override bool not_null { get { return false; } set {} }
+
+ public override double? get(Row row, string? table_name = DEFALT_TABLE_NAME) {
return row.get_real(name, table_name == DEFALT_TABLE_NAME ? table.name : table_name);
}
@@ -109,7 +111,7 @@
public abstract class Column<T> {
return !row.has_real(name, table_name == DEFALT_TABLE_NAME ? table.name : table_name);
}
- internal override void bind(Statement stmt, int index, double value) {
+ internal override void bind(Statement stmt, int index, double? value) {
stmt.bind_double(index, value);
}
}
This diff is collapsed.
Click to expand it.
temp/dino/APKBUILD
+
4
−
2
View file @
656eeb3c
# Forked from Alpine Linux
pkgname
=
dino
pkgver
=
9999_git20210115
pkgrel
=
0
pkgrel
=
1
# feature/handy branch
_commit
=
"eb146f811904405a17251fbb66920eaf0506a6a3"
pkgdesc
=
"Modern Jabber/XMPP client"
...
...
@@ -27,6 +27,7 @@ subpackages="$pkgname-lang"
source
=
"
https://github.com/dino/dino/archive/
$_commit
.tar.gz
bump-signal-version.patch
9acb54df9254609f2fe4de83c9047d408412de28.patch
"
builddir
=
"
$srcdir
/
$pkgname
-
$_commit
"
build
()
{
...
...
@@ -50,4 +51,5 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"a05c15199aae159ef03e05c4c2b97f81744f92cfaed718e2ea99043da76e68a557528e89abacf30519ae9a50e559fc0ed9f6794c5b0104b233a348695de82eea eb146f811904405a17251fbb66920eaf0506a6a3.tar.gz
838ccba8d97db8bc43de26afd259e4bdaf3afea786bf40a7ed9ae63f4fb7c2190e8bf6de7b41880602113df87831d01467547f8bfd1f88b50d35287822cb5f4c bump-signal-version.patch"
838ccba8d97db8bc43de26afd259e4bdaf3afea786bf40a7ed9ae63f4fb7c2190e8bf6de7b41880602113df87831d01467547f8bfd1f88b50d35287822cb5f4c bump-signal-version.patch
01d771c039e9c15882ef11970fbc181efe12202f1f1fd9ff3bd6e805f1e85a662d7662da7fbbfb05d6aa569b9f4fed907cf7357d83d02fb1bafa2bb179811f63 9acb54df9254609f2fe4de83c9047d408412de28.patch"
This diff is collapsed.
Click to expand it.
Administrator
@root
mentioned in commit
53f854e9
By Luca Weiss on 2021-06-08T21:10:54
·
3 years ago
Imported
mentioned in commit
53f854e9
By Luca Weiss on 2021-06-08T21:10:54
Edited
3 years ago
by
Ghost User
mentioned in commit 53f854e98b141fbf2340cad67f1599a3083ca7d5 *By Luca Weiss on 2021-06-08T21:10:54*
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment