From 864873e463dac2a21f48bbbc9f9a1771b5418dd0 Mon Sep 17 00:00:00 2001
From: Oliver Smith <ollieparanoid@postmarketos.org>
Date: Sun, 24 Nov 2024 11:38:53 +0100
Subject: [PATCH] linux-htc-flounder: add V=1 workaround (MR 5848)

Add a workaround so the kernel compile output is not silent (which leads
to pmbootstrap aborting the build). This will be fixed once upgrading to
linux >= 6.2.

Related: pmaports issue 1990
[ci:skip-build]: already built successfully in CI
---
 device/testing/linux-htc-flounder/APKBUILD | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/device/testing/linux-htc-flounder/APKBUILD b/device/testing/linux-htc-flounder/APKBUILD
index c8d529ed026..c7715ec3561 100644
--- a/device/testing/linux-htc-flounder/APKBUILD
+++ b/device/testing/linux-htc-flounder/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Segfault <awarnecke002@hotmail.com>
 pkgname=linux-htc-flounder
 pkgver=6.0.0
-pkgrel=3
+pkgrel=4
 pkgdesc="Google Nexus 9 kernel fork"
 arch="aarch64"
 _carch="arm64"
@@ -33,8 +33,10 @@ prepare() {
 
 build() {
 	unset LDFLAGS
+
+	# V=1: workaround for pma#1990
 	make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
-		KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
+		KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS" V=1
 }
 
 package() {
-- 
GitLab