diff --git a/device/main/device-qemu-aarch64/APKBUILD b/device/main/device-qemu-aarch64/APKBUILD
index 4001f8a526b10b559eb83f8de75ccc8057ab1ec9..c034f3be7687bfe9a3cf5ada048adcc5801c8daa 100644
--- a/device/main/device-qemu-aarch64/APKBUILD
+++ b/device/main/device-qemu-aarch64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
 pkgname=device-qemu-aarch64
 pkgver=6
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (aarch64)"
 url="https://postmarketos.org"
 arch="aarch64"
@@ -51,7 +51,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_virt() {
diff --git a/device/main/device-qemu-amd64/APKBUILD b/device/main/device-qemu-amd64/APKBUILD
index a64b989450afe3463faa0a19d81c4a3d262838fb..0904a2126e3d136681e14e2fb71846fb7c4c9d7a 100644
--- a/device/main/device-qemu-amd64/APKBUILD
+++ b/device/main/device-qemu-amd64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
 pkgname=device-qemu-amd64
 pkgver=7
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (x86_64)"
 url="https://postmarketos.org"
 arch="x86_64"
@@ -52,7 +52,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_none() {
diff --git a/device/main/device-qemu-riscv64/APKBUILD b/device/main/device-qemu-riscv64/APKBUILD
index 0f6861dfde34081a2788c37822508b858971504f..48617b1f217375e2624789e045d29bd250eabdb9 100644
--- a/device/main/device-qemu-riscv64/APKBUILD
+++ b/device/main/device-qemu-riscv64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Luca Weiss <luca@lucaweiss.eu>
 pkgname=device-qemu-riscv64
 pkgver=3
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (riscv64)"
 url="https://postmarketos.org"
 arch="riscv64"
@@ -49,7 +49,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_edge() {