From 8ae6db9a1ec2730341009550523552333c98cdc1 Mon Sep 17 00:00:00 2001
From: Jakob Hauser <jahau@rocketmail.com>
Date: Sun, 17 Nov 2024 03:26:06 +0100
Subject: [PATCH] device-qemu-*: move X11 config file from /etc to /usr

As it's delivered by the distro, it should go into /usr.
---
 device/main/device-qemu-aarch64/APKBUILD | 4 ++--
 device/main/device-qemu-amd64/APKBUILD   | 4 ++--
 device/main/device-qemu-riscv64/APKBUILD | 4 ++--
 3 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/device/main/device-qemu-aarch64/APKBUILD b/device/main/device-qemu-aarch64/APKBUILD
index 4001f8a526b..c034f3be768 100644
--- a/device/main/device-qemu-aarch64/APKBUILD
+++ b/device/main/device-qemu-aarch64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
 pkgname=device-qemu-aarch64
 pkgver=6
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (aarch64)"
 url="https://postmarketos.org"
 arch="aarch64"
@@ -51,7 +51,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_virt() {
diff --git a/device/main/device-qemu-amd64/APKBUILD b/device/main/device-qemu-amd64/APKBUILD
index a64b989450a..0904a2126e3 100644
--- a/device/main/device-qemu-amd64/APKBUILD
+++ b/device/main/device-qemu-amd64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
 pkgname=device-qemu-amd64
 pkgver=7
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (x86_64)"
 url="https://postmarketos.org"
 arch="x86_64"
@@ -52,7 +52,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_none() {
diff --git a/device/main/device-qemu-riscv64/APKBUILD b/device/main/device-qemu-riscv64/APKBUILD
index 0f6861dfde3..48617b1f217 100644
--- a/device/main/device-qemu-riscv64/APKBUILD
+++ b/device/main/device-qemu-riscv64/APKBUILD
@@ -3,7 +3,7 @@
 # Co-Maintainer: Luca Weiss <luca@lucaweiss.eu>
 pkgname=device-qemu-riscv64
 pkgver=3
-pkgrel=0
+pkgrel=1
 pkgdesc="Simulated device in QEMU (riscv64)"
 url="https://postmarketos.org"
 arch="riscv64"
@@ -49,7 +49,7 @@ sway() {
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	install -Dm644 "$srcdir"/resolution-qemu-X11.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/10-resolution-qemu-X11.conf
+		"$subpkgdir"/usr/share/X11/xorg.conf.d/10-resolution-qemu-X11.conf
 }
 
 kernel_edge() {
-- 
GitLab