diff --git a/main/postmarketos-base-eink/001-eink-gschema.override b/main/postmarketos-base-eink/001-eink-gschema.override
new file mode 100644
index 0000000000000000000000000000000000000000..694977c1048cae0bacb731a6f9f56613813f0dcc
--- /dev/null
+++ b/main/postmarketos-base-eink/001-eink-gschema.override
@@ -0,0 +1,2 @@
+[org.gnome.desktop.interface]
+gtk-theme='HighContrast'
diff --git a/main/postmarketos-base-eink/APKBUILD b/main/postmarketos-base-eink/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..804aa8ec8eee69fbdd3e05035fd7b48031d5a1f6
--- /dev/null
+++ b/main/postmarketos-base-eink/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caleb Connolly <caleb@connolly.tech>
+pkgname=postmarketos-base-eink
+pkgver=1
+pkgrel=0
+pkgdesc="Base package with some opinionated default for e-ink devices"
+# It's worth emphasising the word "opinionated" here, e-ink has some
+# obvious differences compared to regular displays, there are cases
+# where it clearly makes sense to adjust default behaviour. However
+# not everyone may agree with these. It should be easy for the user to
+# override changes here easily, ideally without having to resort to a
+# terminal.
+url="https://postmarketos.org"
+arch="noarch"
+license="GPL-3.0-or-later"
+options="!check"
+source="
+	postmarketos-splash-eink.ini
+	001-eink-gschema.override
+"
+subpackages="$pkgname-phosh"
+builddir="$srcdir/"
+
+package() {
+	install -Dm644 "$srcdir/postmarketos-splash-eink.ini" \
+		-t "$pkgdir/etc/postmarketos/"
+}
+
+phosh() {
+# For now phosh hardcodes some colors (like making the quick settings white)
+# when using high contrast, so it's a better option than the postmarketOS-paper
+# theme for now
+	install -Dm644 "$srcdir"/001-eink-gschema.override \
+		"$pkgdir"/usr/share/glib-2.0/schemas/001-eink.gschema.override
+}
diff --git a/main/postmarketos-base-eink/postmarketos-splash-eink.ini b/main/postmarketos-base-eink/postmarketos-splash-eink.ini
new file mode 100644
index 0000000000000000000000000000000000000000..b483c81fb7c5938df1916fc61cc3509897e420b6
--- /dev/null
+++ b/main/postmarketos-base-eink/postmarketos-splash-eink.ini
@@ -0,0 +1,17 @@
+[background]
+color=#fff
+
+[name]
+text=postmarketOS
+font=/usr/share/fonts/ttf-droid/DroidSans.ttf
+color=#000
+
+[logo]
+text=
+font=/usr/share/fonts/ttf-pmos/pmos.ttf
+color=#000
+spacing=1
+
+[text]
+font=/usr/share/fonts/ttf-droid/DroidSans.ttf
+color=#222