diff --git a/cross/gcc-aarch64/APKBUILD b/cross/gcc-aarch64/APKBUILD
index c3159d262a69d7a304072759d4a9c746486982cc..353ba7202f43ad406e01777d8bdbc9e2436fca1f 100644
--- a/cross/gcc-aarch64/APKBUILD
+++ b/cross/gcc-aarch64/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-aarch64
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for aarch64"
 url="https://gcc.gnu.org"
 arch="x86_64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/cross/gcc-armhf/APKBUILD b/cross/gcc-armhf/APKBUILD
index b7042b705dbeede09176e1ddea559da3b1cd8c25..adca679c9fe6dec0b271fc1d7ab01a5c07ca2d4a 100644
--- a/cross/gcc-armhf/APKBUILD
+++ b/cross/gcc-armhf/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-armhf
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for armhf"
 url="https://gcc.gnu.org"
 arch="x86_64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/cross/gcc-armv7/APKBUILD b/cross/gcc-armv7/APKBUILD
index a4ee0168fe82a156155baff3cb874103d13378f1..1b7e6def3bb6c861b5a4e51aad5c822c73d64fa0 100644
--- a/cross/gcc-armv7/APKBUILD
+++ b/cross/gcc-armv7/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-armv7
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for armv7"
 url="https://gcc.gnu.org"
 arch="x86_64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/cross/gcc-riscv64/APKBUILD b/cross/gcc-riscv64/APKBUILD
index 932b0ebabbb0bb7a18726708b5e7ebf987e86fc8..2c13414c9cb17631ffd22b2ed84f9ec33caeb45e 100644
--- a/cross/gcc-riscv64/APKBUILD
+++ b/cross/gcc-riscv64/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-riscv64
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for riscv64"
 url="https://gcc.gnu.org"
 arch="x86_64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/cross/gcc-x86/APKBUILD b/cross/gcc-x86/APKBUILD
index e4f1e6ca07a9b6ae7ef97e13f1b60e61619a54da..678fc466ae8335ae0ffc38153a746713a81886f1 100644
--- a/cross/gcc-x86/APKBUILD
+++ b/cross/gcc-x86/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-x86
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for x86"
 url="https://gcc.gnu.org"
 arch="x86_64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/cross/gcc-x86_64/APKBUILD b/cross/gcc-x86_64/APKBUILD
index 7c32f2276c70cdc6750912cc27ac082aaef5905e..2781cfd7507849c650e3cc59dd6a6bc0f58ba201 100644
--- a/cross/gcc-x86_64/APKBUILD
+++ b/cross/gcc-x86_64/APKBUILD
@@ -34,7 +34,7 @@ _pkgsnap="${pkgver##*_git}"
 [ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
 
 pkgname=gcc-x86_64
-pkgrel=1
+pkgrel=2
 pkgdesc="Stage2 cross-compiler for x86_64"
 url="https://gcc.gnu.org"
 arch="aarch64"
@@ -339,7 +339,7 @@ build() {
 	i586-*-*-*)		_arch_configure="--with-arch=pentium-m --with-fpmath=sse --with-tune=generic --enable-cld";;
 	s390x-*-*-*)		_arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;
 	riscv64-*-*-*)		_arch_configure="--with-arch=rv64gc --with-abi=lp64d --enable-autolink-libatomic";;
-	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d";;
+	loongarch64-*-*-*)      _arch_configure="--with-arch=loongarch64 --with-abi=lp64d --with-tls=trad";;
 	esac
 
 	case "$CTARGET_ARCH" in
diff --git a/device/community/soc-qcom-sdm845/APKBUILD b/device/community/soc-qcom-sdm845/APKBUILD
index c4c94715b338fd0f8ce45f89d9472b4d4745122c..1c749d1029b9b9fab411f0b1ff2f9ee04e5b1dfa 100644
--- a/device/community/soc-qcom-sdm845/APKBUILD
+++ b/device/community/soc-qcom-sdm845/APKBUILD
@@ -3,14 +3,13 @@
 pkgname=soc-qcom-sdm845
 pkgdesc="Common package for Qualcomm SDM845 devices"
 pkgver=22
-pkgrel=1
+pkgrel=2
 url="https://postmarketos.org"
 license="BSD-3-Clause"
 arch="aarch64"
 options="!check !archcheck !tracedeps"
 depends="
 	swclock-offset
-	kmod
 "
 replaces="upower"
 subpackages="
diff --git a/device/testing/device-samsung-hlte/APKBUILD b/device/testing/device-samsung-hlte/APKBUILD
index 648ebb22e999c54ad48ec5b636c81db29c01c5f5..25d777f75e9e5d073b57bfffccba5463182b80c7 100644
--- a/device/testing/device-samsung-hlte/APKBUILD
+++ b/device/testing/device-samsung-hlte/APKBUILD
@@ -1,8 +1,8 @@
 # Reference: <https://postmarketos.org/devicepkg>
 pkgname=device-samsung-hlte
 pkgdesc="Samsung Galaxy Note 3"
-pkgver=2
-pkgrel=5
+pkgver=3
+pkgrel=0
 url="https://postmarketos.org"
 license="MIT"
 arch="armv7"
@@ -49,6 +49,6 @@ nonfree_firmware() {
 
 sha512sums="
 6cef5f8ae1785ac16e6fe84bfc861ac50cdfb94db35d764f44a25c960e123cb82f6e56f45362a5340c62a3d5ac225f2689afd4f6964cb88305a0892ba44214f0  bt-module-deps.conf
-91f6f253275d3d312e120c345e69c40d3dc79ebd52bbe6405cdf82ece58d2c379d571b6be8131a4b51e3d683a420466e48a39b1a9d8b6617cbef713b597b6b65  deviceinfo
+f3c829e1845ed3cc6c1e5c42144e766b681b3c72f606f498070a60b6f1a8f9ef9d3528ea70240c115ac773407c74fe0dfc3a18559c0fcc99678bf71f7b80c58c  deviceinfo
 640f11d6cdea23ae5e183468aa9873f5ce091cac721d893866d5e46c19d77bcc6f5401cc0e6488c36d4da954fe94c3d7046f0bc2d299b656a06b540fab8d5e55  modules-initfs
 "
diff --git a/device/testing/device-samsung-hlte/deviceinfo b/device/testing/device-samsung-hlte/deviceinfo
index 4a1fd6fcdd8be27e07e14db42b09f0cc334cf9da..5ae5e90399ef93ebeefa1b70e5579e0cc50be900 100644
--- a/device/testing/device-samsung-hlte/deviceinfo
+++ b/device/testing/device-samsung-hlte/deviceinfo
@@ -17,21 +17,21 @@ deviceinfo_external_storage="true"
 deviceinfo_screen_width="1080"
 deviceinfo_screen_height="1920"
 deviceinfo_getty="ttyMSM0;115200"
+deviceinfo_mesa_driver="msm"
 deviceinfo_gpu_accelerated="true"
 
 # Bootloader related
-deviceinfo_flash_method="heimdall-bootimg"
+deviceinfo_flash_method="fastboot"
 deviceinfo_kernel_cmdline="console=ttyMSM0,115200,n8 msm.vram=192m msm.allow_vram_carveout=1"
 deviceinfo_generate_bootimg="true"
+deviceinfo_generate_extlinux_config="true"
 deviceinfo_bootimg_qcdt="false"
-deviceinfo_bootimg_append_seandroidenforce="true"
 deviceinfo_flash_offset_base="0x00000000"
 deviceinfo_flash_offset_kernel="0x00008000"
 deviceinfo_flash_offset_ramdisk="0x02900000"
 deviceinfo_flash_offset_second="0x00f00000"
 deviceinfo_flash_offset_tags="0x02700000"
 deviceinfo_flash_pagesize="2048"
-deviceinfo_flash_heimdall_partition_kernel="BOOT"
 
 # Samsung Electronics Co., Ltd
 deviceinfo_usb_idVendor="0x04e8"
diff --git a/device/testing/linux-next/APKBUILD b/device/testing/linux-next/APKBUILD
index 8855eb18ee3e95d1bbb4cc4fda09bb581399f175..4eb32da40680b8bf268246eacb2c82109ef1f361 100644
--- a/device/testing/linux-next/APKBUILD
+++ b/device/testing/linux-next/APKBUILD
@@ -2,7 +2,7 @@
 # Kernel config based on: arch/arm64/configs/defconfig
 
 pkgname=linux-next
-pkgver=6.11_git20240829
+pkgver=6.11_git20240830
 pkgrel=1
 _nextver="${pkgver#*_git}"
 pkgdesc="Linux next kernel"
@@ -69,7 +69,7 @@ package() {
 }
 
 sha512sums="
-524b660bc253238d0913655ed35c08978dc22275989a5ac1802509b02ef5545cf7b22168066bae9780093d138ce78662776db2d71dadd6e821dbea9e74e4b629  linux-next-next-20240829.tar.gz
+a56c706ba6b854e4d63617d56fd7f6fcbc9d3382515f72ac4f4959692ebe90d08e9d702a5e79e5314fac685a2793237ace430789c93fecd9be8f47b1b53dc18b  linux-next-next-20240830.tar.gz
 adbb506c0a2d676b1964a5d7c693f72338541ebd0cacee62e4579d43163c468d95607d73bf7439fb55b4d6bfa0dd42578b07ee20965aa03c2a9d8022cb3ae267  devices.config
 d52f692935675b5b9300c7983848a26149914687a8b3aef3b90f50da3f6534de9b490c6778d490bb5a4202f1a45cc4d9178a1e1b8270a8d612d4181721629c02  pmos.config
 "
diff --git a/main/postmarketos-initramfs/APKBUILD b/main/postmarketos-initramfs/APKBUILD
index 42b2e2b685d854466e9f24080700555868396600..8f06bb077a0cd869c2ed51cf13ff1ab142241a01 100644
--- a/main/postmarketos-initramfs/APKBUILD
+++ b/main/postmarketos-initramfs/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Caleb Connolly <caleb@postmarketos.org>
 # Co-Maintainer: Clayton Craft <clayton@craftyguy.net>
 pkgname=postmarketos-initramfs
-pkgver=3.3.1
+pkgver=3.3.3
 pkgrel=0
 pkgdesc="Base files for the postmarketOS initramfs / initramfs-extra"
 url="https://postmarketos.org"