From ae9c0b9b37e56bf6c4f4d522e043ce616fc9cb3d Mon Sep 17 00:00:00 2001
From: Clayton Craft <clayton@craftyguy.net>
Date: Fri, 1 Nov 2024 12:24:15 -0700
Subject: [PATCH] main/postmarketos-initramfs: umount /boot in the initramfs

Fixes a bug where the kernel thinks the boot partition is still mounted
and it's unavailable for mounting in the rootfs

If you look at what the initramfs was doing before !5635, it was
explicitly umounting the boot partition from /boot in the initramfs and
then mounting it under /boot in the rootfs:
https://gitlab.postmarketos.org/postmarketOS/pmaports/-/blob/c45d7ec0a5f7ac814b50087402bb11825120f42b/main/postmarketos-initramfs/init.sh#L87

With this patch, we're now back to umounting /boot in the initramfs.
The second part of that original logic is now handled elsewhere now, and
that seems to be working OK.

The bug was reported here:
https://gitlab.postmarketos.org/postmarketOS/pmaports/-/issues/3279#note_454346
---
 main/postmarketos-initramfs/APKBUILD | 6 +++---
 main/postmarketos-initramfs/init.sh  | 2 ++
 2 files changed, 5 insertions(+), 3 deletions(-)

diff --git a/main/postmarketos-initramfs/APKBUILD b/main/postmarketos-initramfs/APKBUILD
index 49444298bf5..6d894346dd8 100644
--- a/main/postmarketos-initramfs/APKBUILD
+++ b/main/postmarketos-initramfs/APKBUILD
@@ -1,8 +1,8 @@
 # Maintainer: Caleb Connolly <caleb@postmarketos.org>
 # Co-Maintainer: Clayton Craft <clayton@craftyguy.net>
 pkgname=postmarketos-initramfs
-pkgver=3.4.0
-pkgrel=1
+pkgver=3.4.1
+pkgrel=0
 pkgdesc="Base files for the postmarketOS initramfs / initramfs-extra"
 url="https://postmarketos.org"
 options="!check"  # no tests
@@ -105,7 +105,7 @@ sha512sums="
 9c0e8f6f61d5da191e03a1aa9d5d0ceb5baf1eae6dbb9bfb0af59817783525119ac8394b135f303f7b6434a3eab0b49185fb90379e06823db847a4999c75ce33  00-initramfs-base.dirs
 c0233d22858a5901db64e1d2fe1f6d39a2e2cfd1b94a10932483f55fed9461e9b8aa2d73b154b9d99a7a8b49ee02abfbddfe917ce0c6d7576601ba2668589c01  00-initramfs-base.files
 d0db184a5af00047b5f2c4ae869324968cdd396a17ed2c146e2523669bcf25f9ffd805eba2ec01ea74850ec674e6d0a490cdba7dcbb264bb5c512af3b212f166  00-initramfs-extra-base.files
-5dc7d65e3e6f0df07d2f7ba661dfb6714a3c3bae6a9845a6d116582780ea69e34ba5950e30fc8dd0a4852e8f2b8b1ae9ff2ea962c4c4e4b34df5e3c30d8bbb3d  init.sh
+966284e8ef8f840258a84019db4a6ddd436cdc50193e0673532f70fef86a6e4c1bfd21b682f3708251b6b670ca569c90016926d0926babc5a0257bb33ae55d79  init.sh
 bbfbec0690386e81d1a43420e7898a1e32fdf10eab88dc8d1d500a5def84c60a6dbb7055f66dc163429faf46d540dd4e8e44642b27743ea783eed6b41e0ff019  init_functions.sh
 18a0ca97bca094aeb8cb1c2582205ac0aff131085c39f1715246541cacfb35434aba515cd5d338703843efb36b9effd494a51361c51fb39be6052ad866346d3d  init_2nd.sh
 30fb52456376020e70116169752582d25a011a858111a347c2e53eccaddea8765fab502371cfdc0c2a8ca93034795b7e689e4cd3393ad601268c02024c4e84ab  init_functions_2nd.sh
diff --git a/main/postmarketos-initramfs/init.sh b/main/postmarketos-initramfs/init.sh
index 31b8b9eef30..d991106f9a8 100644
--- a/main/postmarketos-initramfs/init.sh
+++ b/main/postmarketos-initramfs/init.sh
@@ -59,6 +59,8 @@ mount_subpartitions
 wait_boot_partition
 mount_boot_partition /boot
 extract_initramfs_extra /boot/initramfs-extra
+# /boot is mounted later into the rootfs
+umount /boot
 
 # Kill mdev, since it's replaced by udev in the
 # second stage init
-- 
GitLab