From b4df024906b6ba785d6725d6d04bd64a7048f551 Mon Sep 17 00:00:00 2001
From: Liam Hurwitz <lgh@e.email>
Date: Mon, 10 Mar 2025 20:20:56 +0100
Subject: [PATCH] linux-postmarketos-qcom-laptop: add kconfig for Type-C alt
 mode and remoteproc as device.config

The options from the device.config are not set in johans defconfig
---
 .../linux-postmarketos-qcom-laptop/APKBUILD     |  3 +++
 .../device.config                               | 17 +++++++++++++++++
 2 files changed, 20 insertions(+)
 create mode 100644 device/community/linux-postmarketos-qcom-laptop/device.config

diff --git a/device/community/linux-postmarketos-qcom-laptop/APKBUILD b/device/community/linux-postmarketos-qcom-laptop/APKBUILD
index d95d246d953..77d7be586dc 100644
--- a/device/community/linux-postmarketos-qcom-laptop/APKBUILD
+++ b/device/community/linux-postmarketos-qcom-laptop/APKBUILD
@@ -40,6 +40,7 @@ source="
 	$pkgname-$_commit.tar.gz::https://github.com/jhovold/$_repository/archive/$_commit.tar.gz
 	misc.config
 	pmos.config
+	device.config
 "
 builddir="$srcdir/linux-$_commit"
 _outdir="out"
@@ -49,6 +50,7 @@ prepare() {
 	default_prepare
 	cp "$srcdir/pmos.config" "$builddir"/arch/"$_carch"/configs/
 	cp "$srcdir/misc.config" "$builddir"/arch/"$_carch"/configs/
+	cp "$srcdir/device.config" "$builddir"/arch/"$_carch"/configs/
 
 	# Generate .config
 	unset LDFLAGS
@@ -84,4 +86,5 @@ sha512sums="
 d3716fd7b9dbdd913abb78d6e23dd1d4d21c7ca04749f2d1b1b808c454ea1ea4f6d63dc6ba54ac8341e05a4e671443e556cf0334eec566f248b452e9bab396f5  linux-postmarketos-qcom-laptop-c328bbee28fed9e3b89db02ef48f52159d237fb0.tar.gz
 980eefd8aaee78897cd41d039eecc11e23b8d7cc87b41c869f1e2b83cd9b5dac9813d7bd1a0e7c466303c795f234871080686921b9672983604551903004cb68  misc.config
 89244418a7331fd89109591f2748bebdcc7c9a4a34980a551d0a42abf063cb47188758d5e22001caf10f8db893532544a3dbd1111764ddea9db6048bbde005f4  pmos.config
+6976d5602de08e4556b898e5098f9ad7395834d125dfd29e06436a8048d589912772ca7c72b11eea59b2fe3eb237673d09fe774c0c7a189a9bea07daa3cefd9a  device.config
 "
diff --git a/device/community/linux-postmarketos-qcom-laptop/device.config b/device/community/linux-postmarketos-qcom-laptop/device.config
new file mode 100644
index 00000000000..e866689062f
--- /dev/null
+++ b/device/community/linux-postmarketos-qcom-laptop/device.config
@@ -0,0 +1,17 @@
+# Remote Processor (RemoteProc) Framework
+CONFIG_REMOTEPROC_CDEV=y                  # Character device for RemoteProc
+
+# Qualcomm PIL (Peripheral Image Loader)
+CONFIG_QCOM_PIL_INFO=m                    # PIL metadata info
+CONFIG_QCOM_RPROC_COMMON=m                # Common Qualcomm RemoteProc functionality 
+
+# Qualcomm Q6V5 Subsystem
+CONFIG_QCOM_Q6V5_COMMON=m                 # Common Q6V5 functionality
+CONFIG_QCOM_Q6V5_MSS=m                    # Modem Subsystem Support for Q6V5
+
+# Qualcomm WCNSS (Wireless Connectivity Subsystem)
+CONFIG_QCOM_WCNSS_PIL=m                   # WCNSS PIL driver
+
+# USB Type-C Alternate Mode drivers
+CONFIG_TYPEC_DP_ALTMODE=m                 # DisplayPort Alternate Mode
+CONFIG_TYPEC_TBT_ALTMODE=m                # Thunderbolt Alternate Mode
-- 
GitLab