diff --git a/temp/u-boot-librem5/APKBUILD b/temp/u-boot-librem5/APKBUILD
index fe0c80751f59bfec988e4ced4b1b5f146c1ad78b..7dbb1ec1f1b29b539cb133c981d46366d93ae268 100644
--- a/temp/u-boot-librem5/APKBUILD
+++ b/temp/u-boot-librem5/APKBUILD
@@ -1,7 +1,7 @@
 # Forked from Alpine, so we can build it with Librem 5 phone support
 pkgname=u-boot-librem5
 pkgver=0.9
-pkgrel=0
+pkgrel=1
 # 'librem5' branch in atf repo
 _atfversion="92c2de12d36b31938ce940d5cac3c30a98665237"
 # 'librem5' branch in uboot repo
@@ -99,9 +99,11 @@ devkit() {
 }
 
 
-sha512sums="feab35fae6450f24da54998b44b1d834bc33c9597ff8f9a4275e9ec7a1d1f442e133e51635eaabb9b759499728a0f70256d7bd6bc8bbeeb2133992f9c606d607  uboot-imx-e9f7caf70a5c4f468ba00392ad0ca0badecea20a.tar.gz
+sha512sums="
+feab35fae6450f24da54998b44b1d834bc33c9597ff8f9a4275e9ec7a1d1f442e133e51635eaabb9b759499728a0f70256d7bd6bc8bbeeb2133992f9c606d607  uboot-imx-e9f7caf70a5c4f468ba00392ad0ca0badecea20a.tar.gz
 035a4358ddf586c829da7fa2fb0d9d1df913c0c454f2d0e57ff0c6794552e49950fb6373f9aaf72e0e4c78ab411496aabbc60bf66cd76e35053f7a2d77911735  m4-a017421c340a69f2392086da93841244f78a03c5.tar.gz
 cd8c9411ae0e57d2c8c700bf3e8c8d03e7dab955ace249a00911dd8c42b42929e0de3a5885eb9b1d945174abc8cfb177595d83c235e757c70640f451b62547ba  arm-trusted-firmware-92c2de12d36b31938ce940d5cac3c30a98665237.tar.gz
 24d4466b3c2202ceb1c22be2b3db4482eee54d09e167083cc53e82cd9f22ef9ac0cba5a1a3341cacf8ee01adf014eb25f4aa437f35a43ac102dd2f22e935821b  firmware-imx-8.10.bin
-1a98f50e572f3001bf5a37c037cf5649f9de5b6b3b0192c04ece51154f0eaec9b3bd625422cf1604f9c83e4c5d76fa980766380a214418610fab8234fd65d223  update-u-boot
-acec9f7fa5fb3f4e84c6f6f74794325d5d18ea4557ab98fd0915ba5e41748e338f94604815b2f6d595119359462b48d2ee285b2e4025282d3118051b601b23a1  0001-board-purism-librem5-Enable-WiFi-SW-kill-switch.patch"
+63b6339d2a06b58f47d0f0b6f9a2c0fe25aa8edd523599b630ee3ea683f24ce31150a012e6ec5313b9c247529d0b8813d0c87cb6d0d2e91321c1cf7864cca475  update-u-boot
+acec9f7fa5fb3f4e84c6f6f74794325d5d18ea4557ab98fd0915ba5e41748e338f94604815b2f6d595119359462b48d2ee285b2e4025282d3118051b601b23a1  0001-board-purism-librem5-Enable-WiFi-SW-kill-switch.patch
+"
diff --git a/temp/u-boot-librem5/update-u-boot b/temp/u-boot-librem5/update-u-boot
index e02f74117ad14e667e77efc11285aec96123ca96..95884fef5094be527b3cfb69b7b08b962e04cf05 100644
--- a/temp/u-boot-librem5/update-u-boot
+++ b/temp/u-boot-librem5/update-u-boot
@@ -7,7 +7,7 @@ imagedir=
 
 get_boot_blockdev() {
 	# Find the blockdevice where /boot is mounted from
-	mount | sed -n -E 's:.*(/dev/mmcblk\d)p\d on /boot .*:\1:p'	
+	mount | sed -n -E 's:.*(/dev/mmcblk[0-9])p[0-9] on /boot .*:\1:p'
 }
 
 get_defaults() {