diff --git a/device/testing/device-samsung-crownlte/10-logind-check-graphical.conf b/device/testing/device-samsung-crownlte/10-logind-check-graphical.conf
new file mode 100644
index 0000000000000000000000000000000000000000..dd222eac6db791c1ee6d5f917bfa773046cd720a
--- /dev/null
+++ b/device/testing/device-samsung-crownlte/10-logind-check-graphical.conf
@@ -0,0 +1,5 @@
+# let LightDM start Xorg even though we don't have graphics driver
+# https://github.com/canonical/lightdm/commit/77a7c6b7b8ca896b98ef43826641bdd520650bfb
+
+[LightDM]
+logind-check-graphical=false
diff --git a/device/testing/device-samsung-crownlte/APKBUILD b/device/testing/device-samsung-crownlte/APKBUILD
index 539cb38e3238da32086d2f59d31de1ac5455a044..8d966869d49fe81da9208426fdbdb73f4334c6a7 100644
--- a/device/testing/device-samsung-crownlte/APKBUILD
+++ b/device/testing/device-samsung-crownlte/APKBUILD
@@ -1,8 +1,8 @@
 # Reference: <https://postmarketos.org/devicepkg>
 pkgname=device-samsung-crownlte
 pkgdesc="Samsung Galaxy Note 9"
-pkgver=0.3
-pkgrel=1
+pkgver=0.4
+pkgrel=0
 url="https://postmarketos.org"
 license="MIT"
 arch="aarch64"
@@ -20,6 +20,7 @@ source="
 	stylus.conf
 	hciattach
 	10-hciattach.rules
+	10-logind-check-graphical.conf
 "
 subpackages="
 	$pkgname-nonfree-firmware:nonfree_firmware
@@ -41,16 +42,18 @@ nonfree_firmware() {
 	# hciattach service for Bluetooth
 	mkdir "$subpkgdir"
 	install -Dm755 "$srcdir"/hciattach \
-		"$subpkgdir"/etc/init.d/hciattach
+		-t "$subpkgdir"/etc/init.d
 	install -Dm644 "$srcdir"/10-hciattach.rules \
-		"$subpkgdir"/etc/udev/rules.d/10-hciattach.rules
+		-t "$subpkgdir"/etc/udev/rules.d
 }
 
 x11() {
 	install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
 	depends="xf86-input-evdev"
 	install -Dm644 "$srcdir"/stylus.conf \
-		"$subpkgdir"/etc/X11/xorg.conf.d/stylus.conf
+		-t "$subpkgdir"/etc/X11/xorg.conf.d
+	install -Dm644 "$srcdir"/10-logind-check-graphical.conf \
+		-t "$subpkgdir"/usr/share/lightdm/lightdm.conf.d
 }
 
 sha512sums="
@@ -59,4 +62,5 @@ cec13a1cb076a249eb94d11fb122b1f6b0c3e9558a2ed3c8da3e73a8e2db633131ec8ce838e62da8
 29c2f8fbd67f6aa95a34fc465798be71dc360087b4e4fddbcdc9b43a628de384f48c1b9e6a7b3d41c93954baee3b88f08972f0a827d663b0279b06a4b2908bd2  stylus.conf
 70c4d3b7af9e58729b5caca87c6c0032675c4adfd3852b0e3fc1f866675d503c4f08d3edaf1b1949bf15344840222c1a7ba00384c290fa5e1b7742e1198855a8  hciattach
 58f72bb12532ce23782389bf9e9eb8eb8afe004dd46d11d48b21b6da6a84660846f79d528d9968a1c1be57716577035fd0da59b3fcda4f197599e92f243dbb45  10-hciattach.rules
+00addbea452dd3e2cb90e18793becc47d22118e6b99a79b76eb57db02aa8b00b133569beaea81cce4b39c9e556280c1d6ac8ab687016354e2d189734e38768cf  10-logind-check-graphical.conf
 "