diff --git a/device/testing/device-kobo-clara/APKBUILD b/device/testing/device-kobo-clara/APKBUILD
index 15247d19db9626c9559ca344bcb15886a646326c..83bf69653e0ac30b84d18579879bfe7efabf80a6 100644
--- a/device/testing/device-kobo-clara/APKBUILD
+++ b/device/testing/device-kobo-clara/APKBUILD
@@ -1,13 +1,15 @@
+# Maintainer: Andreas Kemnade <andreas@kemnade.info>
 # Reference: <https://postmarketos.org/devicepkg>
 pkgname=device-kobo-clara
 pkgdesc="Kobo Clara HD"
 pkgver=0.7
-pkgrel=3
+pkgrel=4
 url="https://postmarketos.org"
 license="MIT"
 arch="armv7"
 options="!check !archcheck"
 depends="
+	linux-kobo-clara-mainline
 	kobo-epdc-extractor
 	perl
 	postmarketos-base
@@ -15,16 +17,11 @@ depends="
 	u-boot-tools
 "
 makedepends="devicepkg-dev"
-subpackages="
-	$pkgname-kernel-downstream:kernel_downstream
-	$pkgname-kernel-mainline:kernel_mainline
-	$pkgname-nonfree-firmware:nonfree_firmware
-"
+
 source="
 	deviceinfo
-	modules-initfs.mainline
-	uboot-script-downstream.cmd
-	uboot-script-mainline.cmd
+	modules-initfs
+	uboot-script.cmd
 "
 
 build() {
@@ -33,37 +30,13 @@ build() {
 
 package() {
 	devicepkg_package $startdir $pkgname
-}
-
-kernel_downstream() {
-	pkgdesc="Downstream kernel"
-	depends="linux-kobo-clara"
-	devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
-
 	mkimage -A arm -O linux -T script -n postmarketOS \
-		-d "$srcdir"/uboot-script-downstream.cmd "$srcdir/boot-downstream.scr"
-	install -Dm644 "$srcdir/boot-downstream.scr" "$subpkgdir/boot/boot.scr"
-}
-
-kernel_mainline() {
-	pkgdesc="Close to mainline kernel"
-	depends="linux-kobo-clara-mainline"
-	devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
-
-	mkimage -A arm -O linux -T script -n postmarketOS \
-		-d "$srcdir/uboot-script-mainline.cmd" "$srcdir/boot-mainline.scr"
-	install -Dm644 "$srcdir/boot-mainline.scr" "$subpkgdir/boot/boot.scr"
-}
-
-nonfree_firmware() {
-	pkgdesc="Kobo Clara HD firmware"
-	depends="firmware-kobo-clara"
-	mkdir "$subpkgdir"
+		-d "$srcdir/uboot-script.cmd" "$srcdir/boot.scr"
+	install -Dm644 "$srcdir/boot.scr" "$pkgdir/boot/boot.scr"
 }
 
 sha512sums="
-bdc2528bd09f164870a368caf0b06a6c816b883536c3033384060bcf480ddf987daf38db4b523406e1e591f9cea86c9bb97276d88ebc3b05e2ae6bb53adb4ba8  deviceinfo
-5d53ee902538e53c4fe79eaef8e3800b9d3f73ec70d2a9887ddb11a6715ca76ce17128e3c02c2b6f2f575fb86f15c2415c24466d4b1a031f7a346d0db186dcb1  modules-initfs.mainline
-4bfc2714a2670efc451860bd97d36ba12559e00aed41afdde1ac3e01b41458390358ac7f6bc96a6dee6be6a34f534da52d845b02df0566b25f4868774ef69b1d  uboot-script-downstream.cmd
-9f624e90df6bc6acbd6db03d4319a778443b270e5756a2bc78002df8da19d23a3ea652f3d8da15257552a7381646b83553f794d24f6ef31479d3a16af9ae5e0b  uboot-script-mainline.cmd
+c1eb7552f3163a6a48b699a6c99010914b75fd84b36b1d1a4ffb83d19cc1bbc3355bbe9b1a568ea2a6c2d0e4a87c4a22b7330c454c215b8f8b1edb2b2bac170d  deviceinfo
+5d53ee902538e53c4fe79eaef8e3800b9d3f73ec70d2a9887ddb11a6715ca76ce17128e3c02c2b6f2f575fb86f15c2415c24466d4b1a031f7a346d0db186dcb1  modules-initfs
+7bd9c0aa73b67520b8563b9d4453acafa29adcfed1575d96aea3b0d2e2023cbe9cd7d252b97786efb920a6f05e17a913079353ba481428f16c97d82b42051a2c  uboot-script.cmd
 "
diff --git a/device/testing/device-kobo-clara/deviceinfo b/device/testing/device-kobo-clara/deviceinfo
index f90d384682ba62dcaa6b5a996cd8f76d8bcbc7c3..1210d736e60c29bfa0e8f69069635e6c30a49a8c 100644
--- a/device/testing/device-kobo-clara/deviceinfo
+++ b/device/testing/device-kobo-clara/deviceinfo
@@ -8,8 +8,7 @@ deviceinfo_manufacturer="Kobo"
 deviceinfo_codename="kobo-clara"
 deviceinfo_year="2018"
 deviceinfo_arch="armv7"
-deviceinfo_dtb_downstream="imx6sll-e60k02"
-deviceinfo_dtb_mainline="imx6sll-kobo-clarahd"
+deviceinfo_dtb="imx6sll-kobo-clarahd"
 
 # Device related
 deviceinfo_chassis="tablet"
@@ -26,5 +25,4 @@ deviceinfo_generate_legacy_uboot_initfs="true"
 deviceinfo_no_framebuffer="true"
 
 deviceinfo_sd_embed_firmware_step_size="512"
-deviceinfo_sd_embed_firmware_downstream="u-boot/kobo-clara/u-boot.imx:2,firmware/kobo-clara/hwcfg+header.bin:1023,firmware/kobo-clara/ntxfw-E60K00+header.bin:1029,u-boot/kobo-clara/u-boot-env.bin:1536"
-deviceinfo_sd_embed_firmware_mainline="u-boot/kobo-clara/u-boot.imx:2,firmware/kobo-clara/hwcfg+header.bin:1023,u-boot/kobo-clara/u-boot-env.bin:1536"
+deviceinfo_sd_embed_firmware="u-boot/kobo-clara/u-boot.imx:2,u-boot/kobo-clara/u-boot-env.bin:1536"
diff --git a/device/testing/device-kobo-clara/modules-initfs.mainline b/device/testing/device-kobo-clara/modules-initfs
similarity index 100%
rename from device/testing/device-kobo-clara/modules-initfs.mainline
rename to device/testing/device-kobo-clara/modules-initfs
diff --git a/device/testing/device-kobo-clara/uboot-script-mainline.cmd b/device/testing/device-kobo-clara/uboot-script.cmd
similarity index 67%
rename from device/testing/device-kobo-clara/uboot-script-mainline.cmd
rename to device/testing/device-kobo-clara/uboot-script.cmd
index a402847d8c8bb9f32c5d2259c127e12386e37796..c1640aca44ab9da1cb4246a964684cf6a67ec5cf 100644
--- a/device/testing/device-kobo-clara/uboot-script-mainline.cmd
+++ b/device/testing/device-kobo-clara/uboot-script.cmd
@@ -1,9 +1,5 @@
 setenv bootargs console=ttymxc0,115200
 
-# This must be called first, otherwise bootz does not work correctly.
-# The actual kernel is loaded over this below.
-load_ntxkernel
-
 echo Loading kernel
 load mmc 0:1 0x80800000 vmlinuz
 
diff --git a/device/testing/u-boot-kobo-clara/APKBUILD b/device/testing/u-boot-kobo-clara/APKBUILD
index 63813442cf725fe428433c8b5fdeb126ad65e521..ee1eebe3f81d897f2c5229cea14ddf7afc5543be 100644
--- a/device/testing/u-boot-kobo-clara/APKBUILD
+++ b/device/testing/u-boot-kobo-clara/APKBUILD
@@ -1,36 +1,37 @@
+# Maintainer: Andreas Kemnade <andreas@kemnade.info>
 # Reference: <https://postmarketos.org/devicepkg>
 pkgname=u-boot-kobo-clara
-pkgver=2016.03
+pkgver=2020.10
 pkgrel=0
 pkgdesc="U-Boot for Kobo Clara HD"
 arch="armv7"
 _carch="arm"
 license="GPL-2.0"
-url="https://github.com/pmsourcedump/kobo_clara_uboot"
-options="!check"
+url="https://github.com/akemnade/u-boot-fslc"
+makedepends="$depends_dev bc dtc bison flex"
+options="!check !tracedeps pmb:cross-native"
 
-_repository="kobo_clara_uboot"
-_commit="5af329fef886e21b777426d7bf5c6162e2317de7"
+_repository="u-boot-fslc"
+_commit="fcf25705fc8b57cb22c81b2d352e9a06269911be"
 source="
-	$pkgname-$_commit.tar.gz::https://github.com/pmsourcedump/$_repository/archive/$_commit.tar.gz
+	$pkgname-$_commit.tar.gz::https://github.com/akemnade/$_repository/archive/$_commit.tar.gz
 	u-boot-env.txt
 "
 
 builddir="$srcdir/$_repository-$_commit"
 
 build() {
-	make ARCH="$_carch" mx6sll_ntx_lpddr2_512m_config
+	make ARCH="$_carch" mx6sllclarahd_defconfig
 	make ARCH="$_carch"
 	tools/mkenvimage -p 0 -s 8192 -o u-boot-env.bin "$srcdir/u-boot-env.txt"
 }
 
 package() {
-	install -D -m644 "$builddir/u-boot.bin" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot.bin"
-	install -D -m644 "$builddir/u-boot.imx" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot.imx"
+	install -D -m644 "$builddir/u-boot-dtb.imx" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot.imx"
 	install -D -m644 "$builddir/u-boot-env.bin" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot-env.bin"
 }
 
 sha512sums="
-1712f5a922b44a8b80e49e00969f0948cd62864adedfb419d9d2f6ccf765b432f8632787f7c6d1502ec0aa6afb7b27bf4193733c2345ff4a0378b43b5b10643a  u-boot-kobo-clara-5af329fef886e21b777426d7bf5c6162e2317de7.tar.gz
-43c006f8198ac61e5c73dd4a2d583c5ab1da76b76492be9bee385096bdf33e3a42c8058707e8c2f61342faae152ba57f5046909d9ed403f74589d6604f77eb0d  u-boot-env.txt
+6a9c3f5d2ad806ab9529f0c8fc19213098aae620c5bf34e5cc273453bf007266a674489deff18ffa82e8826280192dbc443b024a3f878836021ae6c062be4189  u-boot-kobo-clara-fcf25705fc8b57cb22c81b2d352e9a06269911be.tar.gz
+ca8237a86da93dfea62355cfbb8dbe4104c2f3aea71b4c36d5418e6aef6ead32e9d23e4731b8ff64b4a73ca563b0323087384de10d4946afd657dce4cc7c6fee  u-boot-env.txt
 "
diff --git a/device/testing/u-boot-kobo-clara/u-boot-env.txt b/device/testing/u-boot-kobo-clara/u-boot-env.txt
index 083a0693c2487e598126e76e5cfef32bf3673987..acd851bfc06821210c6855a225f76f20b9fade23 100644
--- a/device/testing/u-boot-kobo-clara/u-boot-env.txt
+++ b/device/testing/u-boot-kobo-clara/u-boot-env.txt
@@ -1,2 +1,2 @@
 # Load actual boot script from the boot partition
-bootcmd=load mmc 0:1 0x80800000 boot.scr ; source
+bootcmd=load mmc 0:1 0x80800000 boot.scr ; source 0x80800000
diff --git a/device/unmaintained/device-kobo-clara-downstream/APKBUILD b/device/unmaintained/device-kobo-clara-downstream/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..cf23eeb13ec558314fb476fcd6d2f85af10e5ca5
--- /dev/null
+++ b/device/unmaintained/device-kobo-clara-downstream/APKBUILD
@@ -0,0 +1,46 @@
+# Unmaintained: Downstream port, maybe useful for EPDC performance improvement
+# needs special userspace to show up anything
+# Reference: <https://postmarketos.org/devicepkg>
+pkgname=device-kobo-clara-downstream
+pkgdesc="Kobo Clara HD downstream"
+pkgver=0.1
+pkgrel=0
+url="https://postmarketos.org"
+license="MIT"
+arch="armv7"
+options="!check !archcheck"
+depends="
+	postmarketos-base
+	u-boot-kobo-clara-downstream
+	u-boot-tools
+	linux-kobo-clara-downstream
+"
+makedepends="devicepkg-dev"
+subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
+
+source="
+	deviceinfo
+	uboot-script-downstream.cmd
+"
+
+build() {
+	devicepkg_build $startdir $pkgname
+}
+
+package() {
+	devicepkg_package $startdir $pkgname
+	mkimage -A arm -O linux -T script -n postmarketOS \
+		-d "$srcdir"/uboot-script-downstream.cmd "$srcdir/boot-downstream.scr"
+	install -Dm644 "$srcdir/boot-downstream.scr" "$pkgdir/boot/boot.scr"
+}
+
+nonfree_firmware() {
+	pkgdesc="Kobo Clara HD firmware"
+	depends="firmware-kobo-clara-downstream"
+	mkdir "$subpkgdir"
+}
+
+sha512sums="
+84b9e5385b7fd77af6891b31d7e95ec424645f741d54168d3d38f6f703071d622829d9f7cf5a29136bf6eb9ec5b2a50a05efe76ddc3e047bb4a69e197fbfde24  deviceinfo
+4bfc2714a2670efc451860bd97d36ba12559e00aed41afdde1ac3e01b41458390358ac7f6bc96a6dee6be6a34f534da52d845b02df0566b25f4868774ef69b1d  uboot-script-downstream.cmd
+"
diff --git a/device/unmaintained/device-kobo-clara-downstream/deviceinfo b/device/unmaintained/device-kobo-clara-downstream/deviceinfo
new file mode 100644
index 0000000000000000000000000000000000000000..86d6a4183188db55af634117b1a89eaf7cbddf23
--- /dev/null
+++ b/device/unmaintained/device-kobo-clara-downstream/deviceinfo
@@ -0,0 +1,28 @@
+# Reference: <https://postmarketos.org/deviceinfo>
+# Please use double quotes only. You can source this file in shell
+# scripts.
+
+deviceinfo_format_version="0"
+deviceinfo_name="Kobo Clara HD"
+deviceinfo_manufacturer="Kobo"
+deviceinfo_codename="kobo-clara-downstream"
+deviceinfo_year="2018"
+deviceinfo_arch="armv7"
+deviceinfo_dtb="imx6sll-e60k02"
+
+# Device related
+deviceinfo_chassis="tablet"
+deviceinfo_keyboard="false"
+deviceinfo_external_storage="true"
+deviceinfo_screen_width="1072"
+deviceinfo_screen_height="1448"
+
+# Bootloader related
+deviceinfo_flash_method="none"
+deviceinfo_boot_part_start="49152"
+deviceinfo_getty="ttymxc0;115200"
+deviceinfo_generate_legacy_uboot_initfs="true"
+deviceinfo_no_framebuffer="true"
+
+deviceinfo_sd_embed_firmware_step_size="512"
+deviceinfo_sd_embed_firmware="u-boot/kobo-clara/u-boot.imx:2,firmware/kobo-clara/hwcfg+header.bin:1023,firmware/kobo-clara/ntxfw-E60K00+header.bin:1029,u-boot/kobo-clara/u-boot-env.bin:1536"
diff --git a/device/testing/device-kobo-clara/uboot-script-downstream.cmd b/device/unmaintained/device-kobo-clara-downstream/uboot-script-downstream.cmd
similarity index 100%
rename from device/testing/device-kobo-clara/uboot-script-downstream.cmd
rename to device/unmaintained/device-kobo-clara-downstream/uboot-script-downstream.cmd
diff --git a/device/testing/firmware-kobo-clara/APKBUILD b/device/unmaintained/firmware-kobo-clara-downstream/APKBUILD
similarity index 93%
rename from device/testing/firmware-kobo-clara/APKBUILD
rename to device/unmaintained/firmware-kobo-clara-downstream/APKBUILD
index b65d18b5429c0ef638dfe9dc631b7f7fc20baa45..88698281a5e4669a4c04208bfd05b138e05a4a76 100644
--- a/device/testing/firmware-kobo-clara/APKBUILD
+++ b/device/unmaintained/firmware-kobo-clara-downstream/APKBUILD
@@ -1,4 +1,5 @@
-pkgname=firmware-kobo-clara
+# Unmaintained: not needed by mainline kernel, describes only the hardware
+pkgname=firmware-kobo-clara-downstream
 pkgver=4.26.16704
 pkgrel=0
 pkgdesc="Kobo Clara firmware"
diff --git a/device/testing/firmware-kobo-clara/hwcfg.bin b/device/unmaintained/firmware-kobo-clara-downstream/hwcfg.bin
similarity index 100%
rename from device/testing/firmware-kobo-clara/hwcfg.bin
rename to device/unmaintained/firmware-kobo-clara-downstream/hwcfg.bin
diff --git a/device/testing/linux-kobo-clara/APKBUILD b/device/unmaintained/linux-kobo-clara-downstream/APKBUILD
similarity index 95%
rename from device/testing/linux-kobo-clara/APKBUILD
rename to device/unmaintained/linux-kobo-clara-downstream/APKBUILD
index 7a4e2e1400a3f2a5818e3b964403af54fe785af4..db2a36a604e42ab2288ae99fed1ef57da680bba2 100644
--- a/device/testing/linux-kobo-clara/APKBUILD
+++ b/device/unmaintained/linux-kobo-clara-downstream/APKBUILD
@@ -1,9 +1,10 @@
+# Unmaintained: Mainline kernel is mature, only interesting for EPDC optimization
 # Reference: <https://postmarketos.org/vendorkernel>
 # Kernel config based on: arch/arm/configs/imx_v7_kobo_defconfig
 
-pkgname=linux-kobo-clara
+pkgname=linux-kobo-clara-downstream
 pkgver=4.1.15
-pkgrel=4
+pkgrel=0
 pkgdesc="Kobo Clara HD kernel fork"
 arch="armv7"
 _carch="arm"
diff --git a/device/testing/linux-kobo-clara/config-kobo-clara.armv7 b/device/unmaintained/linux-kobo-clara-downstream/config-kobo-clara.armv7
similarity index 100%
rename from device/testing/linux-kobo-clara/config-kobo-clara.armv7
rename to device/unmaintained/linux-kobo-clara-downstream/config-kobo-clara.armv7
diff --git a/device/testing/linux-kobo-clara/fbdev-mxc-epdc-replace-blob-by-source-functions.patch b/device/unmaintained/linux-kobo-clara-downstream/fbdev-mxc-epdc-replace-blob-by-source-functions.patch
similarity index 100%
rename from device/testing/linux-kobo-clara/fbdev-mxc-epdc-replace-blob-by-source-functions.patch
rename to device/unmaintained/linux-kobo-clara-downstream/fbdev-mxc-epdc-replace-blob-by-source-functions.patch
diff --git a/device/testing/linux-kobo-clara/fix-device-tree.patch b/device/unmaintained/linux-kobo-clara-downstream/fix-device-tree.patch
similarity index 100%
rename from device/testing/linux-kobo-clara/fix-device-tree.patch
rename to device/unmaintained/linux-kobo-clara-downstream/fix-device-tree.patch
diff --git a/device/testing/linux-kobo-clara/gcc10-extern_YYLOC_global_declaration.patch b/device/unmaintained/linux-kobo-clara-downstream/gcc10-extern_YYLOC_global_declaration.patch
similarity index 100%
rename from device/testing/linux-kobo-clara/gcc10-extern_YYLOC_global_declaration.patch
rename to device/unmaintained/linux-kobo-clara-downstream/gcc10-extern_YYLOC_global_declaration.patch
diff --git a/device/testing/linux-kobo-clara/gcc7-give-up-on-ilog2-const-optimizations.patch b/device/unmaintained/linux-kobo-clara-downstream/gcc7-give-up-on-ilog2-const-optimizations.patch
similarity index 100%
rename from device/testing/linux-kobo-clara/gcc7-give-up-on-ilog2-const-optimizations.patch
rename to device/unmaintained/linux-kobo-clara-downstream/gcc7-give-up-on-ilog2-const-optimizations.patch
diff --git a/device/testing/linux-kobo-clara/gcc8-fix-put-user.patch b/device/unmaintained/linux-kobo-clara-downstream/gcc8-fix-put-user.patch
similarity index 100%
rename from device/testing/linux-kobo-clara/gcc8-fix-put-user.patch
rename to device/unmaintained/linux-kobo-clara-downstream/gcc8-fix-put-user.patch
diff --git a/device/unmaintained/u-boot-kobo-clara-downstream/APKBUILD b/device/unmaintained/u-boot-kobo-clara-downstream/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..271daa09ff5da4998851863a4bc38c82ac22f10a
--- /dev/null
+++ b/device/unmaintained/u-boot-kobo-clara-downstream/APKBUILD
@@ -0,0 +1,37 @@
+# Unmaintained: does weird things, not needed for mainline kernels
+# Reference: <https://postmarketos.org/devicepkg>
+pkgname=u-boot-kobo-clara-downstream
+pkgver=2016.03
+pkgrel=0
+pkgdesc="U-Boot for Kobo Clara HD"
+arch="armv7"
+_carch="arm"
+license="GPL-2.0"
+url="https://github.com/pmsourcedump/kobo_clara_uboot"
+options="!check"
+
+_repository="kobo_clara_uboot"
+_commit="5af329fef886e21b777426d7bf5c6162e2317de7"
+source="
+	$pkgname-$_commit.tar.gz::https://github.com/pmsourcedump/$_repository/archive/$_commit.tar.gz
+	u-boot-env.txt
+"
+
+builddir="$srcdir/$_repository-$_commit"
+
+build() {
+	make ARCH="$_carch" mx6sll_ntx_lpddr2_512m_config
+	make ARCH="$_carch"
+	tools/mkenvimage -p 0 -s 8192 -o u-boot-env.bin "$srcdir/u-boot-env.txt"
+}
+
+package() {
+	install -D -m644 "$builddir/u-boot.bin" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot.bin"
+	install -D -m644 "$builddir/u-boot.imx" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot.imx"
+	install -D -m644 "$builddir/u-boot-env.bin" "$pkgdir/usr/share/u-boot/kobo-clara/u-boot-env.bin"
+}
+
+sha512sums="
+1712f5a922b44a8b80e49e00969f0948cd62864adedfb419d9d2f6ccf765b432f8632787f7c6d1502ec0aa6afb7b27bf4193733c2345ff4a0378b43b5b10643a  u-boot-kobo-clara-5af329fef886e21b777426d7bf5c6162e2317de7.tar.gz
+43c006f8198ac61e5c73dd4a2d583c5ab1da76b76492be9bee385096bdf33e3a42c8058707e8c2f61342faae152ba57f5046909d9ed403f74589d6604f77eb0d  u-boot-env.txt
+"
diff --git a/device/unmaintained/u-boot-kobo-clara-downstream/u-boot-env.txt b/device/unmaintained/u-boot-kobo-clara-downstream/u-boot-env.txt
new file mode 100644
index 0000000000000000000000000000000000000000..083a0693c2487e598126e76e5cfef32bf3673987
--- /dev/null
+++ b/device/unmaintained/u-boot-kobo-clara-downstream/u-boot-env.txt
@@ -0,0 +1,2 @@
+# Load actual boot script from the boot partition
+bootcmd=load mmc 0:1 0x80800000 boot.scr ; source