diff --git a/temp/libcamera/0001-libcamera-debayer_cpu-Sync-DMABUFs.patch b/temp/libcamera/0001-libcamera-debayer_cpu-Sync-DMABUFs.patch
new file mode 100644
index 0000000000000000000000000000000000000000..27ea794bdda500db044e0f6fa2b83fc1456bf6de
--- /dev/null
+++ b/temp/libcamera/0001-libcamera-debayer_cpu-Sync-DMABUFs.patch
@@ -0,0 +1,104 @@
+From cde234eb9b33b1f38848cb4abc196f609be37a3a Mon Sep 17 00:00:00 2001
+From: Robert Mader <robert.mader@collabora.com>
+Date: Fri, 20 Sep 2024 12:49:15 +0100
+Subject: [PATCH] libcamera: debayer_cpu: Sync DMABUFs
+
+Using `DMA_BUF_IOCTL_SYNC` is required for DMABUFs in order to ensure
+correct output. Not doing so currently results in occasional tearing
+and/or backlashes in GL/VK clients that use the buffers directly for
+rendering.
+
+An alternative approach to have the sync code in `MappedFrameBuffer` was
+considered but rejected for now, in order to allow clients more
+flexibility.
+
+While the new helper is added to an annoymous namespace, add
+timeDiff to the same namespace and remove the static definition as a
+drive by.
+
+Signed-off-by: Robert Mader <robert.mader@collabora.com>
+Tested-by: Milan Zamazal <mzamazal@redhat.com> # Debix
+Tested-by: Hans de Goede <hdegoede@redhat.com> # IPU6 + ov2740
+Tested-by: Kieran Bingham <kieran.bingham@ideasonboard.com> # Lenovo X13s + OV5675
+Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
+Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
+Reviewed-by: Nicolas Dufresne <nicolas.dufresne@collabora.com>
+Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
+---
+ src/libcamera/software_isp/debayer_cpu.cpp | 32 +++++++++++++++++++++-
+ 1 file changed, 31 insertions(+), 1 deletion(-)
+
+diff --git a/src/libcamera/software_isp/debayer_cpu.cpp b/src/libcamera/software_isp/debayer_cpu.cpp
+index f8d2677d..686a3b64 100644
+--- a/src/libcamera/software_isp/debayer_cpu.cpp
++++ b/src/libcamera/software_isp/debayer_cpu.cpp
+@@ -12,8 +12,11 @@
+ #include "debayer_cpu.h"
+ 
+ #include <stdlib.h>
++#include <sys/ioctl.h>
+ #include <time.h>
+ 
++#include <linux/dma-buf.h>
++
+ #include <libcamera/formats.h>
+ 
+ #include "libcamera/internal/bayer_format.h"
+@@ -725,12 +728,33 @@ void DebayerCpu::process4(const uint8_t *src, uint8_t *dst)
+ 	}
+ }
+ 
+-static inline int64_t timeDiff(timespec &after, timespec &before)
++namespace {
++
++void syncBufferForCPU(FrameBuffer *buffer, uint64_t syncFlags)
++{
++	for (const FrameBuffer::Plane &plane : buffer->planes()) {
++		const int fd = plane.fd.get();
++		struct dma_buf_sync sync = { syncFlags };
++		int ret;
++
++		ret = ioctl(fd, DMA_BUF_IOCTL_SYNC, &sync);
++		if (ret < 0) {
++			ret = errno;
++			LOG(Debayer, Error)
++				<< "Syncing buffer FD " << fd << " with flags "
++				<< syncFlags << " failed: " << strerror(ret);
++		}
++	}
++}
++
++inline int64_t timeDiff(timespec &after, timespec &before)
+ {
+ 	return (after.tv_sec - before.tv_sec) * 1000000000LL +
+ 	       (int64_t)after.tv_nsec - (int64_t)before.tv_nsec;
+ }
+ 
++} /* namespace */
++
+ void DebayerCpu::process(FrameBuffer *input, FrameBuffer *output, DebayerParams params)
+ {
+ 	timespec frameStartTime;
+@@ -740,6 +764,9 @@ void DebayerCpu::process(FrameBuffer *input, FrameBuffer *output, DebayerParams
+ 		clock_gettime(CLOCK_MONOTONIC_RAW, &frameStartTime);
+ 	}
+ 
++	syncBufferForCPU(input, DMA_BUF_SYNC_START | DMA_BUF_SYNC_READ);
++	syncBufferForCPU(output, DMA_BUF_SYNC_START | DMA_BUF_SYNC_WRITE);
++
+ 	green_ = params.green;
+ 	red_ = swapRedBlueGains_ ? params.blue : params.red;
+ 	blue_ = swapRedBlueGains_ ? params.red : params.blue;
+@@ -767,6 +794,9 @@ void DebayerCpu::process(FrameBuffer *input, FrameBuffer *output, DebayerParams
+ 
+ 	metadata.planes()[0].bytesused = out.planes()[0].size();
+ 
++	syncBufferForCPU(output, DMA_BUF_SYNC_END | DMA_BUF_SYNC_WRITE);
++	syncBufferForCPU(input, DMA_BUF_SYNC_END | DMA_BUF_SYNC_READ);
++
+ 	/* Measure before emitting signals */
+ 	if (measuredFrames_ < DebayerCpu::kLastFrameToMeasure &&
+ 	    ++measuredFrames_ > DebayerCpu::kFramesToSkip) {
+-- 
+2.46.1
+
diff --git a/temp/libcamera/APKBUILD b/temp/libcamera/APKBUILD
index a2afaae7036a28311c6aac9da56c044a43b1c83d..00ba8c9ae7cb31c0f5c02a91c1d5d0bd73e6ab76 100644
--- a/temp/libcamera/APKBUILD
+++ b/temp/libcamera/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=libcamera
 pkgver=9999
 _pkgver=0.3.1
-pkgrel=3
+pkgrel=4
 pkgdesc="Linux camera framework"
 url="https://libcamera.org/"
 arch="all"
@@ -47,6 +47,7 @@ source="https://gitlab.freedesktop.org/camera/libcamera/-/archive/v$_pkgver/libc
 	0002-libcamera-simple-Force-disable-softwareISP-for-milli.patch
 	0003-libcamera-simple-Enable-softISP-for-the-Pinephone.patch
 	0004-libcamera-simple-Skip-hwISP-formats-if-swISP-is-acti.patch
+	0001-libcamera-debayer_cpu-Sync-DMABUFs.patch
 	qcam.desktop
 	90-libcamera.rules
 	"
@@ -152,6 +153,7 @@ a5809b7664685bb44ca05a722655d8b94991c90306b69be1e7b135a1ad72699ab69b0e9bf7edbee0
 979259bb16112b1fbbec0543a1d642a65e62f24ba10b229caffe68398da343160d98c2811f923877ce5d2c9a3c8a53205feb2eb4fbaf921612bbc5419d6be1df  0002-libcamera-simple-Force-disable-softwareISP-for-milli.patch
 47616a06fad66df31e29ebd9c024c95bdea542dd1f5c0ed448a242e35a6d9909f973a74332bfe084478c91ac7a2d778d7b10270cd493dba07bb8d5ad34e9544c  0003-libcamera-simple-Enable-softISP-for-the-Pinephone.patch
 685b8cfae3bb9a000d95a36d9daf9d4ff8770fd877e43c69f0fc0768ebd457282f03ec6ad9bf3a33e72765665bbd642af5db66c1a82aac249ce8c2522291dee6  0004-libcamera-simple-Skip-hwISP-formats-if-swISP-is-acti.patch
+bbe991bc605b79b8c35a49571398ccf21bd18cb21b62f46340cbbf4fc3ec80226d6573cd0b98ebebb9b210ea37ca21a653626307dcd69c6baf2bebce1b5e8a39  0001-libcamera-debayer_cpu-Sync-DMABUFs.patch
 22167a4eceb6d1b40b0b7c45fdf116c71684f5340de7f767535cb8e160ad9d2ae0f00cb3d461f73a344520a48a4641cf46226841d78bee06bfbfd2a91337f754  qcam.desktop
 cb4eb19eec766f1b8667a8b7c9d5f7d44a2dce79fddfdf3b6e3d1849066cebe79f82566bdcf6659c7ddf4faaf233d5adac10cda636935785e5305e2b7e9b34a9  90-libcamera.rules
 "