Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
80a62d7a
Commit
80a62d7a
authored
5 years ago
by
Minecrell
Browse files
Options
Downloads
Patches
Plain Diff
CI: debug
parent
acc894cb
No related branches found
No related tags found
No related merge requests found
Pipeline
#191333
passed
5 years ago
Stage: first
Stage: second
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
.gitlab-ci/check_changed_aports_versions.py
+1
-0
1 addition, 0 deletions
.gitlab-ci/check_changed_aports_versions.py
.gitlab-ci/common.py
+7
-2
7 additions, 2 deletions
.gitlab-ci/common.py
with
8 additions
and
2 deletions
.gitlab-ci/check_changed_aports_versions.py
+
1
−
0
View file @
80a62d7a
...
...
@@ -124,6 +124,7 @@ if __name__ == "__main__":
# Get and print modified packages
common
.
add_upstream_git_remote
()
packages
=
common
.
get_changed_packages
()
print
(
f
"
Changed packages:
{
packages
}
"
)
# Verify modified package count
common
.
get_changed_packages_sanity_check
(
len
(
packages
))
...
...
This diff is collapsed.
Click to expand it.
.gitlab-ci/common.py
+
7
−
2
View file @
80a62d7a
...
...
@@ -119,12 +119,17 @@ def get_changed_packages(with_directory=False):
if
"
/
"
not
in
file
or
file
.
startswith
(
"
.
"
)
or
not
os
.
path
.
exists
(
file
):
continue
# Check that directory actually refers to a package (contains APKBUILD)
dirname
,
filename
=
os
.
path
.
split
(
file
)
if
filename
!=
"
APKBUILD
"
and
not
os
.
path
.
exists
(
os
.
path
.
join
(
dirname
,
"
APKBUILD
"
)):
print
(
f
"
Note: Changed file outside of any package:
{
file
}
"
)
continue
# Add to the ret set (removes duplicated automatically)
if
with_directory
:
ret
.
add
(
file
)
else
:
# device/testing/device-something/APKBUILD -> device-something
ret
.
add
(
file
.
split
(
"
/
"
)[
-
2
])
ret
.
add
(
os
.
path
.
basename
(
dir
))
return
ret
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment