Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
acc4a4fc
Commit
acc4a4fc
authored
5 years ago
by
Lofenyy Wilson
Committed by
lofenyy
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
samsung-kylessopen: Modernized APKBUILD
parent
271aba5d
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
device/linux-samsung-kylessopen/APKBUILD
+10
-29
10 additions, 29 deletions
device/linux-samsung-kylessopen/APKBUILD
with
10 additions
and
29 deletions
device/linux-samsung-kylessopen/APKBUILD
+
10
−
29
View file @
acc4a4fc
# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm/configs/franken_defconfig
pkgname
=
"linux-samsung-kylessopen"
pkgver
=
3.0.101
pkgrel
=
3
pkgdesc
=
"Galaxy Trend kernel fork"
pkgrel
=
4
pkgdesc
=
"
Samsung
Galaxy Trend kernel fork"
arch
=
"armhf"
_carch
=
"arm"
_flavor
=
"samsung-kylessopen"
url
=
"https://kernel.org"
license
=
"GPL
2
"
license
=
"GPL
-2.0-only
"
options
=
"!strip !check !tracedeps"
makedepends
=
"perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev lzo xz gcc6"
makedepends
=
"perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev
devicepkg-dev
lzo xz gcc6"
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
# request if you find out that it is booting working with newer GCCs as
...
...
@@ -22,36 +23,20 @@ if [ "${CC:0:5}" != "gcc6-" ]; then
fi
# Source
_repository
=
"FrankenKernel"
_commit
=
"d0e853abec2d7be79f5d9b319273a0b66046b125"
_kernel
=
"pavlepiramida-frankenkernel"
_config
=
"config-
${
_flavor
}
.
${
arch
}
"
source
=
"
$pkgname
-
$_commit
.tar.gz::https://git
hu
b.com/
pavlepiramida/
${
_repository
}
/archive/
${
_commit
}
.tar.gz
$pkgname
.tar.gz::https://git
la
b.com/
samsung-kylessopen-kernels/
$_kernel
/-/archive/master/
$_kernel
-master
.tar.gz
$_config
compiler-gcc6.h
gcc5.patch
0001-fix-video-argb-setting.patch
"
builddir
=
"
$srcdir
/
$
{
_repository
}
-
${
_commit
}
"
builddir
=
"
$srcdir
/
$
_kernel
-master
"
prepare
()
{
default_prepare
# gcc6 support
cp
-v
"
$srcdir
/compiler-gcc6.h"
"
$builddir
/include/linux/"
# Remove -Werror from all makefiles
local
i
local
makefiles
=
"
$(
find
.
-type
f
-name
Makefile
)
$(
find
.
-type
f
-name
Kbuild
)
"
for
i
in
$makefiles
;
do
sed
-i
's/-Werror-/-W/g'
"
$i
"
sed
-i
's/-Werror//g'
"
$i
"
done
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
cp
"
$srcdir
"
/
$_config
"
$builddir
"
/.config
yes
""
| make
ARCH
=
"
$_carch
"
HOSTCC
=
"
$HOSTCC
"
oldconfig
downstreamkernel_prepare
"
$srcdir
"
"
$builddir
"
"
$_config
"
"
$_carch
"
"
$HOSTCC
"
}
build
()
{
...
...
@@ -78,13 +63,9 @@ package() {
error
"Could not find zImage in
$PWD
!"
return
1
fi
echo
"--[ Installing modules ]--"
cd
"
$builddir
"
make
ARCH
=
"
$_carch
"
CC
=
"
${
CC
:-
gcc
}
"
\
INSTALL_MOD_PATH
=
"
$pkgdir
"
KBUILD_BUILD_VERSION
=
"
$((
pkgrel
+
1
))
-postmarketOS"
modules_install
}
sha512sums
=
"
22c89caaae880c64fb1a9e25ff5c65813b4bfa9a27ca4310fe9da17c4a1bfff2b49b4516f48fd30a4ccb1a185fc525b0c5967b4f18bfd3c2f8cfce66c8a268bd linux-samsung-kylessopen-d0e853abec2d7be79f5d9b319273a0b66046b125
.tar.gz
sha512sums
=
"
b25f1dd36a2dc73322e0e63ede0e4c706603a31d81423ee34e6027c3bcffb283aa135fa3f020032462125ae5fdd004da000e4c15eaceb75408c43d655128eff7 linux-samsung-kylessopen
.tar.gz
b28a411506adb2540c3de93b4d7529d25efb96ab93b31417bd78c4deea3b1e4f63bd4240d090dd27c54040e9c937a27bc8702d471be414722265d2dbd1cf4630 config-samsung-kylessopen.armhf
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
db5d16e03a93b453c98882dcd08b7a4cd96c126393365d8916d9cf045e8725831f70ea841756526af7bead36a74301024e3c569c438442906e079fea2ac0a022 gcc5.patch
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment