Skip to content
Snippets Groups Projects
Verified Commit 250904dd authored by Robert Mader's avatar Robert Mader Committed by Newbyte
Browse files

temp/libcamera: Add tuning files for IMX371 and IMX376 (MR 6299)

Only containing black levels for now.

This should only slightly increase image quality, but apparently also
works around a bug in libcamera making the output all black, with
occasional purple or red flashes.
[ci:skip-build]: already built successfully in CI
parent b9d048b6
No related branches found
No related tags found
No related merge requests found
From b221b929e04d63b529eadb625d9f9d04a224d402 Mon Sep 17 00:00:00 2001
From: Robert Mader <robert.mader@collabora.com>
Date: Sat, 8 Mar 2025 10:38:06 +0100
Subject: [PATCH 1/2] ipa/simple: Add tuning file for IMX371
The value is guessed from similar IMX sensors.
---
src/ipa/simple/data/imx371.yaml | 11 +++++++++++
src/ipa/simple/data/meson.build | 1 +
2 files changed, 12 insertions(+)
create mode 100644 src/ipa/simple/data/imx371.yaml
diff --git a/src/ipa/simple/data/imx371.yaml b/src/ipa/simple/data/imx371.yaml
new file mode 100644
index 000000000..f7d01b738
--- /dev/null
+++ b/src/ipa/simple/data/imx371.yaml
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: CC0-1.0
+%YAML 1.1
+---
+version: 1
+algorithms:
+ - BlackLevel:
+ blackLevel: 4096
+ - Awb:
+ - Lut:
+ - Agc:
+...
diff --git a/src/ipa/simple/data/meson.build b/src/ipa/simple/data/meson.build
index cae83a3d5..19f90c976 100644
--- a/src/ipa/simple/data/meson.build
+++ b/src/ipa/simple/data/meson.build
@@ -4,6 +4,7 @@ conf_files = files([
'hi846.yaml',
'imx355.yaml',
'imx363.yaml',
+ 'imx371.yaml',
's5k3l6xx.yaml',
'uncalibrated.yaml',
])
--
2.48.1
From e277028b17e4b9454a50114a93dfa2722ef0a9f7 Mon Sep 17 00:00:00 2001
From: Robert Mader <robert.mader@collabora.com>
Date: Sat, 8 Mar 2025 10:39:44 +0100
Subject: [PATCH 2/2] ipa/simple: Add tuning file for IMX376
The value is guessed from similar IMX sensors.
---
src/ipa/simple/data/imx376.yaml | 11 +++++++++++
src/ipa/simple/data/meson.build | 1 +
2 files changed, 12 insertions(+)
create mode 100644 src/ipa/simple/data/imx376.yaml
diff --git a/src/ipa/simple/data/imx376.yaml b/src/ipa/simple/data/imx376.yaml
new file mode 100644
index 000000000..f7d01b738
--- /dev/null
+++ b/src/ipa/simple/data/imx376.yaml
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: CC0-1.0
+%YAML 1.1
+---
+version: 1
+algorithms:
+ - BlackLevel:
+ blackLevel: 4096
+ - Awb:
+ - Lut:
+ - Agc:
+...
diff --git a/src/ipa/simple/data/meson.build b/src/ipa/simple/data/meson.build
index 19f90c976..e0c8e443a 100644
--- a/src/ipa/simple/data/meson.build
+++ b/src/ipa/simple/data/meson.build
@@ -5,6 +5,7 @@ conf_files = files([
'imx355.yaml',
'imx363.yaml',
'imx371.yaml',
+ 'imx376.yaml',
's5k3l6xx.yaml',
'uncalibrated.yaml',
])
--
2.48.1
......@@ -3,7 +3,7 @@
pkgname=libcamera
pkgver=9999
_pkgver=0.4.0
pkgrel=10
pkgrel=11
pkgdesc="Linux camera framework"
url="https://libcamera.org/"
arch="all"
......@@ -52,6 +52,8 @@ source="https://gitlab.freedesktop.org/camera/libcamera/-/archive/v$_pkgver/libc
0008-ipa-simple-Add-tuning-file-for-IMX363.patch
0009-ipa-simple-Add-tuning-file-for-s5k3l6xx.patch
0010-ipa-simple-Add-tuning-file-for-hi846.patch
0011-ipa-simple-Add-tuning-file-for-IMX371.patch
0012-ipa-simple-Add-tuning-file-for-IMX376.patch
qcam.desktop
"
builddir="$srcdir/$pkgname-v$_pkgver"
......@@ -158,5 +160,7 @@ add6bd7e641dc085921133bba7302740b1cf71c18a26f13e2c2c7bbbfb830cdee92e7e4603141cd7
a803793ed16eca2563bbbae84713dab6a5f3090ae6ae5f755393c0b2203bf4471f4f37b6fc69991894ced60a8607d671262a51a49f02730931e43c6a4a3e9635 0008-ipa-simple-Add-tuning-file-for-IMX363.patch
374366eeb471f2034319caa02df182d363187e4f1a0a8ec1dedfe39b3765cc19602c62df7881b99005b004395314e3f737c67a494d44a305e4afb2d0f0085115 0009-ipa-simple-Add-tuning-file-for-s5k3l6xx.patch
6ac1989989fbc7d560948d66f59f62a4f28c8b398398d204cf4323c5db5f1eb45d5caa0f287f4f95956a1346e1346d5e1cf2d3577d46c2588b38a15bdcdb3b76 0010-ipa-simple-Add-tuning-file-for-hi846.patch
7bdc0d5f8904d827ad62e16f4ea5d8bf72262bbbf3260634d59884060b4b8592262fc443bd380383bbf4f1eeb4f9da1bcd7080f04a964cc008ad570bedca81c4 0011-ipa-simple-Add-tuning-file-for-IMX371.patch
0e51325a3216dea7fabdcd329b03d2c6493f3e2665e2937e48d94e3fe28d8d01f3077417e8bf08748259aa07b7550eaa484811d17e08edf1817c5bc5c673baf5 0012-ipa-simple-Add-tuning-file-for-IMX376.patch
22167a4eceb6d1b40b0b7c45fdf116c71684f5340de7f767535cb8e160ad9d2ae0f00cb3d461f73a344520a48a4641cf46226841d78bee06bfbfd2a91337f754 qcam.desktop
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment