Skip to content
Snippets Groups Projects
Commit 89ffc0b0 authored by faveoled's avatar faveoled
Browse files

huawei-lual-21

parent 153cafa7
Branches huawei-lua-l21
No related tags found
No related merge requests found
Showing
with 6895 additions and 0 deletions
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-huawei-lua-l21
pkgdesc="Huawei Y3 II 4G"
pkgver=1
pkgrel=0
url="https://postmarketos.org"
license="MIT"
arch="armv7"
options="!check !archcheck"
depends="
linux-huawei-lua-l21
mkbootimg
postmarketos-base
"
makedepends="devicepkg-dev"
source="
deviceinfo
modules-initfs
"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
sha512sums="
fdbf98b011d8bae4f955f5af0649dd3fdcffaa677c37bd285df6a0d3021ec92f3dc549450a906c1d22a10a49444f9064ad0478a3c4bd3ac59d2a71474325cd90 deviceinfo
e70bae17df23dcaaaea0e2d3616556f04baa23f8ee1357785c0f539bf97282d8ddff53953e155b72689bb73beb38c2da3d08de2a61e866684edfa10a6593885d modules-initfs
"
# Reference: <https://postmarketos.org/deviceinfo>
# Please use double quotes only. You can source this file in shell
# scripts.
deviceinfo_format_version="0"
deviceinfo_name="Huawei Y3 II 4G"
deviceinfo_manufacturer="Huawei"
deviceinfo_codename="huawei-lua-l21"
deviceinfo_year="2016"
deviceinfo_dtb=""
deviceinfo_arch="armv7"
deviceinfo_keyboard="false"
deviceinfo_screen_width="854"
deviceinfo_screen_height="480"
# Device related
deviceinfo_chassis="handset"
deviceinfo_external_storage="true"
# Bootloader related
deviceinfo_flash_method="fastboot"
deviceinfo_kernel_cmdline="pmos.debug-shell bootopt=64S3,32N2,32N2"
deviceinfo_generate_bootimg="true"
deviceinfo_flash_pagesize="2048"
deviceinfo_header_version="0"
deviceinfo_flash_offset_base="0x40000000"
deviceinfo_flash_offset_kernel="0x00008000"
deviceinfo_flash_offset_ramdisk="0x04000000"
deviceinfo_flash_offset_second="0x00f00000"
deviceinfo_flash_offset_tags="0x0e000000"
deviceinfo_create_initfs_extra="true"
\ No newline at end of file
# Remove this file if unnecessary (CHANGEME!)
# This file shall contain a list of modules to be included in the initramfs,
# so that they are available in early boot stages. In general, it should
# include modules to support unlocking FDE (touchscreen, panel, etc),
# USB networking, and telnet in the debug-shell.
# The format is one module name per line. Lines starting with the character
# '#', and empty lines are ignored. If there are multiple kernel variants
# with different initramfs module requirements, one modules-initfs.$variant
# file should be created for each of them.
From 790756c7e0229dedc83bf058ac69633045b1000e Mon Sep 17 00:00:00 2001
From: Nick Desaulniers <ndesaulniers@google.com>
Date: Mon, 4 Nov 2019 19:31:45 +0100
Subject: [PATCH] ARM: 8933/1: replace Sun/Solaris style flag on section directive
It looks like a section directive was using "Solaris style" to declare
the section flags. Replace this with the GNU style so that Clang's
integrated assembler can assemble this directive.
---
diff --git a/arch/arm/boot/compressed/head.S b/arch/arm/boot/compressed/head.S
index 3f25fac..a5606a0 100644
--- a/arch/arm/boot/compressed/head.S
+++ b/arch/arm/boot/compressed/head.S
@@ -109,7 +109,7 @@
#endif
.endm
- .section ".start", #alloc, #execinstr
+ .section ".start", "ax"
/*
* sort out different calling conventions
*/
diff --git a/arch/arm/boot/compressed/piggy.gzip.S b/arch/arm/boot/compressed/piggy.gzip.S
index a68adf9..7de824f 100644
--- a/arch/arm/boot/compressed/piggy.gzip.S
+++ b/arch/arm/boot/compressed/piggy.gzip.S
@@ -1,4 +1,4 @@
- .section .piggydata,#alloc
+ .section .piggydata,"a"
.globl input_data
input_data:
.incbin "arch/arm/boot/compressed/piggy.gzip"
diff --git a/arch/arm/mm/proc-v7.S b/arch/arm/mm/proc-v7.S
index 22ac2a6..68744e1 100644
--- a/arch/arm/mm/proc-v7.S
+++ b/arch/arm/mm/proc-v7.S
@@ -462,7 +462,7 @@ __v7_setup_stack:
string cpu_elf_name, "v7"
.align
- .section ".proc.info.init", #alloc, #execinstr
+ .section ".proc.info.init", "ax"
/*
* Standard v7 proc info content
This diff is collapsed.
Based on https://lkml.org/lkml/2020/4/1/1206. In original patch, YYLOC declaration was removed.
However, using original patch, which removes yylloc declaration on 3.18.14 kernel version results in 'yylloc not declared' error.
See part of the original description below:
gcc 10 will default to -fno-common, which causes this error at link
time:
(.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
This is because both dtc-lexer as well as dtc-parser define the same
global symbol yyloc. Before with -fcommon those were merged into one
defintion. The proper solution would be to to mark this as "extern",
diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
index 3b41bfca636..9b9c29e6f31 100644
--- a/scripts/dtc/dtc-lexer.l
+++ b/scripts/dtc/dtc-lexer.l
@@ -39,7 +39,7 @@ LINECOMMENT "//".*\n
#include "srcpos.h"
#include "dtc-parser.tab.h"
-YYLTYPE yylloc;
+extern YYLTYPE yylloc;
/* CAUTION: this will stop working if we ever use yyless() or yyunput() */
#define YY_USER_ACTION \
diff --git a/scripts/dtc/dtc-lexer.lex.c_shipped b/scripts/dtc/dtc-lexer.lex.c_shipped
index 2d30f41778b..d0eb405cb81 100644
--- a/scripts/dtc/dtc-lexer.lex.c_shipped
+++ b/scripts/dtc/dtc-lexer.lex.c_shipped
@@ -637,7 +637,7 @@ char *yytext;
#include "srcpos.h"
#include "dtc-parser.tab.h"
-YYLTYPE yylloc;
+extern YYLTYPE yylloc;
/* CAUTION: this will stop working if we ever use yyless() or yyunput() */
#define YY_USER_ACTION \
Subject: [PATCH] printk-no-inline
---
Index: kernel/printk.c
IDEA additional info:
Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
<+>UTF-8
===================================================================
diff --git a/kernel/printk.c b/kernel/printk.c
--- a/kernel/printk.c (revision aee1ff3a4f5845e540d5e9f16e5650fa1e68f253)
+++ b/kernel/printk.c (date 1688550813317)
@@ -275,7 +275,7 @@
#ifdef CONFIG_MT_PRINTK_UART_CONSOLE
extern int mt_need_uart_console;
-inline void mt_disable_uart(void)
+void mt_disable_uart(void)
{
if (mt_need_uart_console == 0) {
printk("<< printk console disable >>\n");
@@ -284,7 +284,7 @@
printk("<< printk console can't be disabled >>\n");
}
}
-inline void mt_enable_uart(void)
+void mt_enable_uart(void)
{
if (mt_need_uart_console == 1) {
if (printk_disable_uart == 0)
Subject: [PATCH] atf_logger-fix
---
Index: drivers/misc/mediatek/atf_log/atf_logger.c
IDEA additional info:
Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
<+>UTF-8
===================================================================
diff --git a/drivers/misc/mediatek/atf_log/atf_logger.c b/drivers/misc/mediatek/atf_log/atf_logger.c
--- a/drivers/misc/mediatek/atf_log/atf_logger.c (revision e55225c3291f801af998c746ae084860fa654a7c)
+++ b/drivers/misc/mediatek/atf_log/atf_logger.c (date 1688633415872)
@@ -335,6 +335,9 @@
.mode = 0644,
};
+extern int __initdata dt_root_addr_cells;
+extern int __initdata dt_root_size_cells;
+
static int dt_scan_memory(unsigned long node, const char *uname, int depth, void *data)
{
char *type = of_get_flat_dt_prop(node, "device_type", NULL);
Index: drivers/misc/mediatek/mach/mt6735/mt_cpuidle.c
IDEA additional info:
Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
<+>UTF-8
===================================================================
diff --git a/drivers/misc/mediatek/mach/mt6735/mt_cpuidle.c b/drivers/misc/mediatek/mach/mt6735/mt_cpuidle.c
--- a/drivers/misc/mediatek/mach/mt6735/mt_cpuidle.c (revision 2970ba34e89f4bb45d025f550e550bda762abc57)
+++ b/drivers/misc/mediatek/mach/mt6735/mt_cpuidle.c (date 1688639402010)
@@ -1328,10 +1328,7 @@
int cpuid, clusterid;
read_id(&cpuid, &clusterid);
- if (psci_ops.cpu_suspend) {
- DORMANT_LOG(clusterid * 4 + cpuid, 0x203);
- ret = psci_ops.cpu_suspend(pps, virt_to_phys(cpu_resume));
- }
+ ret = -3721;
BUG();
Subject: [PATCH] ca53_timer
---
Index: arch/arm/boot/compressed/Makefile
IDEA additional info:
Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
<+>UTF-8
===================================================================
diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
--- a/arch/arm/boot/compressed/Makefile (revision 99cd6b758cab723a21a0c98ad018c79df61fe76e)
+++ b/arch/arm/boot/compressed/Makefile (date 1688640434782)
@@ -182,7 +182,6 @@
$(obj)/vmlinux: $(obj)/vmlinux.lds $(obj)/$(HEAD) $(obj)/piggy.$(suffix_y).o \
$(addprefix $(obj)/, $(OBJS)) $(lib1funcs) $(ashldi3) FORCE
@$(check_for_multiple_zreladdr)
- $(call if_changed,ld)
@$(check_for_bad_syms)
$(obj)/piggy.$(suffix_y): $(obj)/../Image FORCE
Index: arch/arm/boot/Makefile
IDEA additional info:
Subsystem: com.intellij.openapi.diff.impl.patch.CharsetEP
<+>UTF-8
===================================================================
diff --git a/arch/arm/boot/Makefile b/arch/arm/boot/Makefile
--- a/arch/arm/boot/Makefile (revision 99cd6b758cab723a21a0c98ad018c79df61fe76e)
+++ b/arch/arm/boot/Makefile (date 1688640687790)
@@ -61,7 +61,6 @@
$(Q)$(MAKE) $(build)=$(obj)/compressed $@
$(obj)/zImage: $(obj)/compressed/vmlinux FORCE
- $(call if_changed,objcopy)
@$(kecho) ' Kernel: $@ is ready'
$(obj)/zImage-dtb: $(obj)/zImage $(DTB_OBJS) FORCE
Fix pre-ANSI C code in check-lxdialog.sh.
diff --git a/scripts/kconfig/lxdialog/check-lxdialog.sh b/scripts/kconfig/lxdialog/check-lxdialog.sh
index 9d2a4c58..364eaecb 100644
--- a/scripts/kconfig/lxdialog/check-lxdialog.sh
+++ b/scripts/kconfig/lxdialog/check-lxdialog.sh
@@ -43,7 +43,7 @@ trap "rm -f $tmp" 0 1 2 3 15
check() {
$cc -x c - -o $tmp 2>/dev/null <<'EOF'
#include CURSES_LOC
-main() {}
+int main() { return 0; }
EOF
if [ $? != 0 ]; then
echo " *** Unable to find the ncurses libraries or the" 1>&2
# Reference: <https://postmarketos.org/vendorkernel>
# Kernel config based on: arch/arm/configs/(CHANGEME!)
pkgname=linux-huawei-lua-l21
pkgver=3.10.65
pkgrel=0
pkgdesc="Huawei Y3 II 4G kernel fork"
arch="armv7"
_carch="arm"
_flavor="huawei-lua-l21"
url="https://kernel.org"
license="GPL-2.0-only"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="
bash
bc
bison
devicepkg-dev
findutils
flex
openssl-dev
perl
gcc6
python3
linux-headers
"
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
if [ "${CC:0:5}" != "gcc6-" ]; then
CC="gcc6-$CC"
HOSTCC="gcc6-gcc"
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
fi
# Source
_repository="android_kernel_huawei_y3_ii_lua_l"
_commit="e9b07ded27ad17cd8fe801ea6151be7ce494a205"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://gitlab.com/faveoled/$_repository/-/archive/$_commit/$_repository-$_commit.tar.gz
$_config
00-replace-solaris-style-directive.patch
01-drvgen-precompiled.patch
02-gcc10-extern_YYLOC_global_declaration.patch
03-printk-no-inline.patch
04-atf_logger-fix.patch
05-psci_ops.patch
06-makefile.patch
07-fix-check-lxdialog.patch
"
builddir="$srcdir/$_repository-$_commit"
_outdir="out"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
chmod +x $builddir/arch/arm64/kernel/vdso/gen_vdso_offsets.sh
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
"$_flavor" "$_outdir"
}
sha512sums="
015a055313dd55676a50a744083f5950adc2bc810223062753f2a7152b2dd6938b3124c4e83e3412336a293d4f763d293f043d534796f4fc93536852c8700c1b linux-huawei-lua-l21-e9b07ded27ad17cd8fe801ea6151be7ce494a205.tar.gz
36fbbf2f4fe5d02e9f0bc97aadf7fcf8ed3004711acc657980dc69487c0babdf0d98f2d2b8d23b148c0af9f635e674098c4752f888e7da25aa8b5e2e1e4f268d config-huawei-lua-l21.armv7
a4196e0184b3bb1bc8d0cf4fae931dab623bb9cd02732758bb8ac1d0588682960f58d4dba8ccebb1377e853ca5c135d2a700750228d54ac95a33d1cd44533bca 00-replace-solaris-style-directive.patch
4b628594a962db8cdeffd25de743a0eef1fe7669f67423256b2898efe40adea365efef49d7d1d1c93477967b0c826baac399887ef039e94f4d55da73d52c2f36 01-drvgen-precompiled.patch
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb 02-gcc10-extern_YYLOC_global_declaration.patch
49e1bc3deba6cd46b9b96aeafcf7d607edefa7ceacb4a241027eb3ad4ce2c6754a25a5361f0c58ce89de4a12b571151829f875550961e49065feeb0c13299cba 03-printk-no-inline.patch
90ba388ba2c9b0cc9479df44e7377fd34aa5e6a96916ea12e7a8a035f49521853603843e4d0684fdddf23065fd8d88b75fab9e9acfdebd2fcd9002a1fd70b776 04-atf_logger-fix.patch
5aa524838cd42cfb0ec0b576c598f48d8364eaa5825f61cd1a72d713ffd304084aec97828b4c5714d119726cce64a7f8df0cee9cf31e5af52a66f921203bc8eb 05-psci_ops.patch
70d8d57d46523206f8aa89edbb6f98bc38285395a258ef6cd808305fbf617aecfcc5430ae6bb1bc7c9a643728e3b226bbcfe48511f6e5afea1bbf3df6613dd06 06-makefile.patch
182be3c596b9cc267ac108d7cf03fc8c328ccc6b36770800e4dcedea8d1bb65e3f5eacf590c2948f58b1418cc60a1670ba77dde8c259e428d158c31b6e1dbaf5 07-fix-check-lxdialog.patch
"
This diff is collapsed.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment