Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Operate
Terraform modules
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
faveoled
pmaports
Commits
b1045393
Commit
b1045393
authored
6 years ago
by
Luca Weiss
Browse files
Options
Downloads
Patches
Plain Diff
stuff
parent
d3fdb85b
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/linux-postmarketos-allwinner/APKBUILD
+4
-6
4 additions, 6 deletions
main/linux-postmarketos-allwinner/APKBUILD
main/linux-postmarketos-allwinner/extra.patch
+0
-26
0 additions, 26 deletions
main/linux-postmarketos-allwinner/extra.patch
with
4 additions
and
32 deletions
main/linux-postmarketos-allwinner/APKBUILD
+
4
−
6
View file @
b1045393
...
...
@@ -3,7 +3,7 @@ _config="config-${_flavor}.${CARCH}"
pkgname
=
linux-
${
_flavor
}
pkgver
=
4.20.0
pkgver
=
5.0.0_rc3
pkgrel
=
0
arch
=
"aarch64"
...
...
@@ -13,11 +13,10 @@ depends=""
makedepends
=
"perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev openssl-dev file bison flex"
options
=
"!strip !check !tracedeps"
install
=
_commit
=
"3
99381b838535c2384b33fb1497f8ada2a9ebe8
f"
_commit
=
"3
c1d066cf9d018f794fb96d79c979ec46b61e26
f"
source
=
"
linux-
${
_commit
}
.tar.gz::https://github.com/amarula/linux-amarula/archive/
${
_commit
}
.tar.gz
config-
${
_flavor
}
.aarch64
extra.patch
"
subpackages
=
"
$pkgname
-dev"
...
...
@@ -177,6 +176,5 @@ dev() {
fi
fi
}
sha512sums
=
"b4f56dd4cc3a24c715bbe6dea43382d606cb0b1d2ba894cd7201331084a46295fbf2277be9fbbeba96a72ebbdadedf27df1ec0845b7d492e8bc7a4e991b69871 linux-399381b838535c2384b33fb1497f8ada2a9ebe8f.tar.gz
83df4ac28c28dd7c868218b4c00e4ac2f364c6ddbc4c92dc1bad5c1690d9c24e0bc3dd2591050d3591c49dff0cab299323845a78466923570afa86fce9f78405 config-postmarketos-allwinner.aarch64
0a1cb87e73ad84c778cd8e4a627873e6ec2c0285f3c9d92451bf588b14702f732ce192d25b4f0e8c6cf282de8df5064dfd23f61f06e96e71fb105b21ecfa3e0f extra.patch"
sha512sums
=
"3081d2ebabb84542fa63ed784b57d5f782fdcd24bf94001bff68a123c250b44134987087bb34b4cc521ac7bb11f69a69000f0447421f07963446ee15dffb9b41 linux-3c1d066cf9d018f794fb96d79c979ec46b61e26f.tar.gz
83df4ac28c28dd7c868218b4c00e4ac2f364c6ddbc4c92dc1bad5c1690d9c24e0bc3dd2591050d3591c49dff0cab299323845a78466923570afa86fce9f78405 config-postmarketos-allwinner.aarch64"
This diff is collapsed.
Click to expand it.
main/linux-postmarketos-allwinner/extra.patch
deleted
100644 → 0
+
0
−
26
View file @
d3fdb85b
diff --git a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
index b623c8150b4f..1f47e4954e9d 100644
--- a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
+++ b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
@@ -183,7 +183,7 @@
static struct ccu_nkm pll_mipi_clk = {
.n = _SUNXI_CCU_MULT(8, 4),
.k = _SUNXI_CCU_MULT_MIN(4, 2, 2),
.m = _SUNXI_CCU_DIV(0, 4),
- .min_rate = 300000000, /* Actual rate is 500MHz */
+ .min_rate = 330000000, /* Actual rate is 500MHz */
.common = {
.reg = 0x040,
.hw.init = CLK_HW_INIT("pll-mipi", "pll-video0",
diff --git a/drivers/clk/sunxi-ng/ccu_nkm.c b/drivers/clk/sunxi-ng/ccu_nkm.c
index 096ff4f4839a..6c7a705b8bfb 100644
--- a/drivers/clk/sunxi-ng/ccu_nkm.c
+++ b/drivers/clk/sunxi-ng/ccu_nkm.c
@@ -125,7 +125,7 @@
static unsigned long ccu_nkm_round_rate(struct ccu_mux_internal *mux,
if (nkm->common.features & CCU_FEATURE_FIXED_POSTDIV)
rate *= nkm->fixed_post_div;
- if (rate < nkm->min_rate) {
+ if (rate <= nkm->min_rate) {
rate = nkm->min_rate;
return rate;
}
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment