Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Operate
Terraform modules
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Some Guy
pmaports
Commits
9136c2de
Verified
Commit
9136c2de
authored
3 months ago
by
Richard Acayan
Committed by
Clayton Craft
3 months ago
Browse files
Options
Downloads
Patches
Plain Diff
firmware-google-sargo: compress firmware loaded by kernel (MR 6052)
[ci:skip-build]: already built successfully in CI
parent
eecf4d35
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
device/community/firmware-google-sargo/APKBUILD
+28
-18
28 additions, 18 deletions
device/community/firmware-google-sargo/APKBUILD
with
28 additions
and
18 deletions
device/community/firmware-google-sargo/APKBUILD
+
28
−
18
View file @
9136c2de
# Maintainer: Richard Acayan <mailingradian@gmail.com>
pkgname
=
firmware-google-sargo
pkgver
=
220505.008
pkgrel
=
6
pkgrel
=
7
pkgdesc
=
"Proprietary firmware blobs from the Google Pixel 3a factory image"
url
=
"https://github.com/TheMuppets/proprietary_vendor_google_sargo"
arch
=
"aarch64"
license
=
"proprietary"
makedepends
=
"pil-squasher sscregistrygen"
makedepends
=
"pil-squasher sscregistrygen
zstd
"
_commit
=
"c631f0f2aa24ea60cfb505d327cd4ae56ca27f16"
_modemfw_commit
=
"34bbe2c27f35537f13747c9eba67ece6ae141806"
_device_android_commit
=
"a1cd8bf2603569b8b3b450b9d7b5b595eb549df0"
...
...
@@ -17,6 +17,7 @@ source="
"
builddir
=
"
$srcdir
/proprietary_vendor_google_sargo-
$_commit
"
options
=
"!check !archcheck !strip !tracedeps pmb:cross-native"
_modemfw_dir
=
"
$srcdir
/firmware-google-sargo-modem-
$_modemfw_commit
"
build
()
{
pil-squasher a615_zap.mbn proprietary/vendor/firmware/a615_zap.mdt
...
...
@@ -25,33 +26,42 @@ build() {
# This is an OEM device. The SoC ID for SDM670 is 336.
mkdir
sensors-registry
sscregistrygen
-p
OEM
-s
336 proprietary/vendor/etc/sensors/config sensors-registry/
# Compress kernel-loaded firmware
zstd a615_zap.mbn
zstd ipa_fws.mbn
zstd proprietary/vendor/firmware/adsp.mbn
zstd proprietary/vendor/firmware/venus.mbn
zstd proprietary/vendor/firmware/wlanmdsp.mbn
zstd
"
$_modemfw_dir
"
/modemfw/mba.mbn
zstd
"
$_modemfw_dir
"
/modemfw/modem.mbn
}
package
()
{
_modemfw_dir
=
"
$srcdir
"
/firmware-google-sargo-modem-
"
$_modemfw_commit
"
install
-Dm644
"
$builddir
"
/a615_zap.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/a615_zap.mbn
install
-Dm644
"
$builddir
"
/ipa_fws.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/ipa_fws.mbn
install
-Dm644
"
$builddir
"
/a615_zap.mbn.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/a615_zap.mbn.zst
install
-Dm644
"
$builddir
"
/ipa_fws.mbn.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/ipa_fws.mbn.zst
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/adsp.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/adsp.mbn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/adsp.mbn
.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/adsp.mbn
.zst
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/adspr.jsn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/adspr.jsn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/adspua.jsn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/adspua.jsn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/modemuw.jsn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/modemuw.jsn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/venus.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/venus.mbn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/wlanmdsp.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/wlanmdsp.mbn
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/venus.mbn
.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/venus.mbn
.zst
install
-Dm644
"
$builddir
"
/proprietary/vendor/firmware/wlanmdsp.mbn
.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/wlanmdsp.mbn
.zst
install
-Dm644
"
$_modemfw_dir
"
/modemfw/mba.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/mba.mbn
install
-Dm644
"
$_modemfw_dir
"
/modemfw/modem.mbn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/modem.mbn
install
-Dm644
"
$_modemfw_dir
"
/modemfw/mba.mbn
.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/mba.mbn
.zst
install
-Dm644
"
$_modemfw_dir
"
/modemfw/modem.mbn
.zst
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/modem.mbn
.zst
install
-Dm644
"
$_modemfw_dir
"
/modemfw/modemr.jsn
\
"
$pkgdir
"
/lib/firmware/qcom/sdm670/sargo/modemr.jsn
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment