Skip to content
Snippets Groups Projects
  • Minecrell's avatar
    319396a6
    device-<qcom-msm8916>: revert to msdos partition table for now (MR 5813) · 319396a6
    Minecrell authored
    pmbootstrap 3.0.0 uses GPT partition table by default, which breaks booting
    on all the devices using the lk2nd bootloader. The current version of lk2nd
    supports GPT only for the eMMC, while subpartitions and SD cards must be
    partitioned with MBR. GPT support was present in the legacy branch of
    lk2nd, but was dropped at some point because of poor code quality.
    
    Fix the regression for now by reverting back to the old msdos (MBR)
    partition table. We can revert this again later when lk2nd restores support
    for GPT.
    
    Generated with
    $ for d in $(grep -R linux-postmarketos-qcom-msm8916 | grep -Eo 'device-[^/]+' | sort -u); do \
      echo -e '\n# lk2nd does not support GPT for subpartitions/SD cards yet\ndeviceinfo_partition_type="msdos"' \
      >> device/*/$d/deviceinfo && pmbootstrap checksum $d && pmbootstrap pkgver_bump $d; done
    
    [ci:ignore-count]
    
    [ci:skip-build]: bug in CI prevents build testing armv7 and aarch64, so
    Clayton did the test locally for those archs
    319396a6
    History
    device-<qcom-msm8916>: revert to msdos partition table for now (MR 5813)
    Minecrell authored
    pmbootstrap 3.0.0 uses GPT partition table by default, which breaks booting
    on all the devices using the lk2nd bootloader. The current version of lk2nd
    supports GPT only for the eMMC, while subpartitions and SD cards must be
    partitioned with MBR. GPT support was present in the legacy branch of
    lk2nd, but was dropped at some point because of poor code quality.
    
    Fix the regression for now by reverting back to the old msdos (MBR)
    partition table. We can revert this again later when lk2nd restores support
    for GPT.
    
    Generated with
    $ for d in $(grep -R linux-postmarketos-qcom-msm8916 | grep -Eo 'device-[^/]+' | sort -u); do \
      echo -e '\n# lk2nd does not support GPT for subpartitions/SD cards yet\ndeviceinfo_partition_type="msdos"' \
      >> device/*/$d/deviceinfo && pmbootstrap checksum $d && pmbootstrap pkgver_bump $d; done
    
    [ci:ignore-count]
    
    [ci:skip-build]: bug in CI prevents build testing armv7 and aarch64, so
    Clayton did the test locally for those archs