Skip to content
Snippets Groups Projects
Verified Commit 0886b2e7 authored by Casey's avatar Casey :recycle: Committed by Clayton Craft
Browse files

systemd/gnome-shell-mobile: new aport


Integrates tightly with systemd.

Signed-off-by: default avatarCaleb Connolly <caleb@postmarketos.org>
parent 2c84a6dc
Branches
No related tags found
1 merge request!5859Draft: ElementaryOS pantheon desktop w/ systemd
# Forked from Alpine to add phone adaptivity patches and systemd!
pkgname=gnome-shell-mobile
pkgver=99945_git20240610
_pkgver=45_git20240610
pkgrel=0
pkgdesc="GNOME shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch="all !armhf !s390x !riscv64" # gjs / riscv64: mutter-mobile
license="GPL-2.0-or-later"
depends="
accountsservice
adwaita-icon-theme
caribou
font-adobe-source-code-pro
font-cantarell
gnome-bluetooth
gnome-control-center
gnome-shell-mobile-schemas
gsettings-desktop-schemas
gst-plugin-pipewire
gst-plugins-good
gstreamer
ibus
librsvg
networkmanager-common
polkit
systemd
unzip
upower
xorg-server
"
makedepends="
asciidoc
systemd-dev
evolution-data-server-dev evolution-dev
gcr4-dev
gjs-dev>=1.64.0
gnome-autoar-dev
gnome-bluetooth-dev
gnome-control-center-dev
gnome-desktop-dev>=3.35.91
gobject-introspection-dev
gstreamer-dev
ibus-dev
libcanberra-dev
libnma-dev
libxml2-dev
libxml2-utils
meson
mutter-mobile-dev>=44_git20230405
networkmanager-dev
pipewire-dev
polkit-dev
pulseaudio-dev
py3-setuptools
python3
sassc
startup-notification-dev
"
checkdepends="
xvfb-run
mesa-dri-gallium
"
# gdm is also needed but introduces circular dep
provides="gnome-shell=$_pkgver-r$pkgrel"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-lang $pkgname-schemas::noarch"
_commit="df3f6b4c512d2f181e86ff7f6b1646ce7b907344"
_gvc_commit="8e7a5a4c3e51007ce6579292642517e3d3eb9c50"
source="mobile-shell-$_commit.tar.gz::https://gitlab.gnome.org/verdre/mobile-shell/-/archive/$_commit/mobile-shell-$_commit.tar.gz
libgnome-volume-control-$_gvc_commit.tar.gz::https://gitlab.gnome.org/GNOME/libgnome-volume-control/-/archive/$_gvc_commit/gnome-shell-$_gvc_commit.tar.gz
disable-telepathy-integration.patch
gsh.patch
"
builddir="$srcdir/mobile-shell-$_commit"
options="!check" # Tests have circular dependency 'gnome-shell <-> gdm'
# secfixes:
# 0:
# - CVE-2019-3820
prepare() {
default_prepare
rm -rf "$builddir/subprojects/gvc"
mv "$srcdir/libgnome-volume-control-$_gvc_commit" $builddir/subprojects/gvc
sed -i "s/mutter_api_version = '.*'/mutter_api_version = '99'/g" meson.build
}
build() {
abuild-meson \
-Dtests=false \
. output
meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
xvfb-run meson test --no-rebuild -v -C output
}
schemas() {
pkgdesc="GNOME Shell gsetting schemas"
depends=""
provides="gnome-shell-schemas=$_pkgver-r$pkgrel"
amove usr/share/glib-2.0/schemas
amove usr/share/gnome-control-center/keybindings
}
lang() {
default_lang
provides="gnome-shell-lang=$_pkgver-r$pkgrel"
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
# owned by postmarketos-hidden-desktop-entries
rm $pkgdir/usr/share/applications/org.gnome.Extensions.desktop
}
sha512sums="
f7445d29006496865f9ea9d70efd1e2f1be1886b97bdd09bb5b000db6b576200d076178050527e920837dc416b1803851cb7d33e8024fc99acecdcc4c73816dd mobile-shell-df3f6b4c512d2f181e86ff7f6b1646ce7b907344.tar.gz
ebc6985afbda5ddebcda44d8b6732a9abc2d7249aff3adf7a76a90aa681590f830dcf2e5f3534a624adc32d1f0445e261ee149d65c221f733e0c33e0690a004d libgnome-volume-control-8e7a5a4c3e51007ce6579292642517e3d3eb9c50.tar.gz
2ca70115fab957fdf276b7f0772786e1afd56b0b22bcfd92f5b5f1d29676dc97c19cfb079434d0dbf7b459f1d133dbd8d1faa0d88f7b94846040a23856f951f8 disable-telepathy-integration.patch
dba79b94ab4bcf0db51aa4a19c5fb52f9dae05909fe13531fe9dc06d9db334ac3328bd4040484eac8ef851057ee471a28d86800aa2ae82eec7274f5f79b9146a gsh.patch
"
Upstream: No, this is on our telepathy being broken somehow.
Reason: This is a hotfix to not break everyone's GNOME Session over this.
Issue opened, see: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2733
diff --git a/js/ui/components/telepathyClient.js b/js/ui/components/telepathyClient.js
index b4af438..109d324 100644
--- a/js/ui/components/telepathyClient.js
+++ b/js/ui/components/telepathyClient.js
@@ -18,7 +18,7 @@ const MessageTray = imports.ui.messageTray;
const Params = imports.misc.params;
const Util = imports.misc.util;
-const HAVE_TP = Tp != null && Tpl != null;
+const HAVE_TP = false;
// See Notification.appendMessage
var SCROLLBACK_IMMEDIATE_TIME = 3 * 60; // 3 minutes
Patch-Source: https://github.com/chimera-linux/cports/blob/793dbd2807070fd0fd4f7ba37fd73d4c5ff47584/main/gnome-shell/patches/no-exe-introspection.patch
commit 1d1e96c094570c3a822f835abbff0a5bca4ca10e
Author: Daniel Kolesa <daniel@octaforge.org>
Date: Sun Mar 19 19:11:00 2023 +0100
Disable 9bc89b821cf09195418f20225bbec39c0567d263
Even if we manually define _DYNAMIC, it does not work (segfaults
somewhere in musl, coming from g_strsplit) and is pretty useless
for our case anyway.
diff --git a/src/main.c b/src/main.c
index 8cccc0a..ef6408f 100644
--- a/src/main.c
+++ b/src/main.c
@@ -19,6 +19,10 @@
#include <atk-bridge.h>
#include <link.h>
+#ifdef HAVE_EXE_INTROSPECTION
+#undef HAVE_EXE_INTROSPECTION
+#endif
+
#ifdef HAVE_EXE_INTROSPECTION
#include <elf.h>
#endif
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment