Skip to content
Snippets Groups Projects
Unverified Commit 11e638b0 authored by Bart Ribbers's avatar Bart Ribbers Committed by Oliver Smith
Browse files

temp/mesa-git: upgrade to 0_git20190917 (!591)

- Remove the outdated patch, it has been fixed differently upstream
- Update patch for use-elf-tls slots

[ci:skip-build]: already built successfully in CI
parent dd0f32d9
Branches
No related tags found
No related merge requests found
Pipeline #198489 passed
......@@ -8,9 +8,9 @@
# of this aport, so mesa-git including _all_ of the subpackages, to not cause
# conflicts
pkgname=mesa-git
pkgver=0_git20190725
pkgrel=1
_commit="cd02f60c1e9d0ef37e4defb8e6b00433990fd90c"
pkgver=0_git20190917
pkgrel=0
_commit="631255387f0469910db99eccbfbaa63345425739"
pkgdesc="(Git) Mesa DRI OpenGL library"
url="https://www.mesa3d.org"
arch="armhf armv7 aarch64"
......@@ -67,8 +67,7 @@ source="
$pkgname-$_commit.tar.gz::https://gitlab.freedesktop.org/mesa/mesa/-/archive/$_commit.tar.gz
adjust-cache-deflate-buffer.patch
musl-fix-includes.patch
add-glx-use-tls.patch
fix-build.patch
add-use-elf-tls.patch
"
provides="mesa"
replaces="mesa-dricore mesa"
......@@ -136,7 +135,7 @@ build() {
-Dgallium-vdpau=true \
-Dgallium-va=true \
-Dgallium-xvmc=false \
-Dglx-use-tls=false \
-Duse-elf-tls=false \
-Dgallium-nine=false \
-Db_ndebug=true \
$_arch_opts \
......@@ -345,8 +344,7 @@ _vulkan() {
_mv_vulkan intel ;;
esac
}
sha512sums="be6dc11d0e967bb519e6cea1e6aac76539bcb39f76daf00a194a24e1fc8636891a80dbe7960f30d58f4fa96d836509899c0c8f9474574cc21079355e9ef2977e mesa-git-cd02f60c1e9d0ef37e4defb8e6b00433990fd90c.tar.gz
sha512sums="1aaf6ed470c579303631635e6c5dfb16a8d746c67709987a2772bd23559adf12bc0da39abc620fa3d4229fa76fcbdc3b61a84cf0c6098db85a24f4724295c8c7 mesa-git-631255387f0469910db99eccbfbaa63345425739.tar.gz
cdf22d2da3328e116c379264886bd01fd3ad5cc45fe03dc6fd97bdc4794502598ee195c0b9d975fa264d6ac31c6fa108c0535c91800ecf4fcabfd308e53074cc adjust-cache-deflate-buffer.patch
cf849044d6cc7d2af4ff015208fb09d70bf9660538699797da21bda2ecb7c1892d312af83d05116afd826708d9caafb1d05a13f09139c558aea6fee931e3eee7 musl-fix-includes.patch
1d89e305659bb0ca95b0b593dbc1a17ed28f4a18fabe468c20527302fc90c1ce11ca40a79c8786f1eca68ef643027af706b8689068e31c7f27ceb2303d51633e add-glx-use-tls.patch
c8cc0cb3e5e1e2a4795fa9ddd9312c496db6ec333907a4a1345b97ac839fe8e5a4f3036063242527237eace07d4bd2ccd5ca4b49134eae688a3d7387c83e31fb fix-build.patch"
6974e344b9a613077cb322b734ff4e2780e78f1a2af60657686b3b3341ad526273f58b22624ba6c575988474dbc0978e7ebe4a9d1547483305f8fc251d24d86e add-use-elf-tls.patch"
From f895a39b7437381a86383dd97250aa2cc7393bff Mon Sep 17 00:00:00 2001
From: maxice8 <thinkabit.ukim@gmail.com>
Date: Thu, 9 Aug 2018 18:37:30 -0300
Subject: [PATCH] meson: add glx-use-tls option.
---
meson.build | 6 +++++-
meson_options.txt | 6 ++++++
2 files changed, 11 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 5dbb786..1ab3092 100644
index 501957e35e1..8ee027f1a1e 100644
--- a/meson.build
+++ b/meson.build
@@ -340,7 +340,11 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
endif
@@ -378,8 +378,10 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
-if not with_platform_android or get_option('platform-sdk-version') >= 29
- pre_args += '-DUSE_ELF_TLS'
+if not with_platform_android or get_option('platform-sdk-version') >= 29
+ if get_option('use-elf-tls')
+ pre_args += '-DUSE_ELF_TLS'
+ endif
endif
-pre_args += '-DGLX_USE_TLS'
+with_glx_use_tls = get_option('glx-use-tls')
+if with_glx_use_tls
+ pre_args += '-DGLX_USE_TLS'
+endif
+
if with_glx != 'disabled'
if not (with_platform_x11 and with_any_opengl)
if with_glx == 'auto'
diff --git a/meson_options.txt b/meson_options.txt
index 496fe38..12981dd 100644
index b768c15053c..381cfb435ba 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -195,6 +195,12 @@ option(
@@ -214,6 +214,12 @@ option(
choices : ['auto', 'disabled', 'dri', 'xlib', 'gallium-xlib'],
description : 'Build support for GLX platform'
)
+option(
+ 'glx-use-tls',
+ 'use-elf-tls',
+ type : 'boolean',
+ value : true,
+ description : 'Build support for initial-exec TLS model on GLX platform'
+ description : 'Build support for initial-exec TLS model on ELF platform'
+)
option(
'egl',
type : 'combo',
--
2.18.0
diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
index 2a2d6fe..6082ea3 100644
--- a/src/egl/drivers/dri2/platform_wayland.c
+++ b/src/egl/drivers/dri2/platform_wayland.c
@@ -27,6 +27,8 @@
* Benjamin Franzke <benjaminfranzke@googlemail.com>
*/
+#include <assert.h>
+
#include <stdint.h>
#include <stdlib.h>
#include <string.h>
@@ -114,7 +116,7 @@ static const struct dri2_wl_visual {
},
};
-static_assert(ARRAY_SIZE(dri2_wl_visuals) <= EGL_DRI2_MAX_FORMATS,
+_Static_assert(ARRAY_SIZE(dri2_wl_visuals) <= EGL_DRI2_MAX_FORMATS,
"dri2_egl_display::formats is not large enough for "
"the formats in dri2_wl_visuals");
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment