Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
2770d39f
Unverified
Commit
2770d39f
authored
1 year ago
by
Anton Bambura
Committed by
Oliver Smith
1 year ago
Browse files
Options
Downloads
Patches
Plain Diff
soc-qcom-sc7180: set non-strict iommu for eMMC, SD card and USB (MR 4526)
[ci:skip-build]: already built successfully in CI
parent
cc3dd7de
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Pipeline
#206329
passed
1 year ago
Stage: lint
Stage: build
Changes
2
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
device/community/soc-qcom-sc7180/00-sc7180-nonstrict-iommu.sh
+18
-0
18 additions, 0 deletions
...ce/community/soc-qcom-sc7180/00-sc7180-nonstrict-iommu.sh
device/community/soc-qcom-sc7180/APKBUILD
+8
-1
8 additions, 1 deletion
device/community/soc-qcom-sc7180/APKBUILD
with
26 additions
and
1 deletion
device/community/soc-qcom-sc7180/00-sc7180-nonstrict-iommu.sh
0 → 100644
+
18
−
0
View file @
2770d39f
#!/bin/sh
# This script relaxes iommu for the devices, relaxing memory
# protection, but we consider it a fine tradeoff because those
# hardware blocks don't have firmware on them.
# It Increases eMMC speed by 15% according to gnome disks benchmark
# with sample size 1000 MiB and number of samples 2.
iommus
=
"
/sys/devices/platform/soc@0/7c4000.mmc/iommu_group/type
/sys/devices/platform/soc@0/8804000.mmc/iommu_group/type
/sys/devices/platform/soc@0/a6f8800.usb/a600000.usb/iommu_group/type
"
for
iommu
in
$iommus
;
do
[
-f
"
$iommu
"
]
&&
echo
"DMA-FQ"
>
"
$iommu
"
done
This diff is collapsed.
Click to expand it.
device/community/soc-qcom-sc7180/APKBUILD
+
8
−
1
View file @
2770d39f
# Maintainer: Jenneron <jenneron@protonmail.com>
pkgname
=
soc-qcom-sc7180
pkgdesc
=
"Common package for Qualcomm Snapdragon 7cx devices"
pkgver
=
1
pkgver
=
1
.1
pkgrel
=
0
url
=
"https://postmarketos.org"
license
=
"BSD-3-Clause"
...
...
@@ -11,9 +11,13 @@ subpackages="
$pkgname
-nonfree-firmware:nonfree_firmware
$pkgname
-vulkan
"
source
=
"00-sc7180-nonstrict-iommu.sh"
package
()
{
mkdir
-p
"
$pkgdir
"
install
-Dm755
"
$srcdir
"
/00-sc7180-nonstrict-iommu.sh
\
-t
"
$pkgdir
"
/usr/share/mkinitfs/hooks
}
nonfree_firmware
()
{
...
...
@@ -30,3 +34,6 @@ vulkan() {
mkdir
"
$subpkgdir
"
}
sha512sums
=
"
8d76fc3ed580e5950bcb8561c08bf56c52b8693605dee04f174a49154e270b5ac6d4303bc00499864f30c352e9a0c06c449253e0b8ba974e3d85554f306c84fc 00-sc7180-nonstrict-iommu.sh
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment