Skip to content
Snippets Groups Projects
Unverified Commit 2d103255 authored by Clayton Craft's avatar Clayton Craft :speech_balloon: Committed by Oliver Smith
Browse files

systemd/systemd: add patch to install legacy tmpfiles config

This patch is in 257, so we can drop it when upgrading. Without this
patch, we'd have to the enable sysv compat stuff in systemd just to get
this legacy.conf file generated/installed, which totally doesn't seem
worth it (the sysv compat stuff seems to be a lot!)

Fixes #3616

Part-of: !6352
[ci:skip-build]: already built successfully in CI
parent 55755615
No related branches found
No related tags found
1 merge request!6352systemd/systemd: add patch to install legacy tmpfiles config
Pipeline #217856 passed
......@@ -6,7 +6,7 @@ pkgname=systemd
# currently tracking git MR
pkgver=256.11
_pkgver="musl-v${pkgver//_/-}-split-usr"
pkgrel=3
pkgrel=4
pkgdesc="System and service manager"
url="https://github.com/systemd/systemd"
arch="all !ppc64le !s390x" # blocked by pmboostrap not supporting
......@@ -139,6 +139,8 @@ source="
https://gitlab.postmarketos.org/postmarketOS/systemd/-/archive/$_pkgver/systemd-$_pkgver.tar.gz
wired.network
systemd-apk-macros.sh
tmpfiles-narrow-scope-of-HAVE_SYSV_COMPAT-condition-.patch
"
builddir="$srcdir/systemd-$_pkgver"
......@@ -449,4 +451,5 @@ sha512sums="
3cd75d5ba29a3994230ecbe16ea106d4fe05d7d76e7cd9b9a6a63177f09d8c362c055a1fea49e6c9a10a949afc07a6c75fe75dad2bd302d94e41a81f8ddb2a15 systemd-musl-v256.11-split-usr.tar.gz
81c897fed8a3fbfb67ec591b2398a5d65e4af1b3ef379376c157c98d71f085b707f8ebc896d5571a94f99f8fc84fd6b43e3b879ca9b0d57fc6c4596034c7a777 wired.network
cc1c8f00a0ff1c94fcebe0e6d48b3d1a74c51b9d86bf255762cecda4b4d0c08e313f817aaaa301f41133eaf73c525e36c0f48659b263a7ed990080de9f3cec6c systemd-apk-macros.sh
ad6503195b11db4db2e7a05292fc64a3ac91075577ae2037c2bcceffa932a3052597b5a08335da1e3471d955984ee0232d9e4740371938fc78b70b739617758b tmpfiles-narrow-scope-of-HAVE_SYSV_COMPAT-condition-.patch
"
From c5287ecb19b4f44a39d128ba6e66022db7d5c2f0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Thu, 21 Nov 2024 10:12:56 +0100
Subject: [PATCH] tmpfiles: narrow scope of HAVE_SYSV_COMPAT condition for
legacy.conf
That file contains a bunch of entries of which only some are related to SysV.
The rest are just "traditional APIs" that need to stay. In particular,
/var/lock a.k.a. /run/lock is used by many programs (LVM, iscsi, alsactl).
Similarly, the README about /var/log is something that should stay as long as
we have people migrating from older systems or using the copiuos documentation
that mentions /var/log/messages.txt on the Internet.
/var/lock/subsys is only used by sysvinit, and our code to support /forcefsck,
/fastboot, and /forcequotacheck is conditionalized on HAVE_SYSV_COMPAT, so
conditionalize those here on HAVE_SYSV_COMPAT too.
---
tmpfiles.d/legacy.conf.in | 9 +++++----
tmpfiles.d/meson.build | 2 +-
2 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/tmpfiles.d/legacy.conf.in b/tmpfiles.d/legacy.conf.in
index 4f2c0d7c43..cc96e4b735 100644
--- a/tmpfiles.d/legacy.conf.in
+++ b/tmpfiles.d/legacy.conf.in
@@ -7,8 +7,9 @@
# See tmpfiles.d(5) for details
-# These files are considered legacy and are unnecessary on legacy-free
-# systems.
+# The functionality provided by these files and directories has been replaced
+# by newer interfaces. Their use is discouraged on legacy-free systems. This
+# configuration is provided to maintain backward compatibility.
d /run/lock 0755 root root -
L /var/lock - - - - ../run/lock
@@ -16,15 +17,15 @@ L /var/lock - - - - ../run/lock
L /var/log/README - - - - ../..{{DOC_DIR}}/README.logs
{% endif %}
+{% if HAVE_SYSV_COMPAT %}
# /run/lock/subsys is used for serializing SysV service execution, and
# hence without use on SysV-less systems.
-
d /run/lock/subsys 0755 root root -
# /forcefsck, /fastboot and /forcequotacheck are deprecated in favor of the
# kernel command line options 'fsck.mode=force', 'fsck.mode=skip' and
# 'quotacheck.mode=force'
-
r! /forcefsck
r! /fastboot
r! /forcequotacheck
+{% endif %}
diff --git a/tmpfiles.d/meson.build b/tmpfiles.d/meson.build
index bec24ac7b4..eca5372784 100644
--- a/tmpfiles.d/meson.build
+++ b/tmpfiles.d/meson.build
@@ -30,7 +30,7 @@ foreach pair : files
endforeach
in_files = [['etc.conf', ''],
- ['legacy.conf', 'HAVE_SYSV_COMPAT'],
+ ['legacy.conf', ''],
['static-nodes-permissions.conf', ''],
['systemd.conf', ''],
['var.conf', ''],
--
2.49.0
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment