Skip to content
Snippets Groups Projects
Commit 5a073745 authored by Luca Weiss's avatar Luca Weiss
Browse files

linux-postmarketos-qcom-msm8974: upgrade to 6.11.4

Some kconfig changes to reduce kernel size to avoid conflict of 0x8000
(kernel load address) + uncompressed kernel size (arch/arm/boot/Image) +
compressed kernel size (arch/arm/boot/zImage) being bigger than
0x1e00000 (tags address).

This causes mostly silent boot failures, with CONFIG_DEBUG_LL messages
such as "no ATAGS support: can't continue" or "Error: invalid dtb and
unrecognized/unsupported machine ID" can be seen on UART, though they're
not very clear that the kernel image is essentially too big for what lk
is setting up.

Manual kconfig changes:
* Convert some =y to =m to reduce kernel size, mostly NFS_FS and CIFS
  since those are quite big and there's no point in having them
  built-in.
* Disable EXT2_FS & EXT3_FS - handled by EXT4 driver
* Disable PCI - unused
parent e729f058
No related branches found
No related tags found
No related merge requests found
Pipeline #208562 passed
......@@ -4,8 +4,8 @@ _flavor=postmarketos-qcom-msm8974
_config="config-$_flavor.$CARCH"
pkgname=linux-$_flavor
pkgver=6.9.1
pkgrel=4
pkgver=6.11.4
pkgrel=0
_tag="v${pkgver/_/-}-msm8974"
pkgdesc="Kernel close to mainline with extra patches for Qualcomm MSM8974 devices"
arch="armv7"
......@@ -27,10 +27,10 @@ makedepends="
openssl-dev
perl
postmarketos-installkernel
python3
"
source="
linux-$_tag.tar.gz::https://github.com/msm8974-mainline/linux/archive/refs/tags/$_tag.tar.gz
hlte-makefile.patch
config-$_flavor.armv7
"
builddir="$srcdir/linux-${_tag#v}"
......@@ -61,7 +61,6 @@ package() {
}
sha512sums="
34b5b1e94bc333df301efd156980b09814b633069aa890e43bd2e5102c2a4bcafbcc758db359e50d96447f9de81be68456fba6749e894e5c8768975329f7a948 linux-v6.9.1-msm8974.tar.gz
25bdaca920e5990ed46fb84017eaaef16ff61a7564cece35c614653105252a020b24ce8b0f64e1c2f19c58f5ad5c2527811e8c85e2bbd278653bb82a9aa50b05 hlte-makefile.patch
8bcf4bfee519aa4b3e62df031fecda102a116def244a805645e5963f8d1503b17d93492acef2df56586b43d4f80120ac9743d2961a5e3d19e47e9a125153cd5a config-postmarketos-qcom-msm8974.armv7
309c67155f975445fb24006a14c0e1a12d922e607dd64949b9b7dcc09737c80f098a0857e11d13ec3a78377216342bd1b6725ed0c7a56b5ecb51ca07936c8bc1 linux-v6.11.4-msm8974.tar.gz
e49496044024895c078d4ca2a37473be11a2d603489690ee7eece60e99f3bd43125500a9f5b4464a731ac26ce9c43070054b310e7eaf5b9f1094876860d94179 config-postmarketos-qcom-msm8974.armv7
"
diff --git a/arch/arm/boot/dts/qcom/Makefile b/arch/arm/boot/dts/qcom/Makefile
index ede704dabaa1..e17dba6677d0 100644
--- a/arch/arm/boot/dts/qcom/Makefile
+++ b/arch/arm/boot/dts/qcom/Makefile
@@ -40,6 +40,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-msm8960-cdp.dtb \
qcom-msm8960-samsung-expressatt.dtb \
qcom-msm8974-lge-nexus5-hammerhead.dtb \
+ qcom-msm8974-samsung-hlte.dtb \
qcom-msm8974-sony-xperia-rhine-amami.dtb \
qcom-msm8974-sony-xperia-rhine-honami.dtb \
qcom-msm8974-sony-xperia-sirius.dtb \
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment