Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
5a3fe777
Verified
Commit
5a3fe777
authored
4 months ago
by
Clayton Craft
Browse files
Options
Downloads
Patches
Plain Diff
DO NOT MERGE: CI debug stuff
[ci:ignore-count]
parent
6621dc07
No related branches found
No related tags found
No related merge requests found
Pipeline
#210502
failed
4 months ago
Stage: build
Changes
1
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
.gitlab-ci.yml
+3
-146
3 additions, 146 deletions
.gitlab-ci.yml
with
3 additions
and
146 deletions
.gitlab-ci.yml
+
3
−
146
View file @
5a3fe777
...
...
@@ -7,9 +7,7 @@ before_script: &global_before_scripts
after_script
:
-
.ci/lib/move_logs.sh $CI_PROJECT_DIR
stages
:
-
lint
-
build
-
autoupdate
variables
:
# Default of 20 is pretty small, sometimes MRs have >20 commits in them. 100
# seems like a reasonable balance. If this is too low, git merge-base (from ci/
...
...
@@ -27,105 +25,6 @@ workflow:
# Run scheduled pipeline for autoupdate or manually triggered pipeline
-
if
:
$CI_PIPELINE_SOURCE == "schedule" || $CI_PIPELINE_SOURCE == "web"
# device documentation
wiki
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
.ci/**/*
-
.gitlab-ci.yml
-
device/*/device-*/*
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/wiki.sh
# testcases linting
ruff
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
.ci/*
-
.ci/*/*
-
.gitlab-ci.yml
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/ruff.sh
# shellcheck and various grep checks
shellcheck-grep
:
stage
:
lint
image
:
alpine:edge
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/shellcheck.sh
-
.ci/grep.sh
-
.ci/codeowners.sh
editor-config
:
stage
:
lint
image
:
alpine:edge
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/ec.sh
# aports checks (generic)
pytest-commits
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/pytest.sh
-
.ci/commits.sh
artifacts
:
when
:
on_failure
paths
:
-
log.txt
-
log_testsuite_pmaports.txt
-
pmbootstrap.cfg
expire_in
:
1 week
# APKBUILD linting
aport-lint
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/apkbuild-lint.sh
allow_failure
:
true
# kernel kconfig check
kernel-kconfig
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
kconfigcheck.toml
-
device/*/linux-*/config-*
-
main/linux-*/config-*
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/kconfig.sh
# MR settings
# (Checks for "Allow commits from members who can merge to the target branch")
mr-settings
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event"
before_script
:
-
*global_before_scripts
-
apk -q add python3
script
:
-
wget -q "https://gitlab.postmarketos.org/postmarketOS/ci-common/-/raw/master/check_mr_settings.py"
-
python3 ./check_mr_settings.py
# build changed aports
.build
:
...
...
@@ -143,55 +42,13 @@ mr-settings:
-
packages/
timeout
:
10 h
build-x86_64
:
extends
:
.build
script
:
-
.ci/build-x86_64.sh
build-x86
:
extends
:
.build
script
:
-
.ci/build-x86.sh
build-aarch64
:
tags
:
-
aarch64
extends
:
.build
script
:
-
.ci/build-aarch64.sh
build-armv7
:
tags
:
-
aarch64
extends
:
.build
script
:
-
.ci/build-armv7.sh
build-armhf
:
extends
:
.build
script
:
-
.ci/build-armhf.sh
build-riscv64
:
extends
:
.build
script
:
-
.ci/build-riscv64.sh
auto-update
:
stage
:
autoupdate
rules
:
# This variable is set in the scheduled pipeline configuration. It should be a space separated list of
# package names to update.
-
if
:
$AUTOUPDATE_PACKAGES !=
null
&& $CI_PIPELINE_SOURCE == "schedule" || $CI_PIPELINE_SOURCE == "web"
before_script
:
-
.ci/lib/gitlab_prepare_ci.sh
script
:
-
.ci/autoupdate.sh "$AUTOUPDATE_PACKAGES"
after_script
:
-
.ci/lib/move_logs.sh $CI_PROJECT_DIR
artifacts
:
when
:
on_failure
paths
:
-
log.txt
-
log_testsuite_pmaports.txt
-
pmbootstrap.cfg
-
ls -hal /
-
find ~/.local/var/pmbootstrap ||
true
-
mount -l
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment