Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
80eb55a6
Commit
80eb55a6
authored
3 years ago
by
Caleb Connolly
Browse files
Options
Downloads
Patches
Plain Diff
main/devicepkg-dev: don't generate splash images (MR 2878)
parent
f54600e9
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/devicepkg-dev/APKBUILD
+3
-4
3 additions, 4 deletions
main/devicepkg-dev/APKBUILD
main/devicepkg-dev/devicepkg_build.sh
+0
-45
0 additions, 45 deletions
main/devicepkg-dev/devicepkg_build.sh
with
3 additions
and
49 deletions
main/devicepkg-dev/APKBUILD
+
3
−
4
View file @
80eb55a6
pkgname
=
devicepkg-dev
pkgver
=
0.1
3.2
pkgrel
=
1
pkgver
=
0.1
4.0
pkgrel
=
0
pkgdesc
=
"Provides default device package functions"
url
=
"https://postmarketos.org"
arch
=
"all"
license
=
"MIT"
depends
=
"postmarketos-splash"
source
=
"
compiler-gcc.h
devicepkg_build.sh
...
...
@@ -62,7 +61,7 @@ package() {
}
sha512sums
=
"
d69930dd790b00fb39760a37d95a10899f0d167e10e2804feb05d9ce04f94185dc32d36edc90214aba2ea2aa09bf18f7dab93f1d2eff23f67beb2cc83be30e7c compiler-gcc.h
77dcc7bc4f90bc11f99b7bb88be171f706f7d92921b694ce862d31ab858a4b8850c9e0bdb68299ffce9f934a3c8ab16eb307fd09534085e65f0101334bd68a9d
devicepkg_build.sh
55bf74eca4f2e486ffcc053f937d3c5acc9e5d6ecf8c022c24b400085186e91b775e843aa56c2be73d4d15e76f9f26fc1968e90c065de40e7c1833d376463eee
devicepkg_build.sh
74c1b9b265a943604d5d538ca66d4b7bcad9adcf40710ab19d795b55aac39669bf1089f7f0ec81aa7a01b537784bef4310e4acc3d7a6ba1f282ab01652bdc4d4 devicepkg_package.sh
f81e74e45ae8e55686ae459f550e229e7398daeafa72bd023c2d8c3a0d50e60bf53d5bbdfec931e9fbabe1cd71de57b2192805aaef091ab90bc7203cbaf66ba6 downstreamkernel_prepare.sh
107242a3da38a574c46cb779e0c75afbeef4cfe659e1b85971973ac55843df06f70f53a5985ca623d4123f05f2984f5dace4a53a3509ecefd7dfdc3c8b705cfe downstreamkernel_package.sh
...
...
This diff is collapsed.
Click to expand it.
main/devicepkg-dev/devicepkg_build.sh
+
0
−
45
View file @
80eb55a6
...
...
@@ -20,49 +20,6 @@ fi
# shellcheck disable=SC1090,SC1091
.
"
$srcdir
/deviceinfo"
# Create splash screens
generate_splash_screens
()
{
splash_config
=
${
SPLASH_CONFIG
:-
/etc/postmarketos/splash.ini
}
splash_width
=
${
deviceinfo_screen_width
:-
720
}
splash_height
=
${
deviceinfo_screen_height
:-
1280
}
# Overwrite $@ to easily iterate over the splash screens. Format:
# $1: splash_name
# $2: text
# $3: arguments
set
--
"splash-loading"
"Loading..."
"--center"
\
"splash-noboot"
"boot partition not found
\\
nhttps://postmarketos.org/troubleshooting"
"--center"
\
"splash-noinitramfsextra"
"initramfs-extra not found
\\
nhttps://postmarketos.org/troubleshooting"
"--center"
\
"splash-norootfs"
"rootfs not found
\\
nhttps://postmarketos.org/troubleshooting"
"--center"
\
"splash-resizefs"
"Loading...
\\
nResizing file system during initial boot"
"--center"
\
"splash-mounterror"
"unable to mount root partition
\\
nhttps://postmarketos.org/troubleshooting"
"--center"
\
"splash-debug-shell"
"WARNING
\\
ndebug-shell is active
\\
nhttps://postmarketos.org/debug-shell"
"--center"
\
"splash-charging-error"
"CHARGING MODE
\\
nerror starting charging-sdl
\\
nhttps://postmarketos.org/troubleshooting"
"--center"
\
"splash-netboot-waiting"
"Waiting for netboot...
\\
nhttps://postmarketos.org/netboot"
"--center"
\
"splash-netboot-error"
"failed to initialize netboot
\\
nhttps://postmarketos.org/netboot"
"--center"
# Loop through the splash screens definitions
while
[
$#
-gt
2
]
do
splash_name
=
$1
splash_text
=
$2
splash_args
=
$3
# shellcheck disable=SC2154
if
[
"
${
deviceinfo_framebuffer_landscape
}
"
=
"true"
]
;
then
splash_args
=
"
${
splash_args
}
--landscape"
fi
# shellcheck disable=SC2086
pmos-make-splash
--text
=
"
${
splash_text
}
"
$splash_args
--config
"
${
splash_config
}
"
\
"
$splash_width
"
"
$splash_height
"
"
$srcdir
/
${
splash_name
}
.ppm"
gzip
"
$srcdir
/
${
splash_name
}
.ppm"
shift
3
# move to the next 3 arguments
done
}
# Convert an input calibration matrix from pixel coordinates to 0-1 coordinates
# and echo it for libinput.
# Parameters:
...
...
@@ -118,8 +75,6 @@ generate_machine_info()
}
>
"
$srcdir
/machine-info"
}
generate_splash_screens
generate_machine_info
# shellcheck disable=SC2154
...
...
This diff is collapsed.
Click to expand it.
Administrator
@root
mentioned in commit
e8882889
By Newbyte on 2023-02-20T13:48:15
·
2 years ago
Imported
mentioned in commit
e8882889
By Newbyte on 2023-02-20T13:48:15
Edited
2 years ago
by
Ghost User
mentioned in commit e8882889ade09431c5bbcdc7674ce90ac5cef9f9 *By Newbyte on 2023-02-20T13:48:15*
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment