Skip to content
Snippets Groups Projects
Commit 99a676dc authored by Bhushan Shah's avatar Bhushan Shah
Browse files

kde/kwin: Add patch to disable finding of QML module

ecm_find_qmlmodule checks if QML modules are installed, and if not it
warns during build time. This is purely for packager knowledge. Not
finding those packages here doesn't affect the runtime of the
kwin_wayland at all.

We are disabling this due to bug in the qmlplugindump which causes it to
not return and get stuck, See issue #28.

Revert this when QTBUG-70460 is solved upstream.
parent ba0ba4e8
No related branches found
No related tags found
No related merge requests found
Pipeline #191390 passed
From a6ac58ff3de0393c7dde05bc379d06c36a0ccb68 Mon Sep 17 00:00:00 2001
From: Bhushan Shah <bhush94@gmail.com>
Date: Wed, 12 Sep 2018 11:51:29 +0530
Subject: [PATCH] Disable finding of qml modules
---
CMakeLists.txt | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 554a9263d..0b058126e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -275,16 +275,16 @@ set_package_properties(Libcap PROPERTIES
)
set(HAVE_LIBCAP ${Libcap_FOUND})
-include(ECMQMLModules)
-ecm_find_qmlmodule(QtQuick 2.3)
-ecm_find_qmlmodule(QtQuick.Controls 1.2)
-ecm_find_qmlmodule(QtQuick.Layouts 1.3)
-ecm_find_qmlmodule(QtQuick.VirtualKeyboard 2.1)
-ecm_find_qmlmodule(QtQuick.Window 2.1)
-ecm_find_qmlmodule(QtMultimedia 5.0)
-ecm_find_qmlmodule(org.kde.kquickcontrolsaddons 2.0)
-ecm_find_qmlmodule(org.kde.plasma.core 2.0)
-ecm_find_qmlmodule(org.kde.plasma.components 2.0)
+#include(ECMQMLModules)
+#ecm_find_qmlmodule(QtQuick 2.3)
+#ecm_find_qmlmodule(QtQuick.Controls 1.2)
+#ecm_find_qmlmodule(QtQuick.Layouts 1.3)
+#ecm_find_qmlmodule(QtQuick.VirtualKeyboard 2.1)
+#ecm_find_qmlmodule(QtQuick.Window 2.1)
+#ecm_find_qmlmodule(QtMultimedia 5.0)
+#ecm_find_qmlmodule(org.kde.kquickcontrolsaddons 2.0)
+#ecm_find_qmlmodule(org.kde.plasma.core 2.0)
+#ecm_find_qmlmodule(org.kde.plasma.components 2.0)
########### configure tests ###############
include(CMakeDependentOption)
--
2.18.0
......@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwin
pkgver=5.13.5
pkgrel=0
pkgrel=1
pkgdesc="An easy to use, but flexible, composited Window Manager"
arch="all"
url="https://www.kde.org/workspaces/plasmadesktop/"
......@@ -20,7 +20,8 @@ makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev kdoctools-dev libx
libepoxy-dev libinput-dev xcb-util-cursor-dev libdrm-dev eudev-dev xcb-util-wm-dev"
source="https://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz
0001-Revert-udev-Only-handle-devices-from-the-current-sea.patch
0002-Revert-libinput-connection-Don-t-hardcode-seat0-anym.patch"
0002-Revert-libinput-connection-Don-t-hardcode-seat0-anym.patch
0001-Disable-finding-of-qml-modules.patch"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Fails due to requiring running X11
......@@ -45,4 +46,5 @@ package() {
}
sha512sums="73f2d16403b7972db8ebe228569504d1e6345a633f8b006b6399575b0ed26dc5a3d047be0f476dedfce16acaaba0e3870e62059d96e4f8471fecafca7eee5a14 kwin-5.13.5.tar.xz
a34ff6926f020117fafd8a31c18a183eecb3e0a5fe6c3f2784f531171552350615fb06cbac2f3a1248011eb83ec32fc9df4b64f82443dee1d8e90c1be49e2690 0001-Revert-udev-Only-handle-devices-from-the-current-sea.patch
a534a3d388f066f84813148743eda1da1be000907ddf2c762c098a7ce38fcc1992eaa74763c47d98e82b83e38a03a828f4f3368e7e7ab733714f993646af7c8b 0002-Revert-libinput-connection-Don-t-hardcode-seat0-anym.patch"
a534a3d388f066f84813148743eda1da1be000907ddf2c762c098a7ce38fcc1992eaa74763c47d98e82b83e38a03a828f4f3368e7e7ab733714f993646af7c8b 0002-Revert-libinput-connection-Don-t-hardcode-seat0-anym.patch
d9e5900b4349d2869be51e89ebcf8e9ea73a830196f40f682ea9d6f56719ae9f54025d7f33c68e71c56e128aa7c6014388d18a6572c1a8c33341c405285156b2 0001-Disable-finding-of-qml-modules.patch"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment