Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
a2b1accb
Verified
Commit
a2b1accb
authored
4 years ago
by
Henrik Grimler
Committed by
Alexey Minnekhanov
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
linux-samsung-dream: fix issue with swapped red and blue colors (MR 1843)
parent
4d327313
Branches
Branches containing commit
No related tags found
No related merge requests found
Pipeline
#196777
passed
4 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
device/testing/linux-samsung-dream/05-BGR-to-RGB-colors.patch
+18
-0
18 additions, 0 deletions
...ce/testing/linux-samsung-dream/05-BGR-to-RGB-colors.patch
device/testing/linux-samsung-dream/APKBUILD
+3
-1
3 additions, 1 deletion
device/testing/linux-samsung-dream/APKBUILD
with
21 additions
and
1 deletion
device/testing/linux-samsung-dream/05-BGR-to-RGB-colors.patch
0 → 100644
+
18
−
0
View file @
a2b1accb
diff --git a/drivers/video/fbdev/exynos/dpu/decon_dsi.c b/drivers/video/fbdev/exynos/dpu/decon_dsi.c
index eeaa2ba19778..3e597a145432 100644
--- a/drivers/video/fbdev/exynos/dpu/decon_dsi.c
+++ b/drivers/video/fbdev/exynos/dpu/decon_dsi.c
@@ -862,11 +862,11 @@
int decon_check_var(struct fb_var_screeninfo *var, struct fb_info *info)
case 24:
/* our 24bpp is unpacked, so 32bpp */
var->bits_per_pixel = 32;
- var->red.offset = 16;
+ var->red.offset = 0;
var->red.length = 8;
var->green.offset = 8;
var->green.length = 8;
- var->blue.offset = 0;
+ var->blue.offset = 16;
var->blue.length = 8;
break;
This diff is collapsed.
Click to expand it.
device/testing/linux-samsung-dream/APKBUILD
+
3
−
1
View file @
a2b1accb
...
...
@@ -3,7 +3,7 @@
pkgname
=
linux-samsung-dream
pkgver
=
4.4.111
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Meta package for Samsung Galaxy S8/S8+ kernel fork"
arch
=
"aarch64"
_carch
=
"arm64"
...
...
@@ -28,6 +28,7 @@ source="
02-fix-decon_reg.patch
03-change-dtb-config-var.patch
04-firmware-path.patch
05-BGR-to-RGB-colors.patch
linux4.2-gcc10-extern_YYLOC_global_declaration.patch
"
builddir
=
"
$srcdir
/
$_repository
-
$_commit
"
...
...
@@ -82,4 +83,5 @@ sha512sums="a7c6d55d12ec5ef2bb388fae4106c63eb89ea0d4f8a682f45a0e15899484b633883c
939b2f5b569c3c9d8e088762e394edc6f4eae4a0f08e8c428f687e4e559bb278cefdd377023271487b6c937a6c5421050d7821cefa34c10d44e7cd904fd12b9a 02-fix-decon_reg.patch
6ad12c90f66b10e6b58e161e44841cbbb73e0aef22e4a32fa390ac664451287c253501c9cf84b87aeac41c13fa29b1d8330df3dd58f890567d8a8543a2432505 03-change-dtb-config-var.patch
18082be5bcb4eec18b4916a116a40653826e45ccc52b6cc364790c37ba9056f383c82ae2027a613b9f1973463ea9dfc09ea2d3e19c0cccb16e65507b42931ec9 04-firmware-path.patch
3b76da1513001f7b926e90d46f1435a86d99884ef8f6fe6d2b49d9b6b152a9a0939b4d9e0933b4b7d34a69ad13ae2782e65ee1e29832598eb5ed9aab4bc12ed1 05-BGR-to-RGB-colors.patch
eaf2e61fcb508cdd239b8fed209d2a09ecac77287f6b46d003918fdf1c6fa2ee63f7390f3ff7c49029b8ed6cbcdd81c7e9a4b1ece9f5060b6fc84e322bd47f41 linux4.2-gcc10-extern_YYLOC_global_declaration.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment