Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
a96b1f87
Unverified
Commit
a96b1f87
authored
4 years ago
by
antonialoytorrens
Committed by
Oliver Smith
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
linux-asus-tf101: fix module loading (MR 1534)
parent
07aa7c7f
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
device/testing/linux-asus-tf101/APKBUILD
+21
-7
21 additions, 7 deletions
device/testing/linux-asus-tf101/APKBUILD
device/testing/linux-asus-tf101/config-asus-tf101.armv7
+3
-3
3 additions, 3 deletions
device/testing/linux-asus-tf101/config-asus-tf101.armv7
with
24 additions
and
10 deletions
device/testing/linux-asus-tf101/APKBUILD
+
21
−
7
View file @
a96b1f87
...
...
@@ -2,7 +2,7 @@
pkgname
=
linux-asus-tf101
pkgver
=
3.1.10
pkgrel
=
4
pkgrel
=
5
pkgdesc
=
"Asus Eee Pad Transformer kernel fork"
arch
=
"armv7"
_carch
=
"arm"
...
...
@@ -10,7 +10,19 @@ _flavor="asus-tf101"
url
=
"https://kernel.org"
license
=
"GPL2"
options
=
"!strip !check !tracedeps pmb:cross-native"
makedepends
=
"perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev devicepkg-dev xz gcc6"
makedepends
=
"
perl
sed
installkernel
bash
gmp-dev
bc
linux-headers
elfutils-dev
devicepkg-dev
xz
gcc6
"
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
# request if you find out that it is booting working with newer GCCs as
...
...
@@ -25,8 +37,7 @@ fi
_repository
=
"TF101-GNU-kernel"
_commit
=
"5ddd9654ec52599fbef71657ad2e03b3cdacee31"
_config
=
"config-
$_flavor
.
$arch
"
source
=
"
$pkgname
-
$_commit
.tar.gz::https://github.com/jmrohwer/
$_repository
/archive/
$_commit
.tar.gz
source
=
"
$pkgname
-
$_commit
.tar.gz::https://github.com/jmrohwer/
$_repository
/archive/
$_commit
.tar.gz
compiler-gcc6.h
00-fix_return_address.patch
01-fix-alignment.patch
...
...
@@ -47,8 +58,11 @@ prepare() {
build
()
{
unset
LDFLAGS
make
ARCH
=
"
$_carch
"
CC
=
"
${
CC
:-
gcc
}
"
\
KBUILD_BUILD_VERSION
=
"
$((
pkgrel
+
1
))
-postmarketOS"
make
ARCH
=
"
$_carch
"
CC
=
"
${
CC
:-
gcc
}
"
\
KBUILD_BUILD_VERSION
=
"
$((
pkgrel
+
1
))
-postmarketOS"
# the 'no-pic' flag is necessary to avoid the
# error 'Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0)' when loading the module
make
ARCH
=
"
$_carch
"
CC
=
"
${
CC
:-
gcc
}
"
CFLAGS_MODULE
=
"-fno-pic"
\
KBUILD_BUILD_VERSION
=
"
$((
pkgrel
+
1
))
-postmarketOS"
modules
}
...
...
@@ -72,4 +86,4 @@ cdddc37d3c173c931631037d7c337e45589420eba956231436b8d3b857b942db7fd33e4800d0bada
bc8d62c7bf3de7074b5526906716326dede61f7358278b0a88f33e8fa235dc5305e0fbb45e751817db2aec1fca9ea116962527a2d772fe3892e176a07a8635bd 05-Revert-Update-TF101.patch
60067a14f1b8f71c7cd32f7eaf09c086b0641240ffee55cf4363ba050526625f55e1601fc4702b115f0a301e4526effe487fd1b6cfa85790b20e26fb09ca4f08 06-Enable-USB-Networking.patch
59d9c2b365123acd6eca7b78403a893d8d78867db182ddc1fda2c521e85bb86f871fcb32ecc3ae5248a2cbb93a644a9d665085defe07987ece70326323329953 07-Added-Parameters-to-Atmel-TouchScreen-Drivers.patch
931782f11112f03dea5
77
1
21
4382ecc8bab9a2fbb4beb73c4813d2a94bf3bb10ef108dbbc472d65ddeaf482c74147e1153015964428070ee8940034186c913c1
config-asus-tf101.armv7"
8016bb7bcf2796c94dec26b41273
7721
26321c43bc23cc70d423521865c9840991b5ff5c448e4fdce03cd05f03e91a24c55ce75cc506356dcc8a3bd272259e90
config-asus-tf101.armv7"
This diff is collapsed.
Click to expand it.
device/testing/linux-asus-tf101/config-asus-tf101.armv7
+
3
−
3
View file @
a96b1f87
...
...
@@ -1224,9 +1224,9 @@ CONFIG_WLAN=y
# CONFIG_USB_NET_RNDIS_WLAN is not set
# CONFIG_ATH_COMMON is not set
# CONFIG_BCM4329 is not set
CONFIG_BCMDHD=
y
CONFIG_BCMDHD_FW_DIR="/lib/firmware/"
CONFIG_BCMDHD_NVRAM_DIR="/lib/firmware/"
CONFIG_BCMDHD=
m
CONFIG_BCMDHD_FW_DIR="/lib/firmware/
postmarketos/bcmdhd/
"
CONFIG_BCMDHD_NVRAM_DIR="/lib/firmware/
postmarketos/bcmdhd/bcm4329/
"
# CONFIG_BCMDHD_WEXT is not set
CONFIG_BCMDHD_CFG80211=y
# CONFIG_BCMDHD_NOAPI is not set
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment