Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
ab27ea7e
Verified
Commit
ab27ea7e
authored
6 months ago
by
Clayton Craft
Browse files
Options
Downloads
Patches
Plain Diff
DO NOT MERGE: trim CI, limit to specific runner
parent
762f3834
No related branches found
No related tags found
No related merge requests found
Pipeline
#208235
canceled
6 months ago
Stage: build
Changes
1
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
.gitlab-ci.yml
+2
-126
2 additions, 126 deletions
.gitlab-ci.yml
with
2 additions
and
126 deletions
.gitlab-ci.yml
+
2
−
126
View file @
ab27ea7e
...
...
@@ -7,7 +7,6 @@ before_script: &global_before_scripts
after_script
:
-
.ci/lib/move_logs.sh $CI_PROJECT_DIR
stages
:
-
lint
-
build
-
autoupdate
...
...
@@ -22,106 +21,6 @@ workflow:
# Run scheduled pipeline for autoupdate or manually triggered pipeline
-
if
:
$CI_PIPELINE_SOURCE == "schedule" || $CI_PIPELINE_SOURCE == "web"
# device documentation
wiki
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
.ci/**/*
-
.gitlab-ci.yml
-
device/*/device-*/*
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/wiki.sh
# testcases linting
ruff
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
.ci/*
-
.ci/*/*
-
.gitlab-ci.yml
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/ruff.sh
# shellcheck and various grep checks
shellcheck-grep
:
stage
:
lint
image
:
alpine:edge
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/shellcheck.sh
-
.ci/grep.sh
-
.ci/codeowners.sh
editor-config
:
stage
:
lint
image
:
alpine:edge
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/ec.sh
# aports checks (generic)
pytest-commits
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/pytest.sh
-
.ci/commits.sh
artifacts
:
when
:
on_failure
paths
:
-
log.txt
-
log_testsuite_pmaports.txt
-
pmbootstrap.cfg
expire_in
:
1 week
# APKBUILD linting
aport-lint
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/apkbuild-lint.sh
allow_failure
:
true
# kernel kconfig check
kernel-kconfig
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event" || $CI_COMMIT_REF_PROTECTED == "false"
changes
:
-
kconfigcheck.toml
-
device/*/linux-*/config-*
-
main/linux-*/config-*
script
:
-
.ci/lib/gitlab_prepare_ci.sh
-
.ci/kconfig.sh
# MR settings
# (Checks for "Allow commits from members who can merge to the target branch")
mr-settings
:
stage
:
lint
rules
:
-
if
:
$CI_PIPELINE_SOURCE == "merge_request_event"
before_script
:
-
*global_before_scripts
-
apk -q add python3
script
:
-
wget -q "https://gitlab.postmarketos.org/postmarketOS/ci-common/-/raw/master/check_mr_settings.py"
-
python3 ./check_mr_settings.py
# build changed aports
.build
:
stage
:
build
...
...
@@ -138,36 +37,13 @@ mr-settings:
-
packages/
timeout
:
10 h
build-x86_64
:
extends
:
.build
script
:
-
.ci/build-x86_64.sh
build-x86
:
extends
:
.build
script
:
-
.ci/build-x86.sh
build-aarch64
:
extends
:
.build
tags
:
-
runner5
script
:
-
.ci/build-aarch64.sh
build-armv7
:
extends
:
.build
script
:
-
.ci/build-armv7.sh
build-armhf
:
extends
:
.build
script
:
-
.ci/build-armhf.sh
build-riscv64
:
extends
:
.build
script
:
-
.ci/build-riscv64.sh
auto-update
:
stage
:
autoupdate
rules
:
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment