Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
bca96b10
Unverified
Commit
bca96b10
authored
3 years ago
by
Bobby The Builder
Committed by
Oliver Smith
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
temp/u-boot-pinephone: remove unsupported boards (MR 2155)
parent
a849da48
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
temp/u-boot-pinephone/APKBUILD
+1
-1
1 addition, 1 deletion
temp/u-boot-pinephone/APKBUILD
temp/u-boot-pinephone/update-u-boot
+1
-30
1 addition, 30 deletions
temp/u-boot-pinephone/update-u-boot
with
2 additions
and
31 deletions
temp/u-boot-pinephone/APKBUILD
+
1
−
1
View file @
bca96b10
...
...
@@ -52,5 +52,5 @@ package() {
sha512sums
=
"
73b132cdc26113a83d060f0d243320ca989b4efa98fe95a2205526a42f615ced7046bb9d4878c67a9a550b04c2519d90be3c2272be97c878d759bf5d027cf536 u-boot-7492749fec31b1086bc8933bf113a766aea021aa.tar.gz
3cba8a0e899be8cb0b9260b7a86d4115f74c279a1bac8c1403ee669adf91dca8215d8d2d6395ebb3cd67ce000f37a51d6e033b62a8d616b346a9072fa58a4b70 0001-expose-DRAM-clock-speed.patch
1383521ba8adf0b1b46a172302c005e7bb73c01b2252d783b4df76d56769c5a4dd8c08b997ad34e9ac3811216b7bc3813014518f19ad0f657763b8ac4f34e265
update-u-boot
2b00f3ac20d435f88677064dfbe83a893da98565b0a1a0b7c429ba61d53a088846ea7f36cffc63d615be09560d19ed490665add87533875746186ab1742d3068
update-u-boot
"
This diff is collapsed.
Click to expand it.
temp/u-boot-pinephone/update-u-boot
+
1
−
30
View file @
bca96b10
...
...
@@ -17,9 +17,6 @@ get_boot_blockdev() {
get_defaults
()
{
if
[
-z
"
$board
"
-a
-e
/sys/firmware/devicetree/base/compatible
]
;
then
case
"
$(
cat
/sys/firmware/devicetree/base/compatible 2>/dev/null
)
"
in
wand,
*
)
board
=
wand
;;
pine64,pinebook-pro
*
)
board
=
pinebookpro
;;
pine64,rockpro64
*
)
board
=
rockpro64
;;
pine64,pinephone
*
)
board
=
pinephone
;;
pine64,pinetab
*
)
board
=
pinetab
;;
esac
...
...
@@ -27,9 +24,6 @@ get_defaults() {
if
[
-z
"
$device
"
]
;
then
case
"
$board
"
in
wand|cubie|cubie2
)
device
=
/dev/mmcblk0p0
;;
mx6cuboxi
)
device
=
/dev/mmcblk0
;;
pinebookpro|rockpro64
)
device
=
/dev/mmcblk2
;;
pinephone|pinetab
)
device
=
$(
get_boot_blockdev
)
;;
esac
fi
...
...
@@ -68,7 +62,7 @@ usage: $0 [-n,--dry-run] [-i,--imagedir <imagedir>] [-b|--board <board-type>] [-
options:
-b,--board <board> Specify the board type:
wand, cubie, cubie2, cuboxi, pinebookpro, rockpro64
-b,--board <board> Specify the board type:
pinephone, pinetab
(current default:
${
board
:-
none
}
)
-d,--device <device> Specify the device where to install u-boot
...
...
@@ -114,11 +108,6 @@ while [ $# -gt 0 ]; do
case
"
$opt
"
in
-b
|
--board
)
case
"
$1
"
in
wand|wandboard
)
board
=
"wand"
;;
cubie|cubieboard
)
board
=
"cubie"
;;
cuboxi|mx6cuboxi
)
board
=
"mx6cuboxi"
;;
pinebookpro
)
board
=
"pinebookpro"
;;
rockpro64
)
board
=
"rockpro64"
;;
pinephone
)
board
=
"pinephone"
;;
pinetab
)
board
=
"pinetab"
;;
*
)
usage
;
exit
1
;;
...
...
@@ -194,24 +183,6 @@ fi
(
set
-e
case
"
$board
"
in
wand
)
[
-e
"
$imagedir
/wandboard"
]
||
die
"wandboard images not installed, apk add u-boot-wandboard"
$dryrun
dd
if
=
$imagedir
/wandboard/SPL
of
=
$device
bs
=
1k
seek
=
1
status
=
none
$dryrun
dd
if
=
$imagedir
/wandboard/u-boot.img
of
=
$device
bs
=
1k
seek
=
69
status
=
none
;;
cubie|cubie2
)
[
-e
"
$imagedir
/Cubieboard
${
board
#cubie
}
"
]
||
die
"Cubieboard images not installed, apk add u-boot-cubieboard"
$dryrun
dd
if
=
$imagedir
/Cubieboard
${
board
#cubie
}
/u-boot-sunxi-with-spl.bin
of
=
$device
bs
=
1024
seek
=
8
status
=
none
;;
mx6cuboxi
)
[
-e
"
$imagedir
/mx6cuboxi"
]
||
die
"iMX6 Cubox-i images not installed, apk add u-boot-cuboxi"
$dryrun
dd
if
=
$imagedir
/mx6cuboxi/SPL
of
=
$device
bs
=
1k
seek
=
1
status
=
none
$dryrun
dd
if
=
$imagedir
/mx6cuboxi/u-boot.img
of
=
$device
bs
=
1k
seek
=
69
status
=
none
;;
pinebookpro|rockpro64
)
[
-e
"
$imagedir
/pine64-rockpro64/"
]
||
die
"rockpro64 images not installed, apk add u-boot-rockpro64"
$dryrun
dd
if
=
$imagedir
/pine64-rockpro64/u-boot-rockchip.bin
of
=
$device
bs
=
1024
seek
=
32
status
=
none
;;
pinephone|pinetab
)
[
-e
"
$imagedir
/pine64-pinephone/"
]
||
die
"pinephone images not installed, apk add u-boot-pinephone"
$dryrun
dd
if
=
$imagedir
/pine64-pinephone/u-boot-sunxi-with-spl-
$freq
.bin
of
=
$device
bs
=
1024
seek
=
8
oflag
=
direct
status
=
none
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment