Skip to content
Snippets Groups Projects
Verified Commit bf20cfc4 authored by Pablo Correa Gomez's avatar Pablo Correa Gomez :beach: Committed by Clayton Craft
Browse files

temp/epiphany: drop (MR 3098)

Helps #1479

The Disable-fullscreen patch from Purism is in principle useful
in mobile, as exiting fullscreen is at least troublesome. However,
the patch has not been upstreamed and, although we could carry it
in alpine for the 42 cycle, the 43 cycle will come with GTK4 support
and the patch will not rebase easily. Therefore, instead of waiting
6 months to drop, lets just drop it now.

[ci:skip-build] already built successfully in CI
parent 80793cb2
Branches
No related tags found
No related merge requests found
Pipeline #195523 passed
From 69ab588d7f40aed43302d5f3a73fb7ab84be2b5a Mon Sep 17 00:00:00 2001
From: Patrick Griffis <pgriffis@igalia.com>
Date: Thu, 23 Dec 2021 14:51:50 -0600
Subject: [PATCH] Port to libportal 0.5
This was an API breaking release that requires minor changes.
Original patch:
https://gitlab.gnome.org/GNOME/epiphany/-/commit/84474398f6e59266b73170838219aa896729ce93
---
lib/ephy-flatpak-utils.c | 2 +-
meson.build | 2 +-
org.gnome.Epiphany.Canary.json.in | 6 ++++--
org.gnome.Epiphany.json | 6 ++++--
4 files changed, 10 insertions(+), 6 deletions(-)
diff --git a/lib/ephy-flatpak-utils.c b/lib/ephy-flatpak-utils.c
index 818af95f4..aef937f43 100644
--- a/lib/ephy-flatpak-utils.c
+++ b/lib/ephy-flatpak-utils.c
@@ -29,7 +29,7 @@
#include <gio/gio.h>
#include <gio/gunixfdlist.h>
#if USE_LIBPORTAL
-#include <libportal/portal-gtk3.h>
+#include <libportal-gtk3/portal-gtk3.h>
#endif
#include <string.h>
#include <sys/stat.h>
diff --git a/meson.build b/meson.build
index feb300b71..357035ee4 100644
--- a/meson.build
+++ b/meson.build
@@ -96,7 +96,7 @@ libhandy_dep = dependency('libhandy-1', version: '>= 1.1.0')
libsecret_dep = dependency('libsecret-1', version: '>= 0.19.0')
libxml_dep = dependency('libxml-2.0', version: '>= 2.6.12')
nettle_dep = dependency('nettle', version: nettle_requirement)
-portal_dep = dependency('libportal', version: '>= 0.0.2', required: get_option('libportal'))
+portal_dep = dependency('libportal-gtk3', version: '>= 0.5', required: get_option('libportal'))
sqlite3_dep = dependency('sqlite3', version: '>= 3.22')
if get_option('soup2').enabled()
diff --git a/org.gnome.Epiphany.Canary.json.in b/org.gnome.Epiphany.Canary.json.in
index bc6984838..09d479014 100644
--- a/org.gnome.Epiphany.Canary.json.in
+++ b/org.gnome.Epiphany.Canary.json.in
@@ -106,13 +106,15 @@
"name" : "libportal",
"buildsystem" : "meson",
"config-opts" : [
- "-Dgtk_doc=false"
+ "-Dbackends=gtk3",
+ "-Dintrospection=false",
+ "-Ddocs=false"
],
"sources" : [
{
"type" : "git",
"url" : "https://github.com/flatpak/libportal.git",
- "tag" : "0.4"
+ "tag" : "0.5"
}
]
},
diff --git a/org.gnome.Epiphany.json b/org.gnome.Epiphany.json
index 9f37ea823..5d2cb0d1a 100644
--- a/org.gnome.Epiphany.json
+++ b/org.gnome.Epiphany.json
@@ -103,13 +103,15 @@
"name" : "libportal",
"buildsystem" : "meson",
"config-opts" : [
- "-Dgtk_doc=false"
+ "-Dbackends=gtk3",
+ "-Dintrospection=false",
+ "-Ddocs=false"
],
"sources" : [
{
"type" : "git",
"url" : "https://github.com/flatpak/libportal.git",
- "tag" : "0.4"
+ "tag" : "0.5"
}
]
},
--
2.30.2
# Forked from Alpine to apply adaptability mobile patches
pkgname=epiphany
pkgver=9999_git20210916
_pkgver=41.3
pkgrel=1
pkgdesc="A simple, clean, beautiful view of the web [$_pkgver]"
url="https://wiki.gnome.org/Apps/Web"
# s390x, mips64 and riscv64 blocked by rust -> libhandy1
arch="all !s390x !mips64 !riscv64"
license="GPL-3.0-or-later"
depends="gsettings-desktop-schemas dbus:org.freedesktop.Secrets"
makedepends="meson iso-codes-dev gtk+3.0-dev gsettings-desktop-schemas-dev
icu-dev json-glib-dev libdazzle-dev libhandy1-dev libnotify-dev libsecret-dev
libsoup-dev libxml2-dev nettle-dev sqlite-dev webkit2gtk-dev gcr-dev itstool
libportal-dev libarchive-dev"
checkdepends="appstream-glib desktop-file-utils xvfb-run ibus"
options="!check" # Fail due to our webkitgtk patches!
subpackages="$pkgname-lang $pkgname-doc $pkgname-dbg"
_purism_commit="326e2f6b05bf057dc25f3e80c74d617188836c17"
_purism_patches="https://source.puri.sm/Librem5/debs/epiphany/-/raw/$_purism_commit/debian/patches"
source="https://download.gnome.org/sources/epiphany/${_pkgver%.*}/epiphany-$_pkgver.tar.xz
$_purism_patches/pureos/Disable-fullscreen.patch
0001-Port-to-libportal-0.5.patch
"
builddir="$srcdir/$pkgname-$_pkgver"
build() {
abuild-meson . output
meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
# https://gitlab.gnome.org/GNOME/epiphany/issues/829
env PATH="$PATH:$builddir/output/src" xvfb-run meson test --no-rebuild -v -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
1effef22291687c8ff2252eced24274db3b1f4afacfc3053a33cae85112759918f80d824bb02b7e17d95364eec0062cb3459a6079783d9c900874cc150ea98ba epiphany-41.3.tar.xz
63290c9b52751e4adc324e5f39790ae809fe77067371c15e757e53244706e84063781e4ac9d38c892e0bf616c9dea0414157ba5db4c93a4523d291527603f56f Disable-fullscreen.patch
46b0c50c37ed5a10bb2bfdaffa8c2244eb34233e3446f08e8257340f60cee4797dd3dee37fb56005ddba1305b1708b14895983386a7d9ca0b868396aeda992ef 0001-Port-to-libportal-0.5.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment