Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
d3fdb85b
Commit
d3fdb85b
authored
6 years ago
by
Luca Weiss
Browse files
Options
Downloads
Patches
Plain Diff
Add patch sent by bhushan to apparently fix the panel
parent
8863f67d
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/linux-postmarketos-allwinner/APKBUILD
+3
-1
3 additions, 1 deletion
main/linux-postmarketos-allwinner/APKBUILD
main/linux-postmarketos-allwinner/extra.patch
+26
-0
26 additions, 0 deletions
main/linux-postmarketos-allwinner/extra.patch
with
29 additions
and
1 deletion
main/linux-postmarketos-allwinner/APKBUILD
+
3
−
1
View file @
d3fdb85b
...
...
@@ -17,6 +17,7 @@ _commit="399381b838535c2384b33fb1497f8ada2a9ebe8f"
source
=
"
linux-
${
_commit
}
.tar.gz::https://github.com/amarula/linux-amarula/archive/
${
_commit
}
.tar.gz
config-
${
_flavor
}
.aarch64
extra.patch
"
subpackages
=
"
$pkgname
-dev"
...
...
@@ -177,4 +178,5 @@ dev() {
fi
}
sha512sums
=
"b4f56dd4cc3a24c715bbe6dea43382d606cb0b1d2ba894cd7201331084a46295fbf2277be9fbbeba96a72ebbdadedf27df1ec0845b7d492e8bc7a4e991b69871 linux-399381b838535c2384b33fb1497f8ada2a9ebe8f.tar.gz
83df4ac28c28dd7c868218b4c00e4ac2f364c6ddbc4c92dc1bad5c1690d9c24e0bc3dd2591050d3591c49dff0cab299323845a78466923570afa86fce9f78405 config-postmarketos-allwinner.aarch64"
83df4ac28c28dd7c868218b4c00e4ac2f364c6ddbc4c92dc1bad5c1690d9c24e0bc3dd2591050d3591c49dff0cab299323845a78466923570afa86fce9f78405 config-postmarketos-allwinner.aarch64
0a1cb87e73ad84c778cd8e4a627873e6ec2c0285f3c9d92451bf588b14702f732ce192d25b4f0e8c6cf282de8df5064dfd23f61f06e96e71fb105b21ecfa3e0f extra.patch"
This diff is collapsed.
Click to expand it.
main/linux-postmarketos-allwinner/extra.patch
0 → 100644
+
26
−
0
View file @
d3fdb85b
diff --git a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
index b623c8150b4f..1f47e4954e9d 100644
--- a/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
+++ b/drivers/clk/sunxi-ng/ccu-sun50i-a64.c
@@ -183,7 +183,7 @@
static struct ccu_nkm pll_mipi_clk = {
.n = _SUNXI_CCU_MULT(8, 4),
.k = _SUNXI_CCU_MULT_MIN(4, 2, 2),
.m = _SUNXI_CCU_DIV(0, 4),
- .min_rate = 300000000, /* Actual rate is 500MHz */
+ .min_rate = 330000000, /* Actual rate is 500MHz */
.common = {
.reg = 0x040,
.hw.init = CLK_HW_INIT("pll-mipi", "pll-video0",
diff --git a/drivers/clk/sunxi-ng/ccu_nkm.c b/drivers/clk/sunxi-ng/ccu_nkm.c
index 096ff4f4839a..6c7a705b8bfb 100644
--- a/drivers/clk/sunxi-ng/ccu_nkm.c
+++ b/drivers/clk/sunxi-ng/ccu_nkm.c
@@ -125,7 +125,7 @@
static unsigned long ccu_nkm_round_rate(struct ccu_mux_internal *mux,
if (nkm->common.features & CCU_FEATURE_FIXED_POSTDIV)
rate *= nkm->fixed_post_div;
- if (rate < nkm->min_rate) {
+ if (rate <= nkm->min_rate) {
rate = nkm->min_rate;
return rate;
}
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment