Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
ea840383
Unverified
Commit
ea840383
authored
5 years ago
by
Bart Ribbers
Committed by
Oliver Smith
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
kde/falkon: remove, upstreamed (
!566
)
parent
3f28c769
Branches
Branches containing commit
No related tags found
No related merge requests found
Pipeline
#196602
passed
5 years ago
Stage: first
Stage: second
Changes
3
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
kde/falkon/APKBUILD
+0
-44
0 additions, 44 deletions
kde/falkon/APKBUILD
kde/falkon/disable-backtraces.patch
+0
-35
0 additions, 35 deletions
kde/falkon/disable-backtraces.patch
kde/falkon/disable-ld-fatal-warnings.patch
+0
-29
0 additions, 29 deletions
kde/falkon/disable-ld-fatal-warnings.patch
with
0 additions
and
108 deletions
kde/falkon/APKBUILD
deleted
100644 → 0
+
0
−
44
View file @
3f28c769
# Contributor: George Hopkins <george-hopkins@null.net>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
falkon
pkgver
=
3.0.1
pkgrel
=
2
pkgdesc
=
"Cross-platform web browser using QtWebEngine rendering engine"
url
=
"https://www.falkon.org/"
arch
=
"all"
license
=
"GPL-3.0-or-later"
depends
=
"qt5-qtbase-sqlite"
makedepends
=
"cmake extra-cmake-modules qt5-qtdeclarative-dev qt5-qtwebengine-dev qt5-qtx11extras-dev qt5-qttools-dev xcb-util-dev ki18n-dev ttf-freefont"
source
=
"https://download.kde.org/stable/falkon/
$pkgver
/
$pkgname
-
$pkgver
.tar.xz
disable-ld-fatal-warnings.patch
disable-backtraces.patch"
options
=
"!check"
# Requires X11
prepare
()
{
mkdir
"
$builddir
"
/build
default_prepare
}
build
()
{
cd
"
$builddir
"
/build
cmake ..
\
-DCMAKE_BUILD_TYPE
=
RelWithDebugInfo
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
make
}
check
()
{
cd
"
$builddir
"
/build
CTEST_OUTPUT_ON_FAILURE
=
TRUE ctest
}
package
()
{
cd
"
$builddir
"
/build
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"e2384cb49d4e1ec52ff7804cf798688be2d80fa5957c72accb09376aa0c41ee491c45234fd53c79871bc474a8d0677e40ddb48241a70d77102c67406b0719191 falkon-3.0.1.tar.xz
fa3df8f056198c6120b4da8fc4b62b08ac9ab5f2c97e76a45eca8db1a41a03b64696681fe35b939cf2f8472f6bb8844d3baac8c5f979d0bf99b9a329259f50e4 disable-ld-fatal-warnings.patch
0fb09a9219ecbc6ee5c0f7e3721c33b186f6040be254f72f1901cab047d37402edd881ab42448ad4aeda2d1286c963c33a720b2ed47f321c55755ecdf12f0ec4 disable-backtraces.patch"
This diff is collapsed.
Click to expand it.
kde/falkon/disable-backtraces.patch
deleted
100644 → 0
+
0
−
35
View file @
3f28c769
From ae573b560d0e59a2a32e0e6c20a5522e52fb8b2c Mon Sep 17 00:00:00 2001
From: George Hopkins <george-hopkins@null.net>
Date: Thu, 31 May 2018 13:00:01 +0200
Subject: [PATCH] Disable backtraces
Signed-off-by: George Hopkins <george-hopkins@null.net>
---
src/main/main.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/main/main.cpp b/src/main/main.cpp
index c1af1b6..cdf938d 100644
--- a/src/main/main.cpp
+++ b/src/main/main.cpp
@@ -22,7 +22,7 @@
#include <QMessageBox> // For QT_REQUIRE_VERSION
#include <iostream>
-#if defined(Q_OS_LINUX) || defined(__GLIBC__) || defined(__FreeBSD__) || defined(__HAIKU__)
+#if (defined(Q_OS_LINUX) || defined(__GLIBC__) || defined(__FreeBSD__) || defined(__HAIKU__)) && defined(HAVE_BACKTRACE)
#include <signal.h>
#include <execinfo.h>
@@ -129,7 +129,7 @@
int main(int argc, char* argv[])
qInstallMessageHandler(&msgHandler);
#endif
-#if defined(Q_OS_LINUX) || defined(__GLIBC__) || defined(__FreeBSD__)
+#if (defined(Q_OS_LINUX) || defined(__GLIBC__) || defined(__FreeBSD__) || defined(__HAIKU__)) && defined(HAVE_BACKTRACE)
signal(SIGSEGV, falkon_signal_handler);
#endif
--
2.7.4
This diff is collapsed.
Click to expand it.
kde/falkon/disable-ld-fatal-warnings.patch
deleted
100644 → 0
+
0
−
29
View file @
3f28c769
From 62ec63fab15b1835c94212f47c04636662e0ac76 Mon Sep 17 00:00:00 2001
From: George Hopkins <george-hopkins@null.net>
Date: Thu, 31 May 2018 12:55:06 +0200
Subject: [PATCH 1/2] Disable fatal linker warnings
libQt5Network.so depends on EVP_CipherFinal which throws a warning.
Signed-off-by: George Hopkins <george-hopkins@null.net>
---
CMakeLists.txt | 3 +++
1 file changed, 3 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb35545..357fafe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,6 +143,9 @@
if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
endif()
endif()
+set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-fatal-warnings")
+set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-fatal-warnings")
+
configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config.h)
# Include dirs used everywhere
--
2.7.4
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment