Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
0de1146e
Unverified
Commit
0de1146e
authored
5 years ago
by
Bart Ribbers
Committed by
Alexey Minnekhanov
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
maemo/dsme: new aport (
!810
)
parent
12702997
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
maemo/dsme/APKBUILD
+27
-0
27 additions, 0 deletions
maemo/dsme/APKBUILD
maemo/dsme/build-fix.patch
+84
-0
84 additions, 0 deletions
maemo/dsme/build-fix.patch
with
111 additions
and
0 deletions
maemo/dsme/APKBUILD
0 → 100644
+
27
−
0
View file @
0de1146e
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Contributor: Nikita Ukhrenkov <thekit@disroot.org>
# Maintainer: Nikita Ukhrenkov <thekit@disroot.org>
pkgname
=
dsme
pkgver
=
0.61.5
pkgrel
=
0
pkgdesc
=
"DSME is responsible of device state management, process lifeguard support, watch dogs and thermal management"
url
=
"https://github.com/maemo-leste/dsme"
arch
=
"all !armhf !armv7"
license
=
"LGPL-2.1-only"
depends_dev
=
"glib-dev dbus-glib-dev linux-headers libdsme-dev libcal-dev"
makedepends
=
"
$depends_dev
bash"
subpackages
=
"
$pkgname
-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/maemo-leste/dsme/archive/
$pkgver
.tar.gz
build-fix.patch"
options
=
"!check"
build
()
{
make
-j1
}
package
()
{
DESTDIR
=
"
$pkgdir
"
make
install
}
sha512sums
=
"68e04aae2cf585a6082f6f60c8fbc8a864204bc6c2333d9683bb044f0f24926887e137135987f2e494e0e2e62a76b110334974e24347b88a3115b767efeaf2d7 dsme-0.61.5.tar.gz
174cd9b35b47c8e5573510ae6e4b7a1fbdefe00a2f7622c620acd6ab19f4d56752b0a78be96b1866cbeb7d03a867a8561b050e54b96ff81f33deae25c2404100 build-fix.patch"
This diff is collapsed.
Click to expand it.
maemo/dsme/build-fix.patch
0 → 100644
+
84
−
0
View file @
0de1146e
From 826bf12619b368899d49d0f72957ad42ef863642 Mon Sep 17 00:00:00 2001
From: NeKit <nekit1000@gmail.com>
Date: Thu, 10 Oct 2019 13:47:50 +0200
Subject: [PATCH] Fix compilation on postmarketOS with musl
---
Rules.make | 2 +-
util/Makefile | 12 ++++++------
util/dsmetest.c | 2 +-
util/dsmetool.c | 2 +-
4 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/Rules.make b/Rules.make
index c02de3e..d9b9a42 100644
--- a/Rules.make
+++ b/Rules.make
@@ -185,7 +185,7 @@
$(DISTCLN_SUBDIRS):
# Common rule for all executables
ifndef INSTALLING
$(BINARIES):
- $(CC) -o $@ $(LDFLAGS) $(call TARGET_OBJS,$@) $(addprefix -l,$($@_SO_LIBS) $($@_A_LIBS) $($@_LIBS))
+ $(CC) -o $@ $(call TARGET_OBJS,$@) $(LDFLAGS) $(addprefix -l,$($@_SO_LIBS) $($@_A_LIBS) $($@_LIBS))
endif
diff --git a/util/Makefile b/util/Makefile
index e592d13..6dac30a 100644
--- a/util/Makefile
+++ b/util/Makefile
@@ -8,19 +8,19 @@
BINARIES := batttest dsmetool dsmetest bootstate waitfordsme dsmereboot
# Target composition and overrides
#
batttest_C_OBJS := batttest.o
-batttest_LIBS := dsme
+batttest_LIBS := dsme glib-2.0
dsmetool_C_OBJS := dsmetool.o
-dsmetool_LIBS := dsme
+dsmetool_LIBS := dsme glib-2.0
dsmetest_C_OBJS := dsmetest.o
-dsmetest_LIBS := dsme
+dsmetest_LIBS := dsme glib-2.0
bootstate_C_OBJS := bootstate.o
-bootstate_LIBS := dsme
+bootstate_LIBS := dsme glib-2.0
waitfordsme_C_OBJS := waitfordsme.o
-waitfordsme_LIBS := dsme
+waitfordsme_LIBS := dsme glib-2.0
kicker_C_OBJS := kicker.o
kicker_LIBS := dsme cal
dsmereboot_C_OBJS := dsmereboot.o
-dsmereboot_LIBS := dsme
+dsmereboot_LIBS := dsme glib-2.0
#
diff --git a/util/dsmetest.c b/util/dsmetest.c
index 2fc0f56..8a95547 100644
--- a/util/dsmetest.c
+++ b/util/dsmetest.c
@@ -29,7 +29,7 @@
#include <stdlib.h>
#include <sys/types.h>
#include <sys/stat.h>
-#include <sys/fcntl.h>
+#include <fcntl.h>
#include <sys/time.h>
#include <unistd.h>
#include <errno.h>
diff --git a/util/dsmetool.c b/util/dsmetool.c
index 251a883..0e5d2a8 100644
--- a/util/dsmetool.c
+++ b/util/dsmetool.c
@@ -32,7 +32,7 @@
#include <stdbool.h>
#include <sys/types.h>
#include <sys/stat.h>
-#include <sys/fcntl.h>
+#include <fcntl.h>
#include <sys/time.h>
#include <unistd.h>
#include <errno.h>
--
2.23.0
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment