Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
9bd16849
Unverified
Commit
9bd16849
authored
5 years ago
by
Bart Ribbers
Committed by
Alexey Minnekhanov
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
maemo/osso-systemui: new aport (
!810
)
parent
6fe71d5c
Branches
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
maemo/osso-systemui/APKBUILD
+33
-0
33 additions, 0 deletions
maemo/osso-systemui/APKBUILD
maemo/osso-systemui/osso-systemui-musl-fix.patch
+27
-0
27 additions, 0 deletions
maemo/osso-systemui/osso-systemui-musl-fix.patch
with
60 additions
and
0 deletions
maemo/osso-systemui/APKBUILD
0 → 100644
+
33
−
0
View file @
9bd16849
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Nikita Ukhrenkov <thekit@disroot.org>
pkgname
=
osso-systemui
pkgver
=
0.2.0.19
pkgrel
=
0
pkgdesc
=
"OSSO systemui"
url
=
"https://github.com/maemo-leste/osso-systemui"
arch
=
"all !armhf !armv7"
license
=
"LGPL-2.1-only"
depends_dev
=
"gtk+3.0-dev libcanberra-dev gconf-dev libosso-dev mce-headers osso-systemui-dbus-headers"
makedepends
=
"
$depends_dev
autoconf automake libtool"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/maemo-leste/osso-systemui/archive/
$pkgver
.tar.gz
osso-systemui-musl-fix.patch"
subpackages
=
"
$pkgname
-dev"
options
=
"!check"
prepare
()
{
default_prepare
sh autogen.sh
}
build
()
{
./configure
--prefix
=
/usr
make
}
package
()
{
DESTDIR
=
"
$pkgdir
"
make
install
}
sha512sums
=
"92aac73458446bfccd907f15388ec1e0d4c122b1e70d458933ca6c0739582497bc64480eec5ee9e4928627fd360854977ed9a35746f16e9c107c1a96d5e583ec osso-systemui-0.2.0.19.tar.gz
1cf4a84f44b23c51209a401a6fcddce1d1f8c19df036814ef6750552d44bebbf23a6226aeae693fb4750cfd71f9ae7aa3e44d283d97df1220569c30afab44be6 osso-systemui-musl-fix.patch"
This diff is collapsed.
Click to expand it.
maemo/osso-systemui/osso-systemui-musl-fix.patch
0 → 100644
+
27
−
0
View file @
9bd16849
From f3f317e0ed2ce0df0d19f4093fd265de55a0897f Mon Sep 17 00:00:00 2001
From: Nikita Ukhrenkov <thekit@disroot.org>
Date: Thu, 14 Nov 2019 13:47:46 +0100
Subject: [PATCH] Use pid_t instead of __pid_t to fix build with musl
---
src/systemui.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/systemui.c b/src/systemui.c
index 71ecdde..dc0ca18 100644
--- a/src/systemui.c
+++ b/src/systemui.c
@@ -272,9 +272,9 @@
check_set_callback(GArray *args, system_ui_callback_t *callback)
void daemonize()
{
- __pid_t pid = fork();
+ pid_t pid = fork();
int fd;
- char buf[2 * sizeof(__pid_t)]; /*should be large enough */
+ char buf[2 * sizeof(pid_t)]; /*should be large enough */
if (pid == -1)
ULOG_CRIT("daemonize: fork failed: %s", strerror(errno));
--
2.17.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment